Bug 220944 - misc/mc: "Verbose operation" setting disabled needlessly (patch attached)
Summary: misc/mc: "Verbose operation" setting disabled needlessly (patch attached)
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Many People
Assignee: Ben Woods
URL: https://midnight-commander.org/ticket...
Keywords:
Depends on:
Blocks:
 
Reported: 2017-07-23 13:52 UTC by Michael Bueker
Modified: 2017-07-23 15:41 UTC (History)
0 users

See Also:
woodsb02: maintainer-feedback+
woodsb02: merge-quarterly+


Attachments
bugfix patch (420 bytes, text/x-csrc)
2017-07-23 13:52 UTC, Michael Bueker
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Michael Bueker 2017-07-23 13:52:06 UTC
Created attachment 184629 [details]
bugfix patch

This bug is known upstream, but has been ignored since 2010: https://midnight-commander.org/ticket/2452

The root cause is that a function named tty_baudrate() is expected to return the terminal baudrate, but returns -1 on FreeBSD.

The attached patch (from comment #15 in the above upstream bug report) fixes the problem by disregarding negative return values for that function.
Comment 1 Ben Woods freebsd_committer 2017-07-23 15:10:19 UTC
Hi Michael,

Thanks for pointing out this issue, and for finding the fix. Looking into it now.

For the record, the text below is how you explained the problem to me in a private email:
It never saves my setting for "Verbose operation" in the "Configure" window – these are the steps to reproduce:

1. Clean install, fresh compile (see compile options below).
2. Open mc, turn on "Verbose operation" in the "Configure" window.
3. Observe that the second line in $HOME/.config/mc/ini is now "verbose=true"
4. Open mc. Observe that "Verbose operation" in the "Configure" window is turned _off_.

Other configuration options appear to work fine, but I've only tested a few.
Comment 2 Ben Woods freebsd_committer 2017-07-23 15:22:18 UTC
Hi Michael,
For the record, I cannot replicate this problem on FreeBSD 12-current with either the SLANG or NCURSES interfaces selected, even when running in the urxvt terminal as described in the mc bug #2452 (using port x11/rxvt-unicode).

Could you please let me know some details of your setup to try to replicate? Including:
- OS version
- terminal being used
- NCURSES or SLANG interface for MC selected when building the port?

I will apply this patch anyway, as it makes sense regardless.
Comment 3 commit-hook freebsd_committer 2017-07-23 15:27:25 UTC
A commit references this bug:

Author: woodsb02
Date: Sun Jul 23 15:26:37 UTC 2017
New revision: 446488
URL: https://svnweb.freebsd.org/changeset/ports/446488

Log:
  misc/mc: Fix invalid tty baudrate detection disabling verbose mode

  PR:		220944
  Submitted by:	Michael B?ker <m.bueker@berlin.de>
  Obtained from:	https://midnight-commander.org/ticket/2452#comment:15
  MFH:		2017Q3

Changes:
  head/misc/mc/Makefile
  head/misc/mc/files/patch-src_filemanager_midnight.c
Comment 4 Michael Bueker 2017-07-23 15:33:50 UTC
Hi, Ben. Here's the information you asked for:

$ freebsd-version 
11.0-RELEASE-p10

$ tail -n2 /var/db/ports/misc_mc/options 
OPTIONS_FILE_UNSET+=SLANG
OPTIONS_FILE_SET+=NCURSES

$ tty
/dev/pts/0

Since the FreeBSD box in question is a headless server, all investigations were conducted while logged in via ssh. That's probably very significant for dicussing the properties of the tty, so I'm sorry I neglected to mention it.
Comment 5 commit-hook freebsd_committer 2017-07-23 15:35:33 UTC
A commit references this bug:

Author: woodsb02
Date: Sun Jul 23 15:34:42 UTC 2017
New revision: 446490
URL: https://svnweb.freebsd.org/changeset/ports/446490

Log:
  MFH: r446488

  misc/mc: Fix invalid tty baudrate detection disabling verbose mode

  PR:		220944
  Submitted by:	Michael B?ker <m.bueker@berlin.de>
  Obtained from:	https://midnight-commander.org/ticket/2452#comment:15

  Approved by:	ports-secteam blanket

Changes:
_U  branches/2017Q3/
  branches/2017Q3/misc/mc/Makefile
  branches/2017Q3/misc/mc/files/patch-src_filemanager_midnight.c
Comment 6 Ben Woods freebsd_committer 2017-07-23 15:36:50 UTC
(In reply to m.bueker from comment #4)
Can you please also let me know which terminal you were using on the host computer that you used to ssh in, and which OS it is?
Comment 7 Michael Bueker 2017-07-23 15:41:09 UTC
The host in this case was a Linux Mint machine, running the KDE 4.11.1 with the Konsole 2.11.1 terminal. That version of KDE is quite outdated by now.