Bug 221074 - Hyper V Gen 2 install has no mouse
Summary: Hyper V Gen 2 install has no mouse
Status: New
Alias: None
Product: Base System
Classification: Unclassified
Component: misc (show other bugs)
Version: CURRENT
Hardware: amd64 Any
: --- Affects Some People
Assignee: freebsd-virtualization mailing list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-07-28 21:19 UTC by scorpionmage
Modified: 2019-05-25 19:26 UTC (History)
2 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description scorpionmage 2017-07-28 21:19:29 UTC
When FreeBSD 11.1 is installed on a Gen 2 VM, no mouse shows in the /dev directory. 

Service moused comes up with the message "unable to open /dev/psm0: No such file or directory". No mouse in X either.

Installing from the same media in a Gen 1 VM creates a /dev/psm0 and the mouse works.
Comment 1 Sepherosa Ziehau 2017-08-04 09:29:50 UTC
(In reply to scorpionmage from comment #0)

This is not planned.  If you want to use X, use VNC instead.  I use tigerVNC daily for the FreeBSD development work and of course firefox :).
Comment 2 scorpionmage 2017-08-05 23:59:31 UTC
(In reply to Sepherosa Ziehau from comment #1)
So, there will be no mouse working in X for a HyperV Gen 2 VM?
Comment 3 Sepherosa Ziehau 2017-08-07 01:23:32 UTC
(In reply to scorpionmage from comment #2)

As I said, no plan for it yet.  The Hyper-V console is _not_ suitable for X related stuffs.  And again, if you want to use X, use VNC; it is recommended and works quite well on both gen1 and gen2 Hyper-V.
Comment 4 Sepherosa Ziehau 2017-08-07 01:26:04 UTC
(In reply to scorpionmage from comment #2)

Well, if you _do_ want to stick w/ using the X on the Hyper-V console, then use gen1 VM, which has an emulated PS2 mouse.  I actually don't see gen2 VM buys anything useful for desktop users.
Comment 5 Greg V 2017-09-09 23:03:15 UTC
(In reply to Sepherosa Ziehau from comment #4)
Gen2 VM is based on UEFI and SCSI instead of BIOS and IDE. As a desktop user, I only want to use modern systems, not legacy :) The thought of using emulated IDE drives is terrifying. (VirtualBox emulates NVMe, dammit!)

I actually recommend using VcXsrv and SSH X forwarding via PuTTY. I have a little PowerShell script to launch the VM and run X apps from the VM on the Windows desktop: https://github.com/myfreeweb/xvmmgr

Still, why exactly is the Hyper-V console "_not_ suitable for X related stuffs"?
Comment 6 scorpionmage 2019-05-24 05:42:23 UTC
(In reply to Sepherosa Ziehau from comment #3)
Can you please explain why the console is not suitable? Is there a difference between the Gen 1 and Gen 2 consoles?

I am not a fan of the VNC option as now I have to get a viewer on my Windows machine as well as manage a different configuration from other Linux VMs.
Comment 7 scorpionmage 2019-05-24 05:49:40 UTC
(In reply to Greg V from comment #5)
Agree - the modern technologies are the reason. And it also allows the streamlining of configurations across Linux and FreeBSD VMs. It also allows the GPT partitioning scheme which enables creating temporary filesystem VHDXs which are then mounted by UUID and not by controller location.

Thanks for the suggestion. I have also tried xrdp, which ran into issues after an update - the port might not have a maintainer.
Comment 8 scorpionmage 2019-05-24 05:50:08 UTC
BTW, this is also happening in 12.0 and Current.
Comment 9 scorpionmage 2019-05-24 05:53:24 UTC
(In reply to Greg V from comment #5)
(In reply to scorpionmage from comment #7)
I switched to using xmonad on FreeBSD in the interim, as it lets me use X without a mouse. It does force learning lots of keyboard shortcuts, though, both for the WM and the applications :-(