Bug 221109 - [NEW PORT] sysutils/dsblogoutmgr: Graphical logout manager
Summary: [NEW PORT] sysutils/dsblogoutmgr: Graphical logout manager
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Richard Gallamore
URL: http://freeshell.de/~mk/projects/dsbl...
Keywords: feature
Depends on:
Blocks:
 
Reported: 2017-07-30 23:37 UTC by Marcel Kaiser
Modified: 2017-08-09 15:37 UTC (History)
2 users (show)

See Also:
koobs: maintainer-feedback+


Attachments
svn diff of the new port. (2.73 KB, patch)
2017-07-30 23:37 UTC, Marcel Kaiser
no flags Details | Diff
svn diff of the new port. (3.08 KB, patch)
2017-08-01 10:55 UTC, Marcel Kaiser
no flags Details | Diff
svn diff of the new port. (3.46 KB, patch)
2017-08-01 11:08 UTC, Marcel Kaiser
no flags Details | Diff
svn diff of the new port. (4.25 KB, patch)
2017-08-06 21:59 UTC, Marcel Kaiser
mk: maintainer-approval+
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Marcel Kaiser 2017-07-30 23:37:04 UTC
Created attachment 184859 [details]
svn diff of the new port.

DSBLogoutmgr is a Qt utility that allows you to leave your current window
manager-session, reboot, suspend or shutdown your system. Furthermore, it
supports time-controlled shutdown.

WWW: http://freeshell.de/~mk/projects/dsblogoutmgr.html
---

portlint: OK (looks fine.)
testport: OK (poudriere: 110Ramd64, 103Ri386)
Comment 1 Kubilay Kocak freebsd_committer freebsd_triage 2017-08-01 09:10:59 UTC
Thank you for contributing a new port to FreeBSD Marcel.

Since this is a new port provided in diff format, please include the addition of the port to its respective category/Makefile (sysutils/Makefile in this case).
Comment 2 Marcel Kaiser 2017-08-01 10:55:59 UTC
Created attachment 184894 [details]
svn diff of the new port.
Comment 3 Kubilay Kocak freebsd_committer freebsd_triage 2017-08-01 10:59:32 UTC
It appears the new sysutils/Makefile: SUBDIR+=dsblogoutmgr entry changes are missing from the latest patch
Comment 4 Marcel Kaiser 2017-08-01 11:08:32 UTC
Created attachment 184896 [details]
svn diff of the new port.
Comment 5 Marcel Kaiser 2017-08-01 11:11:05 UTC
Hello Kubilay,

thank you for your help. I hope the new diff will do the trick.
Comment 6 Kubilay Kocak freebsd_committer freebsd_triage 2017-08-01 11:12:58 UTC
Looks good Marcel, thank you and you're welcome

I believe the other issue you recently submitted also needs the category/Makefile: SUBDIR addition
Comment 7 Marcel Kaiser 2017-08-01 11:56:48 UTC
Excellent. Thank you.

I uploaded the corrected diff for x11/dsbautostart.
Comment 8 Richard Gallamore freebsd_committer 2017-08-06 06:15:18 UTC
Looks like this port also requires the runtime depend, fluxbox for the logging out.

The sleep feature also fails with acpiconf: request sleep type (3) failed: Operation not permitted, this is probably because I have this state disabled though.

Also when starting on occasion the screen will dim and the option window doesn't appear.

the buildtools is probably a build depend and not runtime depend, please try adding buildtools_run to change to runtime depends, the same applies with x11/dsbautostart.
Comment 9 Marcel Kaiser 2017-08-06 11:54:18 UTC
Hello Richard,

thanks for taking the time, and for your feedback!

The Fluxbox and acpiconf entries are default/example values. It's up to the user to define commands that fit their needs. The manual page contains a SETUP section with tips on how to handle permission restrictions, and example commands to log out from an Openbox and a Fluxbox session. Should I better add a note to pkg-message?

Can you make the menu window appear by e.g. using <Alt>+<Tab>?

Best regards,
Marcel
Comment 10 Richard Gallamore freebsd_committer 2017-08-06 14:33:35 UTC
(In reply to Marcel Kaiser from comment #9)
I made an error in my last message suggesting add _run, and should have been _build.


Thanks for clarification, yes it would best to provide a pkg-message suggesting configuration steps.

<Alt>+<Tab> will change to other windows, but does not change this program's window from spawning. From what I can tell it occurs about 50% of the time when ran. I'm not sure how it is being triggered, I am running it through terminal with no option switches or args under regular user.
Comment 11 Marcel Kaiser 2017-08-06 21:54:30 UTC
That's odd. I've never experienced this behavior (main window not showing) before. So I tried executing it over and over again, with random delays between each execution:

perl -e 'use Time::HiRes qw(usleep); $x=`dd if=/dev/random bs=1 count=4`; srand(unpack("B*", $x) % 1000000);for ($i = 0; $i < 50; $i++) { usleep(int(rand(3000000))); system("./dsblogoutmgr"); }'

That way, I could reproduce the behavior you describe. The problem occurred not more than 3 times each run (50 executions). With Fluxbox I could reproduce it a few times (ran it > 500 times), with KDE 4 (> 50 executions) only once, and with Openbox (> 50 executions) not a single time.

However, I couldn't reproduce it after changing the part where the window hint- flags are set. Hope this solves the problem.
Comment 12 Marcel Kaiser 2017-08-06 21:59:01 UTC
Created attachment 185106 [details]
svn diff of the new port.
Comment 13 Richard Gallamore freebsd_committer 2017-08-06 22:56:10 UTC
(In reply to Marcel Kaiser from comment #11)
Currently using the area51 kde branch which is known be a bit experimental, so this could be on my end. Sorry for not making this clear up front and thank you for looking into it. Probably is fine if its occurring that few of times with that much testing.
Comment 14 Marcel Kaiser 2017-08-06 23:10:27 UTC
I glad you pointed that out. It shows that there is/was something wrong.

Thank you for your help.
Comment 15 commit-hook freebsd_committer 2017-08-09 07:45:22 UTC
A commit references this bug:

Author: ultima
Date: Wed Aug  9 07:45:03 UTC 2017
New revision: 447594
URL: https://svnweb.freebsd.org/changeset/ports/447594

Log:
  DSBLogoutmgr is a Qt utility that allows you to leave your current window
  manager-session, reboot, suspend or shutdown your system. Furthermore, it
  supports time-controlled shutdown.

  WWW: http://freeshell.de/~mk/projects/dsblogoutmgr.html

  PR:		221109
  Submitted by:	Marcel Kaiser (maintainer)
  Reviewed by:	matthew (mentor)
  Approved by:	matthew (mentor)
  Differential Revision:	https://reviews.freebsd.org/D11930

Changes:
  head/sysutils/Makefile
  head/sysutils/dsblogoutmgr/
  head/sysutils/dsblogoutmgr/Makefile
  head/sysutils/dsblogoutmgr/distinfo
  head/sysutils/dsblogoutmgr/pkg-descr
  head/sysutils/dsblogoutmgr/pkg-message
  head/sysutils/dsblogoutmgr/pkg-plist
Comment 16 Richard Gallamore freebsd_committer 2017-08-09 07:49:05 UTC
(In reply to Marcel Kaiser from comment #14)
Not a problem, and thank you for the port.
Comment 17 Marcel Kaiser 2017-08-09 15:37:32 UTC
Thank you for the commit!