Bug 221376 - 12.0-RELEASE amd64: any kernel fail to boot - freezes just after run kernel
Summary: 12.0-RELEASE amd64: any kernel fail to boot - freezes just after run kernel
Status: Closed Overcome By Events
Alias: None
Product: Base System
Classification: Unclassified
Component: kern (show other bugs)
Version: 12.0-RELEASE
Hardware: amd64 Any
: --- Affects Only Me
Assignee: freebsd-bugs mailing list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-08-09 17:32 UTC by VVD
Modified: 2019-11-17 02:36 UTC (History)
4 users (show)

See Also:


Attachments
dmesg with custom kernel (14.93 KB, text/plain)
2017-08-09 17:32 UTC, VVD
no flags Details
"bad" dmesg (12.48 KB, text/plain)
2017-08-09 17:33 UTC, VVD
no flags Details
dmesg from boot -v with GENERIC kernel 11.2-RELEASE-p8 amd64 (54.04 KB, text/plain)
2019-02-12 16:13 UTC, VVD
no flags Details
Photo of screen from boot -v with kernel 12.0-RELEASE-p3 amd64 (546.86 KB, image/jpeg)
2019-02-12 16:16 UTC, VVD
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description VVD 2017-08-09 17:32:05 UTC
Created attachment 185211 [details]
dmesg with custom kernel

11.1 amd64.

Few lines from dmidecode:
Base Board Information
        Manufacturer: ASUSTeK Computer INC.
        Product Name: P5GD2-Deluxe
Processor Information
        Socket Designation: Socket 775
        Type: Central Processor
        Family: Pentium 4
        Manufacturer: Intel            
        ID: 43 0F 00 00 FF FB EB BF
        Signature: Type 0, Family 15, Model 4, Stepping 3
        Version: Intel(R) Pentium(R) 4 CPU 3.00GHz                   
        Voltage: 1.4 V
        External Clock: 200 MHz
        Max Speed: 3600 MHz
        Current Speed: 3000 MHz

Compiled self with option CPUTYPE?=nocona in /etc/make.conf GENERIC kernel run fine (dmesg.good). Without it during boot system freeze or freeze for 1 minute and then reboot in 90% tries after detect cd0 (no real dmesg, but I edit good dmesg to look same as real messages in console - dmesg.bad).
Comment 1 VVD 2017-08-09 17:33:21 UTC
Created attachment 185212 [details]
"bad" dmesg
Comment 2 VVD 2017-08-09 18:32:39 UTC
GENERIC 11.0 from installation media boot fine.
Comment 3 VVD 2017-08-10 17:47:26 UTC
/boot/loader.conf:
zfs_load="YES"
autoboot_delay="5"
loader_logo="beastie"
vfs.zfs.prefetch_disable="1"
smbus_load="YES"
ichsmb_load="YES"
firewire_load="YES"
Comment 4 VVD 2019-02-12 16:13:41 UTC
Created attachment 201960 [details]
dmesg from boot -v with GENERIC kernel 11.2-RELEASE-p8 amd64

11.2 GENERIC kernel from freebsd-update boot fine.
But any 12.0 kernel freezes just after start.
Comment 5 VVD 2019-02-12 16:16:01 UTC
Created attachment 201961 [details]
Photo of screen from boot -v with kernel 12.0-RELEASE-p3 amd64
Comment 6 Rodney W. Grimes freebsd_committer 2019-02-13 01:51:34 UTC
Please do not put bugs on stable@, current@, hackers@, etc
Placing this bug back on bugs@ to be triaged properly to a technical list
Comment 7 VVD 2019-02-27 23:55:27 UTC
Kernel from config MINIMAL freezes too just after start.
What can I do to find the cause?
Comment 8 VVD 2019-04-01 14:48:32 UTC
Why target-cpu detected as k6-3?

$ cc -march=native -E -v - </dev/null
FreeBSD clang version 6.0.0 (tags/RELEASE_600/final 326565) (based on LLVM 6.0.0)
Target: x86_64-unknown-freebsd11.2
Thread model: posix
InstalledDir: /usr/bin
 "/usr/bin/cc" -cc1 -triple x86_64-unknown-freebsd11.2 -E -disable-free -disable-llvm-verifier -discard-value-names -main-file-name - -mrelocation-model static -mthread-model posix -mdisable-fp-elim -masm-verbose -mconstructor-aliases -munwind-tables -target-cpu k6-3 -target-feature +sse2 -target-feature +cx16 -target-feature -tbm -target-feature -avx512ifma -target-feature -gfni -target-feature -sha -target-feature -fma4 -target-feature -vpclmulqdq -target-feature -prfchw -target-feature -bmi2 -target-feature -xsavec -target-feature -fsgsbase -target-feature -popcnt -target-feature -aes -target-feature -avx512bitalg -target-feature -xsaves -target-feature -avx512er -target-feature -avx512vnni -target-feature -avx512vpopcntdq -target-feature -clwb -target-feature -avx512f -target-feature -clzero -target-feature -pku -target-feature +mmx -target-feature -lwp -target-feature -xop -target-feature -rdseed -target-feature -ibt -target-feature -sse4a -target-feature -avx512bw -target-feature -clflushopt -target-feature -xsave -target-feature -avx512vbmi2 -target-feature -avx512vl -target-feature -avx512cd -target-feature -avx -target-feature -vaes -target-feature -rtm -target-feature -fma -target-feature -bmi -target-feature -rdrnd -target-feature -mwaitx -target-feature -sse4.1 -target-feature -sse4.2 -target-feature -avx2 -target-feature +sse -target-feature -lzcnt -target-feature -pclmul -target-feature -prefetchwt1 -target-feature -f16c -target-feature -ssse3 -target-feature -sgx -target-feature -shstk -target-feature +cmov -target-feature -avx512vbmi -target-feature -movbe -target-feature -xsaveopt -target-feature -avx512dq -target-feature -adx -target-feature -avx512pf -target-feature +sse3 -dwarf-column-info -debugger-tuning=gdb -v -resource-dir /usr/lib/clang/6.0.0 -fdebug-compilation-dir /tmp -ferror-limit 19 -fmessage-length 128 -fobjc-runtime=gnustep -fdiagnostics-show-option -fcolor-diagnostics -o - -x c -
error: unknown target CPU 'k6-3'
Comment 9 roel 2019-05-23 10:43:49 UTC
This is the same issue as is reported in (amongst others) https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=235017 and https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=233534.

The issue is widespread and seems to be caused by incompatible hardware.
Comment 10 VVD 2019-09-06 23:19:59 UTC
(In reply to roel from comment #9)
1st look same, yes.

BTW, clang 8 detect CPU as nocona in FreeBSD 11.3:
$ cc -march=native -E -v - </dev/null
FreeBSD clang version 8.0.0 (tags/RELEASE_800/final 356365) (based on LLVM 8.0.0)
Target: x86_64-unknown-freebsd11.3
Thread model: posix
InstalledDir: /usr/bin
 "/usr/bin/cc" -cc1 -triple x86_64-unknown-freebsd11.3 -E -disable-free -disable-llvm-verifier -discard-value-names -main-file-name - -mrelocation-model static -mthread-model posix -mdisable-fp-elim -masm-verbose -mconstructor-aliases -munwind-tables -target-cpu nocona -target-feature +sse2 -target-feature +cx16 -target-feature -sahf -target-feature -tbm -target-feature -avx512ifma -target-feature -sha -target-feature -gfni -target-feature -fma4 -target-feature -vpclmulqdq -target-feature -prfchw -target-feature -bmi2 -target-feature -cldemote -target-feature -fsgsbase -target-feature -ptwrite -target-feature -xsavec -target-feature -popcnt -target-feature -aes -target-feature -avx512bitalg -target-feature -movdiri -target-feature -xsaves -target-feature -avx512er -target-feature -avx512vnni -target-feature -avx512vpopcntdq -target-feature -pconfig -target-feature -clwb -target-feature -avx512f -target-feature -clzero -target-feature -pku -target-feature +mmx -target-feature -lwp -target-feature -rdpid -target-feature -xop -target-feature -rdseed -target-feature -waitpkg -target-feature -movdir64b -target-feature -sse4a -target-feature -avx512bw -target-feature -clflushopt -target-feature -xsave -target-feature -avx512vbmi2 -target-feature +64bit -target-feature -avx512vl -target-feature -invpcid -target-feature -avx512cd -target-feature -avx -target-feature -vaes -target-feature -rtm -target-feature -fma -target-feature -bmi -target-feature -rdrnd -target-feature -mwaitx -target-feature -sse4.1 -target-feature -sse4.2 -target-feature -avx2 -target-feature -wbnoinvd -target-feature +sse -target-feature -lzcnt -target-feature -pclmul -target-feature -prefetchwt1 -target-feature -f16c -target-feature -ssse3 -target-feature -sgx -target-feature -shstk -target-feature +cmov -target-feature -avx512vbmi -target-feature -movbe -target-feature -xsaveopt -target-feature -avx512dq -target-feature -adx -target-feature -avx512pf -target-feature +sse3 -dwarf-column-info -debugger-tuning=gdb -v -resource-dir /usr/lib/clang/8.0.0 -fdebug-compilation-dir /root -ferror-limit 19 -fmessage-length 128 -fobjc-runtime=gnustep -fdiagnostics-show-option -fcolor-diagnostics -o - -x c - -faddrsig
Comment 11 VVD 2019-11-17 02:36:50 UTC
12.1 boot fine on this hardware.