Bug 221622 - graphics/qgis: dies on signal 11
Summary: graphics/qgis: dies on signal 11
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: freebsd-ports-bugs (Nobody)
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-08-19 06:43 UTC by Martin Birgmeier
Modified: 2017-11-19 20:49 UTC (History)
2 users (show)

See Also:
bugzilla: maintainer-feedback? (rhurlin)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Martin Birgmeier 2017-08-19 06:43:16 UTC
Scenario:
- FreeBSD 11.1
- All ports recompiled for it
- Starting qgis
- Opening an new project

Result:
- After about 30 seconds, qgis dies on a signal 11; gdb is started automatically (why?)
- both the amd64 and i386 versions crash in the same way

This may have to do with consistent problems I have in building py-matplotlib for amd64; I can get it building on one machine, whereas on my main build machine the build always stops, also with a signal 11.

Console output of qgis start:

[0]% qgis  
Warning: loading of qgis translation failed [/usr/local/share/qgis/i18n//qgis_en_US]
Warning: loading of qt translation failed [/usr/local/share/qt4/translations/qt_en_US]
Warning: QCss::Parser - Failed to load file  "/style.qss" 
Warning: QLayout: Attempting to add QLayout "" to QgsPanelWidgetStack "mWidgetStack", which already has a layout
kfilemodule(1779) KSambaSharePrivate::testparmParamValue: We got some errors while running testparm "Load smb config files from /usr/local/etc/smb4.conf
Error loading services.
" 
kfilemodule(1779) KSambaSharePrivate::findSmbConf: KSambaShare: Could not find smb.conf! 
kfilemodule(1779) KSambaSharePrivate::getNetUserShareInfo: We got some errors while running 'net usershare info' 
kfilemodule(1779) KSambaSharePrivate::getNetUserShareInfo: "Can't load /usr/local/etc/smb4.conf - run testparm to debug it
" 
QGIS died on signal 11QGIS died on signal 11(no debugging symbols found)...(no debugging symbols found)...ptrace: Device busy.
/z/users/martin/1779: No such file or directory.
(no debugging symbols found)...Error while reading shared library symbols:
Dwarf Error: wrong version in compilation unit header (is 4, should be 2) [in module /usr/local/lib/gcc5/libgcc_s.so.1]

warning: Lowest section in /usr/local/lib/libicudata.so.58 is .hash at 0000000000000120
Error while reading shared library symbols:
Dwarf Error: wrong version in compilation unit header (is 4, should be 2) [in module /usr/local/lib/gcc5/libgfortran.so.3]
Error while reading shared library symbols:
Dwarf Error: wrong version in compilation unit header (is 4, should be 2) [in module /usr/local/lib/gcc5/libquadmath.so.0]
0x000000080b35e58a in _poll () from /lib/libc.so.7
zsh: killed     qgis
qgis  14.89s user 3.19s system 28% cpu 1:04.11 total
[137]% 

Console output of trying to build py-matplotlib:

[0]# portmaster py27-matplotlib-1.5.3_2 

===>>> Currently installed version: py27-matplotlib-1.5.3_2
===>>> Port directory: /.../hal/z/SRC/FreeBSD-ports/head/math/py-matplotlib

===>>> Launching 'make checksum' for math/py-matplotlib in background
===>>> Gathering dependency list for math/py-matplotlib from ports
===>>> Initial dependency check complete for math/py-matplotlib


===>>> Starting build for math/py-matplotlib <<<===

===>>> All dependencies are up to date

===>  License PSFL accepted by the user
===>   py27-matplotlib-1.5.3_2 depends on file: /usr/local/sbin/pkg - found
===> Fetching all distfiles required by py27-matplotlib-1.5.3_2 for building
===>  Extracting for py27-matplotlib-1.5.3_2
=> SHA256 Checksum OK for matplotlib-matplotlib-v1.5.3_GH0.tar.gz.
/usr/bin/find /usr/tmp/.../hal/z/SRC/FreeBSD-ports/head/math/py-matplotlib/work/matplotlib-1.5.3 -name \*.py | /usr/bin/xargs /bin/chmod -x
===>  Patching for py27-matplotlib-1.5.3_2
===>  Applying FreeBSD patches for py27-matplotlib-1.5.3_2
/usr/bin/sed -i.bak -e 's|/usr/local|/usr/local|g'  -e 's|%%TCL_INCLUDEDIR%%|/usr/local/include/tcl8.6|g'  -e 's|%%TK_INCLUDEDIR%%|/usr/local/include/tk8.6|g'  -e 's|%%TCL_LIBDIR%%|/usr/local/lib/tcl8.6|g'  -e 's|%%TK_LIBDIR%%|/usr/local/lib/tk8.6|g'  -e 's|%%TCL_VER%%|86|g'  -e 's|%%TK_VER%%|86|g'  /usr/tmp/.../hal/z/SRC/FreeBSD-ports/head/math/py-matplotlib/work/matplotlib-1.5.3/setupext.py
/usr/bin/sed -i.bak -e 's|%%GTK_BACKEND%%|True|g'  -e 's|%%GTKAGG_BACKEND%%|True|g'  -e 's|%%QT4AGG_BACKEND%%|False|g'  -e 's|%%QT5AGG_BACKEND%%|False|g'  -e 's|%%TKAGG_BACKEND%%|True|g'  -e 's|%%WXAGG_BACKEND%%|False|g'  /usr/tmp/.../hal/z/SRC/FreeBSD-ports/head/math/py-matplotlib/work/matplotlib-1.5.3/setup.cfg
===>   py27-matplotlib-1.5.3_2 depends on file: /usr/local/lib/python2.7/site-packages/numpy/core/numeric.py - found
===>   py27-matplotlib-1.5.3_2 depends on package: py27-tkinter>0 - found
===>   py27-matplotlib-1.5.3_2 depends on executable: msgfmt - found
===>   py27-matplotlib-1.5.3_2 depends on package: pkgconf>=1.3.0_1 - found
===>   py27-matplotlib-1.5.3_2 depends on package: py27-setuptools>0 - found
===>   py27-matplotlib-1.5.3_2 depends on file: /usr/local/bin/python2.7 - found
===>   py27-matplotlib-1.5.3_2 depends on executable: pygobject-codegen-2.0 - found
===>   py27-matplotlib-1.5.3_2 depends on file: /usr/local/libdata/pkgconfig/pygtk-2.0.pc - found
===>   py27-matplotlib-1.5.3_2 depends on shared library: libfreetype.so - found (/usr/local/lib/libfreetype.so)
===>   py27-matplotlib-1.5.3_2 depends on shared library: libpng.so - found (/usr/local/lib/libpng.so)
===>   py27-matplotlib-1.5.3_2 depends on shared library: libfontconfig.so - found (/usr/local/lib/libfontconfig.so)
===>   py27-matplotlib-1.5.3_2 depends on shared library: libtcl86.so - found (/usr/local/lib/libtcl86.so)
===>   py27-matplotlib-1.5.3_2 depends on shared library: libintl.so - found (/usr/local/lib/libintl.so)
===>   py27-matplotlib-1.5.3_2 depends on shared library: libatk-1.0.so - found (/usr/local/lib/libatk-1.0.so)
===>   py27-matplotlib-1.5.3_2 depends on shared library: libcairo.so - found (/usr/local/lib/libcairo.so)
===>   py27-matplotlib-1.5.3_2 depends on shared library: libgdk_pixbuf-2.0.so - found (/usr/local/lib/libgdk_pixbuf-2.0.so)
===>   py27-matplotlib-1.5.3_2 depends on shared library: libglib-2.0.so - found (/usr/local/lib/libglib-2.0.so)
===>   py27-matplotlib-1.5.3_2 depends on shared library: libintl.so - found (/usr/local/lib/libintl.so)
===>   py27-matplotlib-1.5.3_2 depends on shared library: libgtk-x11-2.0.so - found (/usr/local/lib/libgtk-x11-2.0.so)
===>   py27-matplotlib-1.5.3_2 depends on shared library: libglade-2.0.so - found (/usr/local/lib/libglade-2.0.so)
===>   py27-matplotlib-1.5.3_2 depends on shared library: libxml2.so - found (/usr/local/lib/libxml2.so)
===>   py27-matplotlib-1.5.3_2 depends on shared library: libpango-1.0.so - found (/usr/local/lib/libpango-1.0.so)
===>  Configuring for py27-matplotlib-1.5.3_2
============================================================================
Edit setup.cfg to change the build options

BUILDING MATPLOTLIB
            matplotlib: yes [1.5.3]
                python: yes [2.7.13 (default, Aug  3 2017, 19:15:56)  [GCC
                        4.2.1 Compatible FreeBSD Clang 4.0.0
                        (tags/RELEASE_400/final 297347)]]
              platform: yes [freebsd11]

REQUIRED DEPENDENCIES AND EXTENSIONS
                 numpy: yes [version 1.13.1]
              dateutil: yes [using dateutil version 2.6.1]
                  pytz: yes [using pytz version 2017.2]
                cycler: yes [using cycler version 0.10.0]
               tornado: yes [using tornado version 4.5.1]
             pyparsing: yes [using pyparsing version 2.2.0]
                libagg: yes [pkg-config information for 'libagg' could not
                        be found. Using local copy.]
              freetype: yes [version 2.8.0]
                   png: yes [version 1.6.31]
                 qhull: yes [pkg-config information for 'qhull' could not be
                        found. Using local copy.]

OPTIONAL SUBPACKAGES
           sample_data: yes [installing]
              toolkits: yes [installing]
                 tests: yes [nose 0.11.1 or later is required to run the
                        matplotlib test suite. Please install it with pip or
                        your preferred tool to run the test suite / using
                        mock 2.0.0]
        toolkits_tests: yes [nose 0.11.1 or later is required to run the
                        matplotlib test suite. Please install it with pip or
                        your preferred tool to run the test suite / using
                        mock 2.0.0]

OPTIONAL BACKEND EXTENSIONS
                macosx: no  [Mac OS-X only]
                qt5agg: no  [skipping due to configuration]
                qt4agg: no  [skipping due to configuration]
               gtk3agg: no  [Requires pygobject to be installed.]
*** Signal 11

Stop.
make[1]: stopped in /.../hal/z/SRC/FreeBSD-ports/head/math/py-matplotlib
*** Error code 1

Stop.
make: stopped in /.../hal/z/SRC/FreeBSD-ports/head/math/py-matplotlib

===>>> make build failed for math/py-matplotlib
===>>> Aborting update


===>>> You can restart from the point of failure with this command line:
       portmaster <flags> math/py-matplotlib 

This command has been saved to /tmp/portmasterfail.txt

[1]#
Comment 1 Rainer Hurling freebsd_committer 2017-08-20 08:28:08 UTC
Hi Martin,

Thanks for the report.

On CURRENT I am not able to reproduce crashes in that way, as described by you. 

But there are other problems with stability. For example, during intensive zooming or switching the focus from one application to another an back, QGIS dies frequently. The behaviour seems similar to [1][2]. For me, removing config files at ~/.qgis2 and ~/.config/QGIS does not help. Also, building QGIS without math/py-matplotlib does not help.

Unfortunately, I have no clue, what to do next. It is likely, that there is something odd with qt4 and/or its plugins.


[1] https://gis.stackexchange.com/questions/230576/qgis-crashes-frequently-since-upgrading-to-2-18-2-on-mac
[2] https://gis.stackexchange.com/questions/234853/qgis-quit-unexpectedly-at-startup-on-mac
Comment 2 Martin Birgmeier 2017-09-16 09:42:30 UTC
See bug #221880.
Comment 3 Loïc Bartoletti freebsd_committer 2017-09-17 13:25:34 UTC
Hi Martin and Rainer,

I can reproduce the problem on 11.1 amd64.

Yes it's again a problem with gcc/fortran etc...

Regards.
Comment 4 Loïc Bartoletti freebsd_committer 2017-09-24 07:05:17 UTC
Maybe, it's related with #222539
Comment 5 Martin Birgmeier 2017-09-24 09:13:38 UTC
I tried to run qgis with this LD_LIBRARY_PATH as well as to compile math/py-matplotlib, albeit with no improvement.
Comment 6 Martin Birgmeier 2017-11-17 15:25:14 UTC
QGIS works again. Probably due to the latest gcc changes.
Comment 7 Rainer Hurling freebsd_committer 2017-11-17 20:41:24 UTC
(In reply to Martin Birgmeier from comment #6)

Hi Martin,

Thanks for the update and nice to hear about QGIS working again on your side. 

Could you report some infos like OS version, installed versions of math/py-numpy, lang/gcc and graphics/qgis?
Comment 8 Martin Birgmeier 2017-11-18 14:44:33 UTC
These are the currently installed packages relating to qgis:

graphics/qgis                            qgis-2.18.12_1
databases/py-qt4-sql                     py27-qt4-sql-4.12,1
devel/py-qt4-qscintilla2                 py27-qt4-qscintilla2-2.9.1,1
graphics/py-qt4-svg                      py27-qt4-svg-4.12,1
www/py-qt4-webkit                        py27-qt4-webkit-4.12
net/py-qt4-network                       py27-qt4-network-4.12,1
textproc/py-qt4-xml                      py27-qt4-xml-4.12,1
x11-toolkits/py-qt4-gui                  py27-qt4-gui-4.12,1
devel/py-qt4-core                        py27-qt4-core-4.12_2,1
devel/qscintilla2                        qscintilla2-2.9.1,1
devel/qca                                qca-2.1.1_1
devel/qt4-designer                       qt4-designer-4.8.7_1
devel/qt4-assistant                      qt4-assistant-4.8.7_1
math/py-matplotlib                       py27-matplotlib-1.5.3_3
security/gnupg                           gnupg-2.2.2
security/pinentry                        pinentry-1.0.0_3
www/qt4-webkit                           qt4-webkit-4.8.7_2
x11-toolkits/py-gtk2                     py27-gtk2-2.24.0_4
devel/libglade2                          libglade2-2.6.4_8
graphics/qt4-iconengines                 qt4-iconengines-4.8.7_2
graphics/qt4-imageformats                qt4-imageformats-4.8.7_2
security/pinentry-gtk2                   pinentry-gtk2-1.0.0
x11-toolkits/qt4-declarative             qt4-declarative-4.8.7_1
x11-toolkits/qwt5                        qwt5-5.2.3
devel/qt4-help                           qt4-help-4.8.7_2
devel/qt4-qt3support                     qt4-qt3support-4.8.7_2
graphics/qt4-opengl                      qt4-opengl-4.8.7_3
graphics/qt4-svg                         qt4-svg-4.8.7_2
x11-toolkits/gtk20                       gtk2-2.24.31
x11/qt4-inputmethods                     qt4-inputmethods-4.8.7_2
graphics/gtk-update-icon-cache           gtk-update-icon-cache-2.24.29
x11-toolkits/qt4-gui                     qt4-gui-4.8.7_3
graphics/py-gdal                         py27-gdal-2.2.2
multimedia/gstreamer-plugins             gstreamer-plugins-0.10.36_8,3
print/cups                               cups-2.2.6
x11-toolkits/pango                       pango-1.40.6
accessibility/atk                        atk-2.24.0
devel/py-gobject                         py27-gobject-2.28.6_7
graphics/gdal                            gdal-2.2.2_1
graphics/gdk-pixbuf2                     gdk-pixbuf2-2.36.9
multimedia/gstreamer                     gstreamer-0.10.36_6
net/avahi-app                            avahi-app-0.6.31_5
print/harfbuzz                           harfbuzz-1.5.1_1
security/libsecret                       libsecret-0.18.5
devel/gobject-introspection              gobject-introspection-1.50.0,1
graphics/poppler                         poppler-0.57.0
graphics/py-cairo                        py27-cairo-1.14.1
devel/xdg-utils                          xdg-utils-1.1.1
graphics/cairo                           cairo-1.14.8_1,2
x11-toolkits/py-tkinter                  py27-tkinter-2.7.14_6
graphics/mesa-libs                       mesa-libs-17.2.4
x11-toolkits/tk86                        tk86-8.6.7
x11/xprop                                xprop-1.2.2
x11/xset                                 xset-1.2.3_1
devel/dbus-glib                          dbus-glib-0.108
x11-fonts/libXfontcache                  libXfontcache-1.0.5_3
x11-fonts/libXft                         libXft-2.3.2_1
x11-toolkits/libXmu                      libXmu-1.1.2_3,1
x11/libXcomposite                        libXcomposite-0.4.4_3,1
x11/libXcursor                           libXcursor-1.1.14_4
x11/libXdamage                           libXdamage-1.1.4_3
x11/libXi                                libXi-1.7.9,1
x11/libXinerama                          libXinerama-1.1.3_3,1
x11/libXrandr                            libXrandr-1.5.1
x11/libXScrnSaver                        libXScrnSaver-1.2.2_3
x11/libXv                                libXv-1.0.11,1
x11/libXxf86vm                           libXxf86vm-1.1.4_1
databases/mysql57-client                 mysql57-client-5.7.20_1
devel/dbus                               dbus-1.10.16_1
devel/llvm40                             llvm40-4.0.1_4
devel/qjson                              qjson-0.9.0
graphics/graphite2                       graphite2-1.3.10
graphics/openjpeg                        openjpeg-2.3.0
math/py-numpy                            py27-numpy-1.13.3,1
science/libkml                           libkml-1.3.0_5
x11-toolkits/libXt                       libXt-1.1.5,1
x11/libXext                              libXext-1.3.3_1,1
x11/libXfixes                            libXfixes-5.0.3
x11/libXrender                           libXrender-0.9.10
x11/xcb-util-renderutil                  xcb-util-renderutil-0.3.9_1
devel/py-mock                            py27-mock-2.0.0
math/suitesparse                         suitesparse-4.0.2_7
x11/libX11                               libX11-1.6.5,1
x11/xcb-util                             xcb-util-0.4.0_2,1
devel/py-pbr                             py27-pbr-3.1.1
ftp/curl                                 curl-7.56.1
math/openblas                            openblas-0.2.20_1,1
www/py-requests                          py27-requests-2.18.1_1
x11/libxcb                               libxcb-1.12_2
archivers/minizip                        minizip-1.2.11
databases/qt4-pgsql-plugin               qt4-psql-plugin-4.8.7_3
databases/qt4-sqlite3-plugin             qt4-sqlite-plugin-4.8.7_4
devel/googletest                         googletest-1.8.0.358
devel/json-c                             json-c-0.12.1
devel/libevent                           libevent-2.1.8
devel/protobuf                           protobuf-3.4.1
devel/py-pip                             py27-pip-9.0.1
lang/gcc6                                gcc6-6.4.0_3
net/py-urllib3                           py27-urllib3-1.22
security/nss                             nss-3.34
textproc/qt4-xmlpatterns                 qt4-xmlpatterns-4.8.7_2
www/libnghttp2                           libnghttp2-1.27.0
databases/qt4-sql                        qt4-sql-4.8.7_2
devel/binutils                           binutils-2.28,1
devel/qt4-script                         qt4-script-4.8.7_2
devel/qt4-testlib                        qt4-testlib-4.8.7_2
graphics/libmng                          libmng-1.0.10_3
lang/vala                                vala-0.30.2
math/mpc                                 mpc-1.0.3
net/qt4-network                          qt4-network-4.8.7_3
security/gnutls                          gnutls-3.5.16
security/py-openssl                      py27-openssl-17.3.0
textproc/qt4-clucene                     qt4-clucene-4.8.7_1
textproc/qt4-xml                         qt4-xml-4.8.7_2
x11-fonts/xorg-fonts-truetype            xorg-fonts-truetype-7.7_1
devel/py-Jinja2                          py27-Jinja2-2.9.5
devel/qt4-corelib                        qt4-corelib-4.8.7_10
graphics/lcms                            lcms-1.19_6,1
graphics/lcms2                           lcms2-2.8
graphics/libgeotiff                      libgeotiff-1.4.2
math/mpfr                                mpfr-3.1.6
security/nettle                          nettle-3.3
security/py-cryptography                 py27-cryptography-2.0.3
textproc/libxslt                         libxslt-1.1.29_1
textproc/py-chardet                      py27-chardet-3.0.4
www/py-tornado                           py27-tornado-4.5.2
x11-fonts/dejavu                         dejavu-2.37
x11-fonts/font-bh-ttf                    font-bh-ttf-1.0.3_3
x11-fonts/font-misc-ethiopic             font-misc-ethiopic-1.0.3_3
x11-fonts/font-misc-meltho               font-misc-meltho-1.0.3_3
databases/pyspatialite                   py27-pyspatialite-3.0.1_7
devel/py-babel                           py27-Babel-2.3.4
devel/py-cffi                            py27-cffi-1.7.0
devel/py-cycler                          py27-cycler-0.10.0
devel/py-dateutil                        py27-dateutil-2.6.1
devel/py-singledispatch                  py27-singledispatch-3.4.0.3_1
graphics/jasper                          jasper-1.900.1_17
graphics/tiff                            tiff-4.0.8
math/gmp                                 gmp-6.1.2
security/libgcrypt                       libgcrypt-1.8.1
x11-fonts/encodings                      encodings-1.0.4_3,1
x11-fonts/mkfontdir                      mkfontdir-1.0.7
archivers/libarchive                     libarchive-3.3.2,1
astro/cfitsio                            cfitsio-3.420
databases/py-psycopg2                    py27-psycopg2-2.7.3.2
databases/py-sqlite3                     py27-sqlite3-2.7.14_7
databases/spatialite                     spatialite-4.3.0
devel/boost-libs                         boost-libs-1.65.1_1
devel/desktop-file-utils                 desktop-file-utils-0.23
devel/py-asn1crypto                      py27-asn1crypto-0.22.0
devel/py-backports_abc                   py27-backports_abc-0.5
devel/py-enum34                          py27-enum34-1.1.6
devel/py-funcsigs                        py27-funcsigs-1.0.2
devel/py-functools32                     py27-functools32-3.2.3
devel/py-future                          py27-future-0.16.0
devel/py-pycparser                       py27-pycparser-2.10
devel/py-pyparsing                       py27-pyparsing-2.2.0
devel/py-pytz                            py27-pytz-2017.2,1
devel/py-six                             py27-six-1.11.0
devel/py-termcolor                       py27-termcolor-1.1.0_1
devel/py-yaml                            py27-yaml-3.11_2
dns/libidn2                              libidn2-2.0.4
dns/py-idna                              py27-idna-2.5
graphics/jpeg-turbo                      jpeg-turbo-1.5.2
graphics/py-pyproj                       py27-pyproj-1.9.5.1
misc/qt4-doc                             qt4-doc-4.8.7_1
misc/shared-mime-info                    shared-mime-info-1.8
net/py-ipaddress                         py27-ipaddress-1.0.18
net/py-pysocks                           py27-pysocks-1.6.7
security/libassuan                       libassuan-2.4.3
security/libksba                         libksba-1.3.5
security/p11-kit                         p11-kit-0.23.9
security/py-certifi                      py27-certifi-2017.11.5
textproc/py-MarkupSafe                   py27-MarkupSafe-1.0
textproc/py-pygments                     py27-pygments-2.2.0
www/py-httplib2                          py27-httplib2-0.10.3
x11-fonts/fontconfig                     fontconfig-2.12.1,1
x11-fonts/libXfont                       libXfont-1.5.2,2
x11-fonts/mkfontscale                    mkfontscale-1.1.2
archivers/liblz4                         liblz4-1.8.0,1
databases/postgresql96-client            postgresql96-client-9.6.6
devel/glib20                             glib-2.50.2_7,1
devel/icu                                icu-60.1,1
devel/libunistring                       libunistring-0.9.7
devel/nspr                               nspr-4.17
devel/orc                                orc-0.4.25
devel/py-sip                             py27-sip-4.19.2,1
devel/py27-setuptools                    py27-setuptools-36.5.0
devel/spatialindex                       spatialindex-1.8.5
graphics/geos                            geos-3.6.2
graphics/proj                            proj-4.9.3
lang/f2c                                 f2c-20060810_6
lang/python2                             python2-2_3
misc/qtchooser                           qtchooser-39
print/freetype2                          freetype2-2.8_1
security/libgpg-error                    libgpg-error-1.27
security/libtasn1                        libtasn1-4.12
textproc/docbook-xsl                     docbook-xsl-1.76.1_3
textproc/freexl                          freexl-1.0.4
textproc/libxml2                         libxml2-2.9.4
textproc/xerces-c3                       xerces-c3-3.2.0_2
x11/libSM                                libSM-1.2.2_3,1
databases/gdbm                           gdbm-1.13_1
devel/gmake                              gmake-4.2.1_1
graphics/libdrm                          libdrm-2.4.88,1
lang/python27                            python27-2.7.14_1
textproc/docbook                         docbook-1.5
x11-fonts/libfontenc                     libfontenc-1.1.3_1
x11/libICE                               libICE-1.0.9_1,1
x11/libXau                               libXau-1.0.8_3
x11/libXdmcp                             libXdmcp-1.1.2
x11/libxshmfence                         libxshmfence-1.2_2
databases/sqlite3                        sqlite3-3.21.0_1
devel/gettext-tools                      gettext-tools-0.19.8.1
devel/libpciaccess                       libpciaccess-0.13.5
textproc/docbook-sgml                    docbook-sgml-4.5_1
textproc/docbook-xml                     docbook-xml-5.0_3
x11-fonts/fontcacheproto                 fontcacheproto-0.1.3
x11-fonts/fontsproto                     fontsproto-2.1.3,1
x11/compositeproto                       compositeproto-0.4.2
x11/damageproto                          damageproto-1.2.1
x11/dri2proto                            dri2proto-2.8
x11/fixesproto                           fixesproto-5.0
x11/glproto                              glproto-1.4.17
x11/inputproto                           inputproto-2.3.2
x11/kbproto                              kbproto-1.0.7
x11/pixman                               pixman-0.34.0
x11/randrproto                           randrproto-1.5.0
x11/renderproto                          renderproto-0.11.1
x11/scrnsaverproto                       scrnsaverproto-1.2.2
x11/videoproto                           videoproto-2.3.3
x11/xextproto                            xextproto-7.3.0
x11/xf86vidmodeproto                     xf86vidmodeproto-2.3.1
x11/xineramaproto                        xineramaproto-1.2.1
x11/xproto                               xproto-7.0.31
x11/xtrans                               xtrans-1.3.5
archivers/unzip                          unzip-6.0_7
databases/unixODBC                       unixODBC-2.3.4
devel/gettext-runtime                    gettext-runtime-0.19.8.1_1
devel/libffi                             libffi-3.2.1_1
devel/libunwind                          libunwind-20170113_1
devel/readline                           readline-7.0.3_1
lang/lua52                               lua52-5.2.4
math/gsl                                 gsl-2.4
multimedia/librtmp                       librtmp-2.4.20151223
net/openldap24-sasl-client               openldap-sasl-client-2.4.45
security/ca_root_nss                     ca_root_nss-3.34
textproc/iso8879                         iso8879-1986_3
textproc/sdocbook-xml                    sdocbook-xml-1.1_2,2
textproc/xmlcharent                      xmlcharent-0.3_2
archivers/lzo2                           lzo2-2.10_1
archivers/zip                            zip-3.0_1
converters/libiconv                      libiconv-1.14_11
devel/libdaemon                          libdaemon-0.14_1
devel/libedit                            libedit-3.1.20170329_2,1
devel/libpthread-stubs                   libpthread-stubs-0.4
devel/npth                               npth-1.5
devel/pcre                               pcre-8.40_1
devel/pkgconf                            pkgconf-1.3.10,1
graphics/giflib                          giflib-5.1.4
graphics/jbigkit                         jbigkit-2.1_1
graphics/png                             png-1.6.34
graphics/poppler-data                    poppler-data-0.4.8
lang/gcc-ecj45                           gcc-ecj-4.5
lang/perl5.24                            perl5-5.24.3
lang/tcl86                               tcl86-8.6.7
misc/hicolor-icon-theme                  hicolor-icon-theme-0.15
misc/pciids                              pciids-20171021
multimedia/v4l_compat                    v4l_compat-1.6.3
net/uriparser                            uriparser-0.8.4
print/indexinfo                          indexinfo-0.3.1
print/libpaper                           libpaper-1.1.24.4
science/hdf5                             hdf5-1.10.1_1
security/cyrus-sasl2                     cyrus-sasl-2.1.26_12
security/libssh2                         libssh2-1.8.0,3
sysutils/gnome_subr                      gnome_subr-1.0
textproc/expat2                          expat-2.2.1
textproc/xmlcatmgr                       xmlcatmgr-2.2_2
x11-fonts/font-util                      font-util-1.3.1
Comment 9 Rainer Hurling freebsd_committer 2017-11-18 16:44:57 UTC
(In reply to Martin Birgmeier from comment #8)

Thanks for the list. I assume you are on FreeBSD 11.1 amd64 and the ports are installed via pkg?
Comment 10 Martin Birgmeier 2017-11-19 20:29:55 UTC
See the scenario described in the initial problem report: 11.1, amd64 and i386, compiled from source using portmaster.
Comment 11 Rainer Hurling freebsd_committer 2017-11-19 20:49:22 UTC
OK, thanks again. This is for my local case studies.

BTW, I am preparing an update towards 2.18.14. It should be in bugzilla in a couple of days.