Bug 221921 - [patch] adapt databases/db5 to new 'armv7' architecture
Summary: [patch] adapt databases/db5 to new 'armv7' architecture
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: Mark Linimon
URL:
Keywords: patch
Depends on:
Blocks:
 
Reported: 2017-08-29 21:11 UTC by Mark Linimon
Modified: 2017-09-01 14:52 UTC (History)
0 users

See Also:
mandree: maintainer-feedback+


Attachments
patch to databases/db5 (462 bytes, patch)
2017-08-29 21:11 UTC, Mark Linimon
mandree: maintainer-approval+
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Mark Linimon freebsd_committer freebsd_triage 2017-08-29 21:11:11 UTC
Created attachment 185892 [details]
patch to databases/db5

The src tree is splitting 32-bit arm support into 'armv6' and the new 'armv7'.  This patch adds armv7 support.  It should provide no regression on any existing architecture.
Comment 1 Matthias Andree freebsd_committer 2017-08-29 21:38:59 UTC
Mark, I approve of the patch. Please go ahead and commit.

The only corner case appear to be specific ARMv6+ on FreeBSD 10.x or old 11.x, but I'm not sure if it's worth looking into (we can't backport the patch from db6 due to the AGPLv3, we'd taint db5) - anything else should be covered.
Comment 2 commit-hook freebsd_committer 2017-09-01 14:50:10 UTC
A commit references this bug:

Author: linimon
Date: Fri Sep  1 14:49:10 UTC 2017
New revision: 449083
URL: https://svnweb.freebsd.org/changeset/ports/449083

Log:
  The src tree is splitting 32-bit arm support into 'armv6' and the new
  'armv7'.  This patch adds armv7 support.  It should provide no regression
  on any existing architecture.

  PR:		221921
  Approved by:	maintainer

Changes:
  head/databases/db5/Makefile
Comment 3 Mark Linimon freebsd_committer freebsd_triage 2017-09-01 14:52:04 UTC
Committed, thanks.

AFAICT anyone wanting to use arm will need to be on a recent version of -11, or more likely, -current, so I don't think there's enough to worry about here.