Bug 222254 - devel/flang-clang fails to make install
Summary: devel/flang-clang fails to make install
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Johannes M Dieterich
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-09-12 12:15 UTC by Otacílio de Araújo Ramos Neto
Modified: 2018-11-18 21:30 UTC (History)
4 users (show)

See Also:
bugzilla: maintainer-feedback? (jmd)


Attachments
pkg info (51.69 KB, text/plain)
2017-09-14 09:17 UTC, Otacílio de Araújo Ramos Neto
no flags Details
Full make log (845.80 KB, text/plain)
2017-09-14 09:33 UTC, Otacílio de Araújo Ramos Neto
no flags Details
make bug fixes (10.12 KB, patch)
2018-05-06 20:32 UTC, robert.ayrapetyan
no flags Details | Diff
poudriere log for a patched port (36.77 KB, text/plain)
2018-05-06 20:33 UTC, robert.ayrapetyan
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Otacílio de Araújo Ramos Neto 2017-09-12 12:15:17 UTC
After um make install on math/R with options to use flang a build and install of devel/flang-clang starts. Build runs ok, but install fails with this message:

-- Up-to-date: /usr/ports/devel/flang-clang/work/stage/usr/local/flang/include/clang-c/Documentation.h
-- Up-to-date: /usr/ports/devel/flang-clang/work/stage/usr/local/flang/include/clang-c/Index.h
-- Up-to-date: /usr/ports/devel/flang-clang/work/stage/usr/local/flang/include/clang-c/Platform.h
-- Up-to-date: /usr/ports/devel/flang-clang/work/stage/usr/local/flang/lib/cmake/clang/ClangTargets.cmake
-- Up-to-date: /usr/ports/devel/flang-clang/work/stage/usr/local/flang/lib/cmake/clang/ClangTargets-release.cmake
-- Up-to-date: /usr/ports/devel/flang-clang/work/stage/usr/local/flang/lib/cmake/clang/ClangConfig.cmake
gzip: can't stat: /usr/ports/devel/flang-clang/work/stage//usr/local/flang/man/man1/scan-build.1: No such file or directory
*** Error code 1

Stop.
make[4]: stopped in /usr/ports/devel/flang-clang
*** Error code 1

Stop.
make[3]: stopped in /usr/ports/devel/flang
*** Error code 1

Stop.
make[2]: stopped in /usr/ports/devel/flang
*** Error code 1
Comment 1 Johannes M Dieterich freebsd_committer 2017-09-14 02:04:25 UTC
Which FreeBSD version is this?
Comment 2 Otacílio de Araújo Ramos Neto 2017-09-14 09:17:58 UTC
Created attachment 186365 [details]
pkg info
Comment 3 Otacílio de Araújo Ramos Neto 2017-09-14 09:18:36 UTC
(In reply to Johannes M Dieterich from comment #1)

[ota@nostromo /usr/home/ota]$ uname -a
FreeBSD nostromo 11.1-RELEASE-p1 FreeBSD 11.1-RELEASE-p1 #0: Wed Aug  9 11:55:48 UTC 2017     root@amd64-builder.daemonology.net:/usr/obj/usr/src/sys/GENERIC  amd64
[ota@nostromo /usr/home/ota]$ freebsd-version 
11.1-RELEASE-p1
Comment 4 Otacílio de Araújo Ramos Neto 2017-09-14 09:33:22 UTC
Created attachment 186366 [details]
Full make log

Sorry, the breakage is not on make install, but make. This log shows the full build process messages.
Comment 5 Johannes M Dieterich freebsd_committer 2017-10-20 03:09:16 UTC
Please check with the new version. It completed poudriere runs fine (just like the version before that, so maybe it'll have the same issues).
Comment 6 Otacílio de Araújo Ramos Neto 2017-10-20 11:56:14 UTC
Same error

Creating clang-cpp
Creating flang
-- Installing: /usr/ports/devel/flang-clang/work/stage/usr/local/flang/bin/clang-format
-- Installing: /usr/ports/devel/flang-clang/work/stage/usr/local/flang/share/clang/clang-format-bbedit.applescript
-- Installing: /usr/ports/devel/flang-clang/work/stage/usr/local/flang/share/clang/clang-format-diff.py
-- Installing: /usr/ports/devel/flang-clang/work/stage/usr/local/flang/share/clang/clang-format-sublime.py
-- Installing: /usr/ports/devel/flang-clang/work/stage/usr/local/flang/share/clang/clang-format.el
-- Installing: /usr/ports/devel/flang-clang/work/stage/usr/local/flang/share/clang/clang-format.py
-- Installing: /usr/ports/devel/flang-clang/work/stage/usr/local/flang/bin/git-clang-format
-- Installing: /usr/ports/devel/flang-clang/work/stage/usr/local/flang/bin/clang-import-test
-- Installing: /usr/ports/devel/flang-clang/work/stage/usr/local/flang/bin/clang-offload-bundler
-- Installing: /usr/ports/devel/flang-clang/work/stage/usr/local/flang/bin/c-index-test
-- Installing: /usr/ports/devel/flang-clang/work/stage/usr/local/flang/bin/clang-check
-- Installing: /usr/ports/devel/flang-clang/work/stage/usr/local/flang/bin/scan-build
-- Installing: /usr/ports/devel/flang-clang/work/stage/usr/local/flang/libexec/ccc-analyzer
-- Installing: /usr/ports/devel/flang-clang/work/stage/usr/local/flang/libexec/c++-analyzer
-- Installing: /usr/ports/devel/flang-clang/work/stage/usr/local/flang/share/man/man1/scan-build.1
-- Installing: /usr/ports/devel/flang-clang/work/stage/usr/local/flang/share/scan-build/scanview.css
-- Installing: /usr/ports/devel/flang-clang/work/stage/usr/local/flang/share/scan-build/sorttable.js
-- Installing: /usr/ports/devel/flang-clang/work/stage/usr/local/flang/bin/scan-view
-- Installing: /usr/ports/devel/flang-clang/work/stage/usr/local/flang/share/scan-view/ScanView.py
-- Installing: /usr/ports/devel/flang-clang/work/stage/usr/local/flang/share/scan-view/Reporter.py
-- Installing: /usr/ports/devel/flang-clang/work/stage/usr/local/flang/share/scan-view/startfile.py
-- Installing: /usr/ports/devel/flang-clang/work/stage/usr/local/flang/share/scan-view/FileRadar.scpt
-- Installing: /usr/ports/devel/flang-clang/work/stage/usr/local/flang/share/scan-view/GetRadarVersion.scpt
-- Installing: /usr/ports/devel/flang-clang/work/stage/usr/local/flang/share/scan-view/bugcatcher.ico
-- Installing: /usr/ports/devel/flang-clang/work/stage/usr/local/flang/lib/libclang.so.4.0
-- Installing: /usr/ports/devel/flang-clang/work/stage/usr/local/flang/lib/libclang.so.4
-- Installing: /usr/ports/devel/flang-clang/work/stage/usr/local/flang/lib/libclang.so
-- Up-to-date: /usr/ports/devel/flang-clang/work/stage/usr/local/flang/include/clang-c
-- Up-to-date: /usr/ports/devel/flang-clang/work/stage/usr/local/flang/include/clang-c/BuildSystem.h
-- Up-to-date: /usr/ports/devel/flang-clang/work/stage/usr/local/flang/include/clang-c/CXCompilationDatabase.h
-- Up-to-date: /usr/ports/devel/flang-clang/work/stage/usr/local/flang/include/clang-c/CXErrorCode.h
-- Up-to-date: /usr/ports/devel/flang-clang/work/stage/usr/local/flang/include/clang-c/CXString.h
-- Up-to-date: /usr/ports/devel/flang-clang/work/stage/usr/local/flang/include/clang-c/Documentation.h
-- Up-to-date: /usr/ports/devel/flang-clang/work/stage/usr/local/flang/include/clang-c/Index.h
-- Up-to-date: /usr/ports/devel/flang-clang/work/stage/usr/local/flang/include/clang-c/Platform.h
-- Installing: /usr/ports/devel/flang-clang/work/stage/usr/local/flang/lib/cmake/clang/ClangTargets.cmake
-- Installing: /usr/ports/devel/flang-clang/work/stage/usr/local/flang/lib/cmake/clang/ClangTargets-release.cmake
-- Installing: /usr/ports/devel/flang-clang/work/stage/usr/local/flang/lib/cmake/clang/ClangConfig.cmake
gzip: can't stat: /usr/ports/devel/flang-clang/work/stage//usr/local/flang/man/man1/scan-build.1: No such file or directory
*** Error code 1

Stop.
make[2]: stopped in /usr/ports/devel/flang-clang
*** Error code 1

Stop.
make[1]: stopped in /usr/ports/devel/flang
*** Error code 1

Stop.
make: stopped in /usr/ports/devel/flang
Comment 7 Walter Schwarzenfeld freebsd_triage 2018-01-22 01:20:02 UTC
I tried it today on 11.1. Builds and installs fine, without errors. Can you confirm this or is the problem still  
present?
Comment 8 Otacílio de Araújo Ramos Neto 2018-01-22 17:14:30 UTC
For me still present

root@nostromo:/usr/ports/devel/flang-clang # uname -a
FreeBSD nostromo 11.1-RELEASE-p4 FreeBSD 11.1-RELEASE-p4 #0: Tue Nov 14 06:12:40 UTC 2017     root@amd64-builder.daemonology.net:/usr/obj/usr/src/sys/GENERIC  amd64

root@nostromo:/usr/ports # svnlite info
Path: .
Working Copy Root Path: /usr/ports
URL: svn://svn.freebsd.org/ports/head
Relative URL: ^/head
Repository Root: svn://svn.freebsd.org/ports
Repository UUID: 35697150-7ecd-e111-bb59-0022644237b5
Revision: 459673
Node Kind: directory
Schedule: normal
Last Changed Author: tz
Last Changed Rev: 459673
Last Changed Date: 2018-01-22 13:35:23 -0300 (seg, 22 jan 2018)


-- Installing: /usr/ports/devel/flang-clang/work/stage/usr/local/flang/lib/cmake/clang/ClangTargets-release.cmake
-- Installing: /usr/ports/devel/flang-clang/work/stage/usr/local/flang/lib/cmake/clang/ClangConfig.cmake
gzip: can't stat: /usr/ports/devel/flang-clang/work/stage//usr/local/flang/man/man1/scan-build.1: No such file or directory
*** Error code 1

Stop.
make: stopped in /usr/ports/devel/flang-clang
Comment 9 Johannes M Dieterich freebsd_committer 2018-01-22 17:40:06 UTC
Since I cannot reproduce: did you set anything in make.conf concerning manpages?
Comment 10 Otacílio de Araújo Ramos Neto 2018-01-30 13:41:57 UTC
No, but I did some modifications to /etc/make.conf

MALLOC_PRODUCTION=	YES
DEVELOPER=yes
WITH_CCACHE_BUILD=yes
CCACHE_DIR=/var/tmp/ccache_dir

DEFAULT_VERSIONS+=  perl5=5.24 gcc=5
Comment 11 Walter Schwarzenfeld freebsd_triage 2018-02-05 17:39:58 UTC
Have you tried to build it without CCACHE?
Comment 12 robert.ayrapetyan 2018-05-06 20:32:13 UTC
Created attachment 193111 [details]
make bug fixes

- Removed BROKEN from Makefile
- Updated to a new snapshot and fix pkg-plist to match the recent upgrade of 
LLVM 5.0.1 to 5.0.2.
- Bumped DISTVERSION to force recompilation after the above companion compiler 
update.
Comment 13 robert.ayrapetyan 2018-05-06 20:33:55 UTC
Created attachment 193112 [details]
poudriere log for a patched port
Comment 14 Johannes M Dieterich freebsd_committer 2018-05-07 01:56:13 UTC
Thanks, I am aware. This happened again b/c of an update to devel/llvm50.

I want to take the time to also update flang and flang-clang to the latest git revisions.
Comment 15 robert.ayrapetyan 2018-05-07 07:22:02 UTC
(In reply to Johannes M Dieterich from comment #14)
Thanks, I believe flang-clang is already on a latest revision (Latest commit 64043d5 on Dec 20, 2017)
Comment 16 commit-hook freebsd_committer 2018-05-20 21:35:02 UTC
A commit references this bug:

Author: jmd
Date: Sun May 20 21:34:19 UTC 2018
New revision: 470487
URL: https://svnweb.freebsd.org/changeset/ports/470487

Log:
  devel/flang-clang: chase recent update of devel/llvm50 companion. Only plist changes.

  PR:		222254
  Reviewed by:	zeising (mentor)
  Approved by:	zeising (mentor)
  Obtained from:	PR 222254 ( robert.ayrapetyan at gmail.com )
  Differential Revision:	https://reviews.freebsd.org/D15351

Changes:
  head/devel/flang-clang/Makefile
  head/devel/flang-clang/distinfo
  head/devel/flang-clang/pkg-plist
Comment 17 Walter Schwarzenfeld freebsd_triage 2018-11-18 03:13:50 UTC
Is there a reason to keep this open, or forgotten to close?