Bug 222704 - `sudo pkg update` segfaults in Vagrant
Summary: `sudo pkg update` segfaults in Vagrant
Status: Closed DUPLICATE of bug 222510
Alias: None
Product: Base System
Classification: Unclassified
Component: bin (show other bugs)
Version: 11.1-STABLE
Hardware: Any Any
: --- Affects Only Me
Assignee: freebsd-virtualization mailing list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-09-30 17:21 UTC by Andrew Pennebaker
Modified: 2017-11-13 14:32 UTC (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Andrew Pennebaker 2017-09-30 17:21:15 UTC
Apologies, I am new to FreeBSD. I'ved used Linux package managers, but I'm just starting to learn how to use FreeBSD packages/ports, so forgive my syntax.

When I try to run sudo pkg update in FreeBSD 11.1-STABLE in Vagrant, I get a segfault.

Trace:

vagrant@:~ % sudo pkg update
Segmentation fault

Vagrantfile:

Vagrant.configure("2") do |config|
  config.vm.box = "freebsd/FreeBSD-11.1-STABLE"

  config.vm.guest = :freebsd
  config.vm.synced_folder ".", "/vagrant", id: "vagrant-root", disabled: true
  config.ssh.shell = "sh"
  config.vm.base_mac = "080027D14C66"

  config.vm.provider :virtualbox do |vb|
   vb.customize ["modifyvm", :id, "--memory", "1024"]
   vb.customize ["modifyvm", :id, "--cpus", "1"]
   vb.customize ["modifyvm", :id, "--hwvirtex", "on"]
   vb.customize ["modifyvm", :id, "--audio", "none"]
   vb.customize ["modifyvm", :id, "--nictype1", "virtio"]
   vb.customize ["modifyvm", :id, "--nictype2", "virtio"]
  end
end

I'm using Vagrant v2.0 with VirtualBox 5.1.10r112026 on macOS Sierra 10.12.6, by the way.
Comment 1 Brad Davis freebsd_committer 2017-11-13 14:32:41 UTC
This is a sudo bug, see the linked bug.

*** This bug has been marked as a duplicate of bug 222510 ***