Bug 222795 - lang/python27: Marked as BROKEN with openssl-devel but is not
Summary: lang/python27: Marked as BROKEN with openssl-devel but is not
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: Sunpoet Po-Chuan Hsieh
URL:
Keywords: easy, needs-patch, needs-qa
Depends on:
Blocks: 222552
  Show dependency treegraph
 
Reported: 2017-10-05 13:11 UTC by Tom Francis
Modified: 2018-02-24 06:58 UTC (History)
4 users (show)

See Also:


Attachments
svn diff for lang/python27 (5.92 KB, patch)
2018-01-26 11:22 UTC, Bernard Spil
brnrd: maintainer-approval?
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Tom Francis 2017-10-05 13:11:12 UTC
devel/python27 is marked as BROKEN with openssl-devel, but it is not.  Python 2.7.14 at least (possibly earlier versions) have added support for OpenSSL 1.1, which is what openssl-devel provides.  This port should not be marked as broken.
Comment 1 Walter Schwarzenfeld freebsd_triage 2018-01-26 07:25:51 UTC
Ping!
Comment 2 Bernard Spil freebsd_committer 2018-01-26 08:13:21 UTC
Looks like this was fixed in 2.7.14. From the changelog

- Issue #26470: Port ssl and hashlib module to OpenSSL 1.1.0.

See https://raw.githubusercontent.com/python/cpython/84471935ed2f62b8c5758fd544c7d37076fe0fa5/Misc/NEWS
Comment 3 Bernard Spil freebsd_committer 2018-01-26 09:39:56 UTC
Doesn't build with the current openssl-devel port.
This is due to errors in Python's tests for NPN (deprecated).

Creating a patch, will report back here,
Comment 4 Walter Schwarzenfeld freebsd_triage 2018-01-26 10:32:39 UTC
Thanks, for reply.
Comment 5 Bernard Spil freebsd_committer 2018-01-26 11:22:40 UTC
Created attachment 190080 [details]
svn diff for lang/python27

Created an upstream Pull-Request. Backporting from 2.7 wasn't complete.

We can easily add this to the port, see patch.

From make test:
> 0:09:54 load avg: 0.64 [397/403/1] test_ssl passed

I've also sent a pull-request for cpython master branch to align detection and use of NPN with detection/use of ALPN.
Comment 6 Bernard Spil freebsd_committer 2018-02-13 20:24:25 UTC
Currently looking at updating security/openssl to 1.1.0, we need to get this moving.
Comment 7 commit-hook freebsd_committer 2018-02-15 12:48:16 UTC
A commit references this bug:

Author: sunpoet
Date: Thu Feb 15 12:47:59 UTC 2018
New revision: 461915
URL: https://svnweb.freebsd.org/changeset/ports/461915

Log:
  Fix build with OpenSSL 1.1.0 (security/openssl-devel)

  - Remove BROKEN_SSL=openssl-devel

  Reference:	https://bugs.python.org/issue30622
  		https://github.com/python/cpython/commit/b2d096bd2a5ff86e53c25d00ee5fa097b36bf1d8
  PR:		222795
  Submitted by:	brnrd
  MFH:		2018Q1

Changes:
  head/lang/python27/Makefile
  head/lang/python27/files/patch-issue30622
Comment 8 Sunpoet Po-Chuan Hsieh freebsd_committer 2018-02-15 12:48:55 UTC
Committed. Thanks!
Comment 9 Kubilay Kocak freebsd_committer freebsd_triage 2018-02-24 06:58:03 UTC
ports r462630 (followup to this issue, but not PR: referenced), likely caused a regression (see bug 226135).

I am investigating and will attempt to produce a workaround (for including OPENSSL framework flags), before reverting.