Bug 222935 - lang/guile2: Does not build since at least 2017Q1
Summary: lang/guile2: Does not build since at least 2017Q1
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Mark Felder
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-10-11 18:14 UTC by Mark Felder
Modified: 2017-10-11 19:14 UTC (History)
0 users

See Also:
bugzilla: maintainer-feedback? (bofh)
feld: maintainer-feedback+
feld: merge-quarterly+


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Mark Felder freebsd_committer 2017-10-11 18:14:42 UTC
It appears we do not rebuild all packages when we move to a new quarterly and this port/package has not needed to be rebuilt in some time. It currently fails to build.


Backtrace:
In ice-9/eval.scm:
 387: 19 [eval #<memoized (<7> <0> (<7> <1> (<7> <2> (<11> <6> <5>))))> (# # # ...)]
 387: 18 [eval #<memoized (<8> <4> (<5> <0> (<9> <4> <3>)))> (# # # # ...)]
 387: 17 [eval # #]
 387: 16 [eval # #]
 387: 15 [eval # #]
 387: 14 [eval #<memoized (<9> <5> (if <1> (<6> <1> <0>) <0>))> (# # # # ...)]
 387: 13 [eval # #]
 387: 12 [eval #<memoized (<8> <4> (<5> <0> (<9> <4> <3>)))> (# # # # ...)]
 387: 11 [eval # #]
 387: 10 [eval # #]
 387: 9 [eval # #]
In language/tree-il/analyze.scm:
 570: 8 [#<procedure 805a5dae0 at language/tree-il/analyze.scm:567:4 (x results)> # ...]
In ice-9/eval.scm:
 387: 7 [eval # #]
 387: 6 [eval # #]
In language/tree-il/analyze.scm:
1501: 5 [#<procedure 8061f92a0 at language/tree-il/analyze.scm:1429:3 (x _ env locs)> # ...]
In ice-9/eval.scm:
 486: 4 [eval # #]
 381: 3 [eval # #]
In unknown file:
   ?: 2 [#<variable 8006ad250 value: #<procedure #<variable 8006ad250 value: #<program 800b9aa58>> (_ _ _ _ _)>> #]
In ice-9/eval.scm:
 481: 1 [lp (#<fluid 13>) ((#<procedure 805009cb0 at ice-9/eval.scm:264:7 %args>))]
 481: 0 [lp (#<fluid 13>) (#)]

ice-9/eval.scm:481:19: gmake[3]: *** [Makefile:2235: language/assembly/disassemble.go] Error 1
gmake[3]: *** Waiting for unfinished jobs....
wrote `language/objcode/spec.go'
wrote `language/value/spec.go'
wrote `language/scheme/spec.go'
wrote `system/base/pmatch.go'
wrote `system/base/target.go'
wrote `system/base/message.go'
Backtrace:
In ice-9/eval.scm:
 387: 19 [eval #<memoized (<9> <5> (<6> <0> (<6> <1> (<10> <5> <4>))))> (# # # ...)]
 387: 18 [eval # #]
 387: 17 [eval #<memoized (<7> <0> (<7> <1> (<7> <2> (<11> <6> <5>))))> (# # # ...)]
 387: 16 [eval #<memoized (<9> <5> (<6> <0> (<6> <1> (<10> <5> <4>))))> (# # # ...)]
 387: 15 [eval # #]
In srfi/srfi-1.scm:
 465: 14 [fold #<procedure 805a2cc30 at ice-9/eval.scm:416:20 (a b)> # #]
In ice-9/eval.scm:
 387: 13 [eval #<memoized (<9> <5> (if <1> (<6> <1> <0>) <0>))> (# # # # ...)]
 387: 12 [eval # #]
 387: 11 [eval #<memoized (<8> <4> (<5> <0> (<9> <4> <3>)))> (# # # # ...)]
In srfi/srfi-1.scm:
 465: 10 [fold #<procedure 805a2cc30 at ice-9/eval.scm:416:20 (a b)> # #]
In ice-9/eval.scm:
 387: 9 [eval # #]
 387: 8 [eval # #]
In language/tree-il/analyze.scm:
 570: 7 [#<procedure 805a2cc90 at language/tree-il/analyze.scm:567:4 (x results)> # ...]
In srfi/srfi-1.scm:
 598: 6 [map #<procedure 80605b4c0 at language/tree-il/analyze.scm:570:19 (analysis result)> ...]
In language/tree-il/analyze.scm:
1501: 5 [#<procedure 80572e7e0 at language/tree-il/analyze.scm:1429:3 (x _ env locs)> # ...]
In ice-9/eval.scm:
 486: 4 [eval # #]
 381: 3 [eval # #]
In unknown file:
   ?: 2 [#<variable 8006ad250 value: #<procedure #<variable 8006ad250 value: #<program 800b9aa58>> (_ _ _ _ _)>> #]
In ice-9/eval.scm:
 481: 1 [lp (#<fluid 13>) ((#<procedure 803c51460 at ice-9/eval.scm:264:7 %args>))]
 481: 0 [lp (#<fluid 13>) (#)]

ice-9/eval.scm:481:19: gmake[3]: *** [Makefile:2235: system/base/lalr.go] Error 1
wrote `system/base/syntax.go'
wrote `system/base/compile.go'
wrote `ice-9/boot-9.go'
wrote `ice-9/r4rs.go'
wrote `system/base/ck.go'
wrote `ice-9/r5rs.go'
wrote `ice-9/psyntax-pp.go'
Backtrace:
In ice-9/eval.scm:
 481: 19 [lp (#<fluid 17>) (#)]
 440: 18 [eval # #]
 440: 17 [eval # #]
In language/tree-il/compile-glil.scm:
  63: 16 [compile-glil #<tree-il #> #<directory # 8068a7140> (# #)]
In language/tree-il/analyze.scm:
 580: 15 [analyze-tree (# # #) #<tree-il #> #<directory # 8068a7140>]
In ice-9/eval.scm:
 387: 14 [eval #<memoized (<8> <4> (<5> <0> (<9> <4> <3>)))> (# # # # ...)]
In srfi/srfi-1.scm:
 465: 13 [fold #<procedure 8042f0300 at ice-9/eval.scm:416:20 (a b)> # #]
In ice-9/eval.scm:
 387: 12 [eval #<memoized (<8> <4> (<5> <0> (<9> <4> <3>)))> (# # # # ...)]
 387: 11 [eval #<memoized (<9> <5> (if <1> (<6> <1> <0>) <0>))> (# # # # ...)]
 387: 10 [eval # #]
 387: 9 [eval # #]
 387: 8 [eval # #]
In language/tree-il/analyze.scm:
 570: 7 [#<procedure 8042f0360 at language/tree-il/analyze.scm:567:4 (x results)> # ...]
In srfi/srfi-1.scm:
 598: 6 [map #<procedure 80638a2c0 at language/tree-il/analyze.scm:570:19 (analysis result)> ...]
In language/tree-il/analyze.scm:
1501: 5 [#<procedure 806617140 at language/tree-il/analyze.scm:1429:3 (x _ env locs)> # ...]
In ice-9/eval.scm:
 486: 4 [eval # #]
 381: 3 [eval # #]
In unknown file:
   ?: 2 [#<variable 8006ad250 value: #<procedure #<variable 8006ad250 value: #<program 800b9aa58>> (_ _ _ _ _)>> #]
In ice-9/eval.scm:
 481: 1 [lp (#<fluid 13>) ((#<procedure 80502c460 at ice-9/eval.scm:264:7 %args>))]
 481: 0 [lp (#<fluid 13>) (#)]

ice-9/eval.scm:481:19: gmake[3]: *** [Makefile:2235: system/base/types.go] Error 1
wrote `language/scheme/decompile-tree-il.go'
wrote `ice-9/deprecated.go'
wrote `ice-9/and-let-star.go'
wrote `ice-9/binary-ports.go'
wrote `language/tree-il/peval.go'
Backtrace:
In language/tree-il.scm:
 378: 19 [loop #<tree-il #> (# #t # #)]
 384: 18 [loop #<tree-il #> (# #t # #)]
 386: 17 [loop #<tree-il #> (# #t # #)]
 371: 16 [loop #<tree-il #> (# #t # #)]
In srfi/srfi-1.scm:
 465: 15 [fold #<procedure loop (tree result)> (# #t # #) (# # #)]
In language/tree-il.scm:
 371: 14 [loop #<tree-il #> (# #t # #)]
In srfi/srfi-1.scm:
 465: 13 [fold #<procedure loop (tree result)> (# #t # #) (# # #)]
In language/tree-il.scm:
 378: 12 [loop #<tree-il #> (# #t # #)]
 384: 11 [loop #<tree-il #> (# #t # #)]
 371: 10 [loop #<tree-il #> (# #t # #)]
In srfi/srfi-1.scm:
 465: 9 [fold #<procedure loop (tree result)> (# #t # #) (# # #)]
In language/tree-il.scm:
 371: 8 [loop #<tree-il #> (# #t # #)]
In language/tree-il/analyze.scm:
 570: 7 [#<procedure 8040bd750 at language/tree-il/analyze.scm:567:4 (x results)> # ...]
In srfi/srfi-1.scm:
 598: 6 [map #<procedure 805f8e240 at language/tree-il/analyze.scm:570:19 (analysis result)> ...]
In language/tree-il/analyze.scm:
1501: 5 [#<procedure 805f89240 at language/tree-il/analyze.scm:1429:3 (x _ env locs)> # ...]
In ice-9/eval.scm:
 486: 4 [eval # #]
 381: 3 [eval # #]
In unknown file:
   ?: 2 [#<variable 8006ad250 value: #<procedure #<variable 8006ad250 value: #<program 800b9aa58>> (_ _ _ _ _)>> #]
In ice-9/eval.scm:
 481: 1 [lp (#<fluid 13>) (#)]
 481: 0 [lp (#<fluid 13>) (#)]

ice-9/eval.scm:481:19: gmake[3]: *** [Makefile:2235: ice-9/calling.go] Error 1
wrote `ice-9/command-line.go'
wrote `ice-9/common-list.go'
gmake[3]: Leaving directory '/wrkdirs/usr/ports/lang/guile2/work/guile-2.0.14/module'
gmake[2]: *** [Makefile:1841: all-recursive] Error 1
gmake[2]: Leaving directory '/wrkdirs/usr/ports/lang/guile2/work/guile-2.0.14'
gmake[1]: *** [Makefile:1727: all] Error 2
gmake[1]: Leaving directory '/wrkdirs/usr/ports/lang/guile2/work/guile-2.0.14'
===> Compilation failed unexpectedly.
Try to set MAKE_JOBS_UNSAFE=yes and rebuild before reporting the failure to
the maintainer.
*** Error code 1

Stop.
make: stopped in /usr/ports/lang/guile2
[00:16:09] ====>> Saved guile2-2.0.14_1 wrkdir to: /usr/local/poudriere/data/wrkdirs/103R-2017Q4/2017Q4/guile2-2.0.14_1.tbz
build of lang/guile2 ended at Wed Oct 11 12:40:50 CDT 2017
Comment 1 Mark Felder freebsd_committer 2017-10-11 18:20:09 UTC
Actually I thought I built this with MAKE_JOBS_UNSAFE to test but built against the wrong tree. This seems to solve the problem. I'm double checking and will commit this change to the port if it works.
Comment 2 Muhammad Moinur Rahman freebsd_committer 2017-10-11 18:22:54 UTC
(In reply to Mark Felder from comment #1)
Am AFK .. But the log looks like an issue of MAKE_JOBS_UNSAFE. Feel free to commit
Comment 3 commit-hook freebsd_committer 2017-10-11 19:11:03 UTC
A commit references this bug:

Author: feld
Date: Wed Oct 11 19:10:52 UTC 2017
New revision: 451773
URL: https://svnweb.freebsd.org/changeset/ports/451773

Log:
  lang/guile2: This port is MAKE_JOBS_UNSAFE

  PR:		222935
  Approved by:	portmgr (with hat)
  MFH:		2017Q4

Changes:
  head/lang/guile2/Makefile
Comment 4 commit-hook freebsd_committer 2017-10-11 19:12:06 UTC
A commit references this bug:

Author: feld
Date: Wed Oct 11 19:11:36 UTC 2017
New revision: 451774
URL: https://svnweb.freebsd.org/changeset/ports/451774

Log:
  MFH: r451773

  lang/guile2: This port is MAKE_JOBS_UNSAFE

  PR:		222935
  Approved by:	portmgr (with hat)

Changes:
_U  branches/2017Q4/
  branches/2017Q4/lang/guile2/Makefile
Comment 5 Mark Felder freebsd_committer 2017-10-11 19:14:06 UTC
Confirmed, committed, MFH.