Bug 223030 - graphics/mesa-libs: fix device name detection for Wayland/EGL
Summary: graphics/mesa-libs: fix device name detection for Wayland/EGL
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: freebsd-x11 mailing list
URL:
Keywords:
: 224203 (view as bug list)
Depends on:
Blocks:
 
Reported: 2017-10-15 15:35 UTC by Greg V
Modified: 2018-04-10 01:02 UTC (History)
2 users (show)

See Also:
bugzilla: maintainer-feedback? (x11)


Attachments
mesa-fix-loader.patch (873 bytes, patch)
2017-10-15 15:35 UTC, Greg V
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Greg V 2017-10-15 15:35:56 UTC
Created attachment 187196 [details]
mesa-fix-loader.patch

Currently, Wayland EGL clients receive /dev/dri/card408 instead of /dev/dri/card0 as the device path, and fall back to software rendering :D

This patch changes the "device name from file descriptor" function in Mesa from a  reimplementation of libdrm's drmGetDeviceNameFromFd2 to just calling that function, where we already have this fixed.

Reported upstream: https://bugs.freedesktop.org/show_bug.cgi?id=103283
Comment 1 Greg V 2017-10-26 14:48:04 UTC
Landed upstream https://cgit.freedesktop.org/mesa/mesa/commit/?id=db8519a369261cdedda50852facc45616d4eba28 — will be there in 17.4 :) But for now it's still worth including into the port.
Comment 2 Niclas Zeising freebsd_committer 2017-12-09 16:08:25 UTC
*** Bug 224203 has been marked as a duplicate of this bug. ***
Comment 3 Niclas Zeising freebsd_committer 2017-12-09 16:09:56 UTC
Is this an issue only on wayland?  This isn't clear from the discussion in bug 224203, which is regarding the same thing.
Comment 4 Niclas Zeising freebsd_committer 2017-12-17 13:19:24 UTC
I just landed an updated version of mesa (17.3).  Is this patch needed for that version as well?
I want to let mesa 17.3 simmer for a little while, before I get to this.
Comment 5 Greg V 2017-12-17 18:56:23 UTC
(In reply to Niclas Zeising from comment #4)
Yes, this is needed. Until… probably 17.4.
Comment 6 commit-hook freebsd_committer 2018-04-10 00:14:43 UTC
A commit references this bug:

Author: jbeich
Date: Tue Apr 10 00:14:22 UTC 2018
New revision: 466924
URL: https://svnweb.freebsd.org/changeset/ports/466924

Log:
  graphics/mesa-dri: fix device name detection for Wayland/EGL

  PR:		223030
  Submitted by:	Greg V
  Obtained from:	upstream (Mesa 18.0.0)
  Approved by:	maintainer timeout (4 months)

Changes:
  head/graphics/mesa-dri/Makefile
  head/graphics/mesa-dri/files/patch-src_loader_loader.c
Comment 7 commit-hook freebsd_committer 2018-04-10 00:19:02 UTC
A commit references this bug:

Author: jbeich
Date: Tue Apr 10 00:18:46 UTC 2018
New revision: 466930
URL: https://svnweb.freebsd.org/changeset/ports/466930

Log:
  MFH: r466924

  graphics/mesa-dri: fix device name detection for Wayland/EGL

  PR:		223030
  Submitted by:	Greg V
  Obtained from:	upstream (Mesa 18.0.0)
  Approved by:	maintainer timeout (4 months)
  Approved by:	ports-secteam blanket

Changes:
_U  branches/2018Q2/
  branches/2018Q2/graphics/mesa-dri/Makefile
  branches/2018Q2/graphics/mesa-dri/files/patch-src_loader_loader.c