Bug 223195 - graphics/mesa-dri: update to 17.3.0
Summary: graphics/mesa-dri: update to 17.3.0
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: freebsd-x11 mailing list
URL: https://www.mesa3d.org/relnotes/17.3....
Keywords: patch
Depends on: 220982 223193
Blocks:
  Show dependency treegraph
 
Reported: 2017-10-23 17:11 UTC by Jan Beich
Modified: 2018-01-23 22:57 UTC (History)
4 users (show)

See Also:
zeising: maintainer-feedback+


Attachments
rc1 (7.85 KB, patch)
2017-10-23 17:11 UTC, Jan Beich
no flags Details | Diff
rc1 (8.30 KB, patch)
2017-10-24 01:46 UTC, Jan Beich
no flags Details | Diff
rc2 (8.30 KB, patch)
2017-10-30 19:30 UTC, Jan Beich
no flags Details | Diff
rc3 (8.30 KB, patch)
2017-11-08 04:08 UTC, Jan Beich
no flags Details | Diff
rc3 (rebased after ports r453796) (8.30 KB, patch)
2017-11-09 06:38 UTC, Jan Beich
no flags Details | Diff
rc4 (8.73 KB, patch)
2017-11-14 15:27 UTC, Jan Beich
no flags Details | Diff
rc4 (9.09 KB, patch)
2017-11-14 19:27 UTC, Jan Beich
no flags Details | Diff
rc5 (8.67 KB, patch)
2017-11-20 16:31 UTC, Jan Beich
no flags Details | Diff
rc6 (8.67 KB, patch)
2017-12-04 12:51 UTC, Jan Beich
no flags Details | Diff
release (8.54 KB, patch)
2017-12-08 19:28 UTC, Jan Beich
zeising: maintainer-approval+
Details | Diff
SandyBridge Xorg.0.log (16.19 KB, text/x-log)
2017-12-10 13:06 UTC, Carlos J. Puga Medina
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Comment 1 Jan Beich freebsd_committer 2017-10-23 17:36:07 UTC
ChangeLog writes:
> libtxc_dxtn is now integrated into Mesa. GL_EXT_texture_compression_s3tc
> and GL_ANGLE_texture_compression_dxt are now always enabled on drivers
> that support them

Oops, forgot to drop RUN_DEPENDS line despite noting in bug 212762 comment 6.
Comment 2 Jan Beich freebsd_committer 2017-10-24 01:46:54 UTC
Created attachment 187412 [details]
rc1
Comment 3 Greg V 2017-10-26 14:58:16 UTC
You can delete patch-src_mesa_main_compiler.h from the port since it's unnecessary, we are already handled by the 'else' case (noticed by Emil Velikov on mesa-dev)
Comment 4 Jan Beich freebsd_committer 2017-10-26 17:24:39 UTC
(In reply to Greg V from comment #3)
Agree but it's unrelated to the update thus maybe ignored by the maintainer. Can you file a separate bug instead?
Comment 7 Jan Beich freebsd_committer 2017-11-09 06:38:28 UTC
Created attachment 187875 [details]
rc3 (rebased after ports r453796)
Comment 9 Jan Beich freebsd_committer 2017-11-14 19:27:31 UTC
Created attachment 188000 [details]
rc4

lang/clover was failing to build.

  mv: /wrkdirs/usr/ports/lang/clover/work/stage/etc/OpenCL: No such file or directory

error log: http://sprunge.us/GihO
caused by: https://cgit.freedesktop.org/mesa/mesa/commit/?id=9e1698b17bcd
Comment 12 Jan Beich freebsd_committer 2017-12-08 19:28:06 UTC
Created attachment 188632 [details]
release

Mesa 17.3.0 has been officially released, starting countdown to maintainer timeout. As upstream will maintain Mesa 17.2.* until 17.3.1 there's no rush to land this before 2018Q1 branches.

https://lists.freedesktop.org/archives/mesa-announce/2017-December/000380.html
Comment 13 Niclas Zeising freebsd_committer 2017-12-09 17:18:01 UTC
Hi!
Do you need this for anything particular?  The following from the release notes makes me a bit hesitant in approving this.

"Mesa 17.3.0 is a new development release. People who are concerned with stability and reliability should stick with a previous release or wait for Mesa 17.3.1."
Comment 14 Jan Beich freebsd_committer 2017-12-09 18:18:18 UTC
That message has been in each Mesa X.Y.0 release for some time. Upstream doesn't do QA on FreeBSD, so waiting won't guarantee more stability on FreeBSD. I've sent CFT to x11@ and ports@ list. Mesa 17.3.1 is expected to be released in ~2 weeks.

The rest is as described in comment 12. To avoid bisecting pain the update has to land separately from any unrelated changes.
Comment 15 Niclas Zeising freebsd_committer 2017-12-09 20:06:19 UTC
Thanks for the explanation.

I assume you are running this somewhere, have you detected any issues so far?  I would prefer to wait and see, especially if you've sent out a CFT and haven't gotten any response yet.
Comment 16 Greg V 2017-12-09 20:19:13 UTC
(In reply to Niclas Zeising from comment #15)
I've been running all the release candidates on two machines (amdgpu RX 480 and i915 Haswell), with both Xorg and Wayland, with lots of OpenGL and Vulkan applications (OpenMW, Dolphin, RPCS3, PPSSPP…) Of course it works perfectly.
Comment 17 Niclas Zeising freebsd_committer 2017-12-09 20:30:15 UTC
(In reply to Greg V from comment #16)
Nothing is "of course it works" when it comes to the graphics stack.  I've been bitten by it before.
Comment 18 Niclas Zeising freebsd_committer 2017-12-09 20:59:04 UTC
Approved
Comment 19 Carlos J. Puga Medina freebsd_committer 2017-12-10 13:06:08 UTC
Created attachment 188687 [details]
SandyBridge Xorg.0.log

Confirmed: Mesa-17.3.0 works flawlessly (Mpv was tested: no crashes or performance issues).
Comment 20 commit-hook freebsd_committer 2017-12-17 13:07:59 UTC
A commit references this bug:

Author: zeising
Date: Sun Dec 17 13:07:38 UTC 2017
New revision: 456530
URL: https://svnweb.freebsd.org/changeset/ports/456530

Log:
  Update mesa ports to 17.3.0

  Add missing dependencies on xcb and xxf86vm.

  Changelog for mesa: https://www.mesa3d.org/relnotes/17.3.0.html

  PR:		223195
  Submitted by:	jbeich
  Tested by:	Greg V, cpm

Changes:
  head/graphics/mesa-dri/Makefile
  head/graphics/mesa-dri/Makefile.common
  head/graphics/mesa-dri/Makefile.targets
  head/graphics/mesa-dri/distinfo
  head/graphics/mesa-dri/files/patch-src_egl_drivers_dri2_platform__x11.c
  head/graphics/mesa-dri/files/patch-src_glx_glxext.c
  head/graphics/mesa-dri/files/patch-src_intel_Makefile.in
  head/graphics/mesa-libs/Makefile
  head/graphics/mesa-libs/pkg-plist
  head/lang/clover/Makefile
Comment 21 Niclas Zeising freebsd_committer 2017-12-17 13:13:18 UTC
This is in.  I'll keep the PR open for a couple of days, in case there's any fallout.
Comment 22 Jan Beich freebsd_committer 2017-12-22 15:43:49 UTC
Thanks. The cadence for Mesa patch-level releases is ~2 weeks, for FreeBSD package bulk builds is 2 days (except Sunday). After bug 224513 lands, cementing 17.3.x series before 2018Q1 branches, MFH to 2018Q1 of the subsequent updates (e.g., 17.3.2) can be postponed by 1 week to bake on /head. Also, runtime regressions (e.g., crashes, broken init) on /quarterly can be fixed quickly under ports-secteam@ blanket if those don't require a port update with lots of unrelated changes.