Bug 225220 - net/boinc-client: always seems to build with X11
Summary: net/boinc-client: always seems to build with X11
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Larry Rosenman
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-01-16 15:46 UTC by Gary
Modified: 2018-01-16 17:25 UTC (History)
0 users

See Also:
bugzilla: maintainer-feedback? (ler)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Gary 2018-01-16 15:46:39 UTC
# pwd
/usr/ports/net/boinc-client
# head -2 Makefile 
# Created by: J.R. Oldroyd <fbsd@opal.com>
# $FreeBSD: head/net/boinc-client/Makefile 459148 2018-01-16 01:28:06Z ler $
# make showconfig
===> The following configuration options are available for boinc-client-7.8.6_2:
     CLIENT=on: Build BOINC client
     LINUX=on: Accept Linux science applications
     MANAGER=off: Build BOINC manager GUI
     NLS=on: Native Language Support
     SKINS=off: Install more skins for BOINC manager
     USER=on: Create/check BOINC client user and directory
     X11=off: Build graphics API
====> Command line options in script
     NO_GUI_RPC=off: Disable GUI RPC and socket (breaks boinc_curses)
     NO_NET_INFO=on: Do not send host address and name to servers
===> Use 'make config' to modify these settings

Note X11 and MANAGER are deselected

# make
===>  License LGPL3 accepted by the user
===>   boinc-client-7.8.6_2 depends on file: /usr/local/sbin/pkg - found
===> Fetching all distfiles required by boinc-client-7.8.6_2 for building
===>  Extracting for boinc-client-7.8.6_2
=> SHA256 Checksum OK for BOINC-boinc-client_release-7.8-7.8.6_GH0.tar.gz.
===>  Patching for boinc-client-7.8.6_2
===>   Converting DOS text files to UNIX text files
===>  Applying FreeBSD patches for boinc-client-7.8.6_2
===>   boinc-client-7.8.6_2 depends on executable: autoconf-2.69 - found
===>   boinc-client-7.8.6_2 depends on executable: autoheader-2.69 - found
===>   boinc-client-7.8.6_2 depends on executable: autoreconf-2.69 - found
===>   boinc-client-7.8.6_2 depends on executable: aclocal-1.15 - found
===>   boinc-client-7.8.6_2 depends on executable: automake-1.15 - found
===>   boinc-client-7.8.6_2 depends on executable: libtoolize - found
===>   boinc-client-7.8.6_2 depends on executable: msgfmt - found
===>   boinc-client-7.8.6_2 depends on executable: gmake - found
===>   boinc-client-7.8.6_2 depends on package: pkgconf>=1.3.0_1 - found
===>   boinc-client-7.8.6_2 depends on file: /usr/local/libdata/pkgconfig/x11.pc - not found
===>  License MIT accepted by the user
===>   libX11-1.6.5,1 depends on file: /usr/local/sbin/pkg - found
===> Fetching all distfiles required by libX11-1.6.5,1 for building
===>  Extracting for libX11-1.6.5,1

Why is it trying to build libX11?
Comment 1 Larry Rosenman freebsd_committer 2018-01-16 17:25:21 UTC
Thanks for the report.  Fixed in PORTREVISION 3.
Comment 2 commit-hook freebsd_committer 2018-01-16 17:25:50 UTC
A commit references this bug:

Author: ler
Date: Tue Jan 16 17:24:54 UTC 2018
New revision: 459197
URL: https://svnweb.freebsd.org/changeset/ports/459197

Log:
  net/boinc-client: don't look for X11 libraries when X11 is not set

  PR:			225220
  Submitted by:		freebsd-bugzilla@in-addr.com

Changes:
  head/net/boinc-client/Makefile