Bug 225406 - Add lib path for fortran.mk related builds
Summary: Add lib path for fortran.mk related builds
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Ports Framework (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Port Management Team
URL:
Keywords:
Depends on:
Blocks: 225128
  Show dependency treegraph
 
Reported: 2018-01-23 15:52 UTC by Diane Bruce
Modified: 2018-02-19 19:14 UTC (History)
4 users (show)

See Also:


Attachments
Simple patch to fortran.mk to expose the Fortran library path (714 bytes, patch)
2018-01-23 15:52 UTC, Diane Bruce
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Diane Bruce freebsd_committer 2018-01-23 15:52:14 UTC
Created attachment 190003 [details]
Simple patch to fortran.mk to expose the Fortran library path

Due to the libgcc_s problem (See https://wiki.freebsd.org/libgcc%20problem) it is sometimes necessary to LD_PRELOAD libgcc_s.so in order to make a port work or to even build a port. Also see https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=225351 for another example.

I am forced with the current framework to do something like
CONFIGURE_ENV= LD_PRELOAD="${LOCALBASE}/lib/gcc${_GCC_VER}/libgcc_s.so"
in my Makefile (gnuradio configure)

I propose exposing the LIBPATH from fortran.mk
So we can do something like CONFIGURE_ENV=  LD_PREFLOAD="${FLIBPATH}/libgcc_s.so"


attached is a tiny path to allow this
Comment 1 Jan Beich freebsd_committer 2018-01-25 08:08:42 UTC
Can you still reproduce after base r328286? If something manages to lose RPATH due to dlopen() or some other trickery then add USES=fortran to inherit LDFLAGS.
Comment 2 Diane Bruce freebsd_committer 2018-02-19 19:14:22 UTC
(In reply to Jan Beich from comment #1)

It's fine now, closing this PR.