Bug 225560 - devel/boehm-gc: update to 7.6.4 and etc
Summary: devel/boehm-gc: update to 7.6.4 and etc
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: Carlos J. Puga Medina
URL:
Keywords:
Depends on: 226183
Blocks:
  Show dependency treegraph
 
Reported: 2018-01-30 12:39 UTC by Yasuhiro KIMURA
Modified: 2018-03-10 13:13 UTC (History)
2 users (show)

See Also:
antoine: exp-run+


Attachments
patch file (9.81 KB, patch)
2018-01-30 12:39 UTC, Yasuhiro KIMURA
no flags Details | Diff
updated patch file (9.45 KB, patch)
2018-02-03 19:46 UTC, Yasuhiro KIMURA
no flags Details | Diff
updated patch file (9.46 KB, patch)
2018-02-22 13:28 UTC, Yasuhiro KIMURA
no flags Details | Diff
updated patch file (10.59 KB, patch)
2018-02-22 21:46 UTC, Yasuhiro KIMURA
no flags Details | Diff
updated patch file (11.64 KB, patch)
2018-02-25 06:54 UTC, Yasuhiro KIMURA
no flags Details | Diff
lang/crystal patch (1.81 KB, patch)
2018-02-26 22:32 UTC, Greg V
no flags Details | Diff
updated patch file (13.11 KB, patch)
2018-02-27 16:26 UTC, Yasuhiro KIMURA
no flags Details | Diff
updated patch file (13.11 KB, patch)
2018-03-10 09:22 UTC, Yasuhiro KIMURA
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Yasuhiro KIMURA 2018-01-30 12:39:34 UTC
Created attachment 190197 [details]
patch file

* Update to 7.6.4
* Regenerate files/patch-include_gc_pthread_redirects.h to fix portlint waring.
* Bump PORTREVISION of depending ports because version number of shared libraries changed.
Comment 1 Yasuhiro KIMURA 2018-02-03 19:46:00 UTC
Created attachment 190304 [details]
updated patch file

Update patch to fit it to latest ports tree. So please commit attached patch instead of original one.
Comment 2 Yasuhiro KIMURA 2018-02-22 13:28:42 UTC
Created attachment 190894 [details]
updated patch file

Update patch to sync with latest ports tree.
So please commit attached patch instead of previous ones.
Comment 3 Yasuhiro KIMURA 2018-02-22 21:46:39 UTC
Created attachment 190907 [details]
updated patch file

Forgot to bump PORTSREVESION of some ports.
So please commit attached patch instead of previous ones.
Comment 4 Antoine Brodin freebsd_committer 2018-02-24 20:51:14 UTC
devel/boehm-gc-threaded fails to package
Comment 5 Antoine Brodin freebsd_committer 2018-02-24 22:28:14 UTC
devel/boehm-gc-redirect fails to package too.
Comment 6 Yasuhiro KIMURA 2018-02-25 06:54:55 UTC
Created attachment 190982 [details]
updated patch file

(In reply to Antoine Brodin from comment #4 and comment #5)

Thank you for feedback. I fixed these errors. And this time I tested following ports with poudriere and 11.1-RELEASE amd64 jail.

devel/boehm-gc
devel/boehm-gc-redirect
devel/boehm-gc-threaded
devel/dparser
devel/shards
devel/shedskin
editors/zile
finance/gnucash
games/aisleriot
games/trackballs
graphics/graphviz
graphics/inkscape
lang/crystal
lang/ecl
lang/guile2
lang/mdk
lang/neko
lang/oo2c
lang/sagittarius-scheme
lang/see
math/asymptote
net-im/freetalk
net-im/gale
textproc/chpp
www/w3m

All but following 3 ports could be built successfully.

* lang/crystal

Build of this port fails with following reason.

1. This port downloads and uses pre-compiled binary to build itself.
2. The pre-compiled binary is dynamically linked to libgc-threaded.so.2.
3. But after devel/boehm-gc is updated to 7.6.4, version number of shared library is changed from 2 to 1.
4. So pre-compiled binary can't run because it can't find proper shared library.
5. Because execution of pre-compiled binary ends with error, build of this port also fails.

So build error can't be fixed unless maintainer of this port provides new pre-compiled binary.

* devel/shards

Build of this port fails because it depends on lang/crystal.

* lang/neko

Build of this port fails because of wrong usage of USE_APACHE_BUILD in Makefile. I fixed it and confirmed this port can be built successfully.
I'm going to report this bug as a different bug report.
Comment 7 Antoine Brodin freebsd_committer 2018-02-26 13:15:17 UTC
Exp-run looks fine  (aside from lang/crystal failure)
Comment 8 Yasuhiro KIMURA 2018-02-26 13:51:49 UTC
(In reply to Yasuhiro KIMURA from comment #6)

About lang/neko update to newer version is submitted as bug #226183 and wrong usage of USE_APACHE_BUILD is also fixed in it.
Comment 9 Carlos J. Puga Medina freebsd_committer 2018-02-26 18:54:25 UTC
Greg,

Would you mind to prepare an update for lang/crystal?

See comment #6 for further details.
Comment 10 Greg V 2018-02-26 22:32:15 UTC
Created attachment 191031 [details]
lang/crystal patch

They changed the version *back* from 2 to 1? wow okay.

Try this patch.

(I wonder what would be a good way to handle this when I switch the port to bootstrap from previously built packages… Download dependencies too, extract them and set LD_LIBRARY_PATH?)
Comment 11 Yasuhiro KIMURA 2018-02-27 16:26:32 UTC
Created attachment 191057 [details]
updated patch file

(In reply to Greg V from comment #10)

Thank you Greg. I merged your patch with mine and confirmed both lang/crystal and devel/shards can be built successfully now.
Comment 12 Yasuhiro KIMURA 2018-03-10 09:22:17 UTC
Created attachment 191369 [details]
updated patch file

Update patch to chase update of lang/neko. So please commit attached patch instead of previous ones.
Comment 13 commit-hook freebsd_committer 2018-03-10 11:10:33 UTC
A commit references this bug:

Author: cpm
Date: Sat Mar 10 11:09:31 UTC 2018
New revision: 464065
URL: https://svnweb.freebsd.org/changeset/ports/464065

Log:
  devel/boehm-gc: update to 7.6.4

  - Regenerate patch to make portlint happy
  - Bump SHLIBS version in pkg-plist

  Changelog: https://github.com/ivmai/bdwgc/releases/tag/v7.6.4

  PR:		225560
  Submitted by:	Yasuhiro KIMURA <yasu@utahime.org>
  Reviewed by:	cpm
  Exp-run by:	antoine

Changes:
  head/devel/boehm-gc/Makefile
  head/devel/boehm-gc/distinfo
  head/devel/boehm-gc/files/patch-doc_gc.man
  head/devel/boehm-gc/files/patch-include_gc_pthread_redirects.h
  head/devel/boehm-gc/pkg-plist
Comment 14 commit-hook freebsd_committer 2018-03-10 11:23:46 UTC
A commit references this bug:

Author: cpm
Date: Sat Mar 10 11:23:01 UTC 2018
New revision: 464068
URL: https://svnweb.freebsd.org/changeset/ports/464068

Log:
  Bump PORTREVISION due upgrade of devel/boehm-gc to 7.6.4

  PR:		225560
  Submitted by:	Yasuhiro KIMURA <yasu@utahime@org>
  Reviewed by:	cpm
  Approved by:	portmgr (antoine)

Changes:
  head/devel/autogen/Makefile
  head/devel/dparser/Makefile
  head/devel/shards/Makefile
  head/devel/shedskin/Makefile
  head/editors/zile/Makefile
  head/finance/gnucash/Makefile
  head/games/aisleriot/Makefile
  head/games/trackballs/Makefile
  head/graphics/graphviz/Makefile
  head/graphics/inkscape/Makefile
  head/lang/ecl/Makefile
  head/lang/guile2/Makefile
  head/lang/mdk/Makefile
  head/lang/neko/Makefile
  head/lang/oo2c/Makefile
  head/lang/sagittarius-scheme/Makefile
  head/lang/see/Makefile
  head/math/asymptote/Makefile
  head/net-im/freetalk/Makefile
  head/net-im/gale/Makefile
  head/textproc/chpp/Makefile
  head/www/w3m/Makefile
Comment 15 Carlos J. Puga Medina freebsd_committer 2018-03-10 11:24:24 UTC
Committed, thanks!
Comment 16 Greg V 2018-03-10 13:06:32 UTC
(In reply to Carlos J. Puga Medina from comment #15)
Looks like you didn't commit the lang/crystal part? (Included in attachment 191369 [details])
Comment 17 Yasuhiro KIMURA 2018-03-10 13:13:12 UTC
(In reply to Greg V from comment #16)

It was committed as ports r464067.