Bug 225902 - editors/emacs editors/emacs-devel: fix configure error when devel/liblockfile is installed
Summary: editors/emacs editors/emacs-devel: fix configure error when devel/liblockfile...
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: Joseph Mingrone
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-02-15 01:11 UTC by Yasuhiro KIMURA
Modified: 2018-02-21 01:17 UTC (History)
3 users (show)

See Also:
yasu: maintainer-feedback? (emacs)


Attachments
patch file (800 bytes, patch)
2018-02-15 01:11 UTC, Yasuhiro KIMURA
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Yasuhiro KIMURA 2018-02-15 01:11:49 UTC
Created attachment 190634 [details]
patch file

Fix configure error when devel/liblockfile is installed.
Comment 1 Joseph Mingrone freebsd_committer 2018-02-16 15:50:57 UTC
Could you elaborate?  I am unable to reproduce this.  Here are poudriere logs for editors/emacs with LIB_DEPENDS=liblockfile.so:devel/liblockfile temporarily added.

http://pkg.awarnach.mathstat.dal.ca/data/10amd64-default/2018-02-16_11h43m44s/logs/emacs-25.3_2,3.log

http://pkg.awarnach.mathstat.dal.ca/data/11amd64-default/2018-02-16_11h31m51s/logs/emacs-25.3_2,3.log
Comment 2 Yasuhiro KIMURA 2018-02-17 07:48:10 UTC
(In reply to Joseph Mingrone from comment #1)

Thank you for feedback. I investigated and found configure error happens only with nox flavor. It is applicable to both editors/emacs and editors/emacs-devel. I also added LIB_DEPENDS=liblockfile.so:devel/liblockfile temporarily and confirmed build of editors/emacs@nox and editors/emacs-devel@nox failed with poudriere.
Comment 3 Joseph Mingrone freebsd_committer 2018-02-20 15:35:45 UTC
Could we get portmgr approval for this?  I will commit this patch (with '=' instead of '+='), but there is a hook preventing the commit because the port has flavors.
Comment 4 commit-hook freebsd_committer 2018-02-20 16:18:08 UTC
A commit references this bug:

Author: jrm
Date: Tue Feb 20 16:17:16 UTC 2018
New revision: 462408
URL: https://svnweb.freebsd.org/changeset/ports/462408

Log:
  editors/emacs@nox, editors/emacs-devel@nox: Fix configure error

  When liblockfile is installed, configure fails, but only for the @nox
  flavors.

  There is an emacs-devel@gnu.org mailing list thread discussing the issue.
  https://lists.gnu.org/archive/html/emacs-devel/2018-02/msg00515.html

  PR:		225902
  Submitted by:	Yasuhiro KIMURA <yasu@utahime.org>

Changes:
  head/editors/emacs/Makefile
  head/editors/emacs-devel/Makefile
Comment 5 Joseph Mingrone freebsd_committer 2018-02-21 01:17:11 UTC
Thanks.