Bug 226729 - www/py-django-allauth: Update to 0.35.0
Summary: www/py-django-allauth: Update to 0.35.0
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Sunpoet Po-Chuan Hsieh
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-03-19 13:52 UTC by vladimir.chukharev
Modified: 2018-03-19 15:39 UTC (History)
0 users

See Also:


Attachments
Patch (975 bytes, patch)
2018-03-19 13:52 UTC, vladimir.chukharev
vladimir.chukharev: maintainer-approval+
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description vladimir.chukharev 2018-03-19 13:52:21 UTC
Created attachment 191630 [details]
Patch

Update www/py-django-allauth from 0.34.0 to 0.35.0.
Comment 1 Sunpoet Po-Chuan Hsieh freebsd_committer 2018-03-19 14:10:07 UTC
Hi,

There are some missing RUN_DEPENDS and py-django-allauth 0.35.0 requires Django 1.11+.

from setup.py:
...
if IS_PY2:
    openid_package = 'python-openid >= 2.2.5'
    test_requirements.append('mock >= 1.0.1')
else:
    openid_package = 'python3-openid >= 3.0.8'
...
    install_requires=['Django >= 1.11',
                      openid_package,
                      'requests-oauthlib >= 0.3.0',
                      "requests"],
Comment 2 commit-hook freebsd_committer 2018-03-19 15:15:02 UTC
A commit references this bug:

Author: sunpoet
Date: Mon Mar 19 15:14:35 UTC 2018
New revision: 465021
URL: https://svnweb.freebsd.org/changeset/ports/465021

Log:
  Update to 0.35.0

  - While I'm here:
    - Update RUN_DEPENDS: use Django metaport (www/py-django)
    - Add missing RUN_DEPENDS

  Changes:	https://github.com/pennersr/django-allauth/blob/master/ChangeLog.rst
  PR:		226729
  Submitted by:	Vladimir Chukharev <Vladimir.Chukharev@gmail.com> (maintainer)

Changes:
  head/www/py-django-allauth/Makefile
  head/www/py-django-allauth/distinfo
Comment 3 Sunpoet Po-Chuan Hsieh freebsd_committer 2018-03-19 15:18:26 UTC
Committed. Thanks!
Comment 4 Sunpoet Po-Chuan Hsieh freebsd_committer 2018-03-19 15:28:52 UTC
Forgot to mention that I changed RUN_DEPENDS from py-django18 to py-django because py-django-allauth 0.34.0 requires Django 1.8+ but 0.35.0 requires Django 1.11+.
Comment 5 vladimir.chukharev 2018-03-19 15:39:58 UTC
Thanks a lot indeed for your help! It would take much more time from me to fix those things.