Bug 226885 - net/ucarp: [PATCH] Switch to Github source tree
Summary: net/ucarp: [PATCH] Switch to Github source tree
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: Yuri Victorovich
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-03-23 23:37 UTC by Artyom Davidov
Modified: 2018-07-18 22:42 UTC (History)
2 users (show)

See Also:


Attachments
patch to use code from GH (1.99 KB, patch)
2018-03-23 23:37 UTC, Artyom Davidov
no flags Details | Diff
patch to use code from GH v2 (2.07 KB, patch)
2018-03-27 16:52 UTC, Artyom Davidov
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Artyom Davidov 2018-03-23 23:37:03 UTC
Created attachment 191764 [details]
patch to use code from GH

Switch to Github source tree since it contains various bugfixes.

The original 1.5.2 was released in early 2010 and since then there were no updates to distfiles. But there were numerous bugfixes and minor feature enhancements that are available on Github.

Also this patch will do the following things:
Fix patch-l2vlan to comply with updated sources.
Require GNU Autotools for build.
Add a dirty fix in the 'pre-configure' section of the Makefile for two missing 'gettextize' files in upstream code.

Don't bump PORTVERSION, just PORTREVISION because upstream is still 1.5.2
Comment 1 Yuri Victorovich freebsd_committer 2018-03-24 02:29:02 UTC
Instead of GH_TAGNAME you should use the identifier that git returns: "git describe --tags"

Also "touch" shouldn't be needed.
Comment 2 Artyom Davidov 2018-03-24 23:27:25 UTC
Hi Yuri,
We cannot use the identifier from "git describe --tags" since there are no tags in that project on GH. So in this particular case we have to fallback to commit identifier. Also the "git describe --always" returns "4f339d4" that is being used in this patch.

Regarding those two "touch" statements in the Makefile - Autotools fails to process the source code when those two files are missing.
If someone knows a better way to work-around this issue, without adding additional build dependencies to port, please share it with me and I'll update this patch accordingly.

wbr,
Artyom
Comment 3 Artyom Davidov 2018-03-26 00:30:37 UTC
Loking at the other ports and handbook I wonder woudn't it be better to include the GH commit date in PORTVERSION instead of bumping PORTREVISION in this case?
Comment 4 Yuri Victorovich freebsd_committer 2018-03-26 00:35:49 UTC
The problem is that the new upstream repository that you change to doesn't indicate that it corresponds to this version.

The best solution would have been if they assigned the version, ex. 1.5.3.
The next best possible solution is to do what you said: to add date to the version.
Comment 5 Artyom Davidov 2018-03-26 17:59:20 UTC
Though new repository doesn't contain any tags o version identifiers, there is a version number that is present in the source code itself. One can check the configure.ac file and several others and see that they contains 1.5.2 in version fields. Also, this version number can be seen in "ucarp -h" output, after software is build.
Considering this I assume that we can set PORTVERSION= 1.5.2.20171201 where 20171201 - is the date of the GH commit with the identifier "4f339d4" that is being referenced in this patch.
If these changes are acceptable I'll update this patch accordingly.
Comment 6 Artyom Davidov 2018-03-27 16:52:37 UTC
Created attachment 191874 [details]
patch to use code from GH v2

Added the 2nd version of the patch.
Use PORTVERSION instead of PORTREVISION.
No other changes from the previous version of the patch.
Comment 7 Artyom Davidov 2018-07-18 15:59:03 UTC
Alexey, Yuri any update on this issue?
Comment 8 Yuri Victorovich freebsd_committer 2018-07-18 22:23:57 UTC
Maintainer reset.
Comment 9 Yuri Victorovich freebsd_committer 2018-07-18 22:41:51 UTC
Committed with changes.
Thank you for your submission!
Comment 10 commit-hook freebsd_committer 2018-07-18 22:42:27 UTC
A commit references this bug:

Author: yuri
Date: Wed Jul 18 22:41:24 UTC 2018
New revision: 474908
URL: https://svnweb.freebsd.org/changeset/ports/474908

Log:
  net/ucarp: Switch to Github source tree

  Port changes:
  * Add license
  * Group USEx section
  * Remove CONFIGURE_ARGS
  * Use option helpers instead of .if/.else

  PR:		226885
  Submitted by:	Artyom Davidov <ard_1@mail.ru>

Changes:
  head/net/ucarp/Makefile
  head/net/ucarp/distinfo
  head/net/ucarp/files/patch-l2vlan