Bug 227337 - net-mgmt/seafile-server setup scripts broken
Summary: net-mgmt/seafile-server setup scripts broken
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Richard Gallamore
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-04-07 01:54 UTC by Greg Fitzgerald
Modified: 2018-04-08 21:35 UTC (History)
0 users

See Also:
bugzilla: maintainer-feedback? (ultima)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Greg Fitzgerald 2018-04-07 01:54:58 UTC
After installing seafile-server you are instructed to run either setup-seafile.sh for sqlite support or setup-seafile-mysql.sh for mysql support.

I first started with setup-seafile.sh for sqlite support as I felt that met my needs. Immediately I'm greated with the following..

```
 ./setup-seafile.sh
The seafile-server diretory doesn't contain all needed files.
Please make sure you have extracted all files and folders from tarball.
Error occured during setup.
Please fix possible issues and run the script again.
```

Next I try the mysql setup script just to get this working and get the following.

```
 ./setup-seafile-mysql.sh
Checking python on this machine ...
  Checking python module: setuptools ... Done.
  Checking python module: python-imaging ...
 python-imaging  is not installed, Please install it first.
On Debian/Ubntu: apt-get install python-imaging
On CentOS/RHEL: yum install python-imaging
Error occured during setup.
Please fix possible problems and run the script again.
```

I don't even see py27-imaging in ports.
Comment 1 Richard Gallamore freebsd_committer 2018-04-08 20:37:39 UTC
# poudriere bulk -i -j 111amd64 -p test www/seahub
......deleted, poudriere setting up env......
root@111amd64-test:~ # cd /usr/local/www/haiwen/seafile-server
root@111amd64-test:/usr/local/www/haiwen/seafile-server # ./setup-seafile.sh
-----------------------------------------------------------------
This script will guide you to config and setup your seafile server.

Make sure you have read seafile server manual at

        https://github.com/haiwen/seafile/wiki

Note: This script will guide your to setup seafile server using sqlite3,
which may have problems if your disk is on a NFS/CIFS/USB.
In these cases, we sugguest you setup seafile server using MySQL.

Press [ENTER] to continue
-----------------------------------------------------------------
Checking packages needed by seafile ...

Checking python on this machine ...
Find python: python2.7

  Checking python module: setuptools ... Done.
  Checking python module: python-imaging ... Done.
  Checking python module: python-sqlite3 ... Done.

Checking for sqlite3 ...Done.

Checking Done.


What would you like to use as the name of this seafile server?
Your seafile users will be able to see the name in their seafile client.
You can use a-z, A-Z, 0-9, _ and -, and the length should be 3 ~ 15
[server name]:



I'm not sure why you would be receiving this error. Suggest trying to reinstall all the dependencies.
Comment 2 Greg Fitzgerald 2018-04-08 20:56:47 UTC
I have a proxmox server. Just created a fresh FreeBSD 11.1 VM ran the install again, ran the script and got the same error.

FreeBSD freebsd 11.1-RELEASE-p9 FreeBSD 11.1-RELEASE-p9 #0: Tue Apr  3 16:59:16 UTC 2018     root@amd64-builder.daemonology.net:/usr/obj/usr/src/sys/GENERIC  amd64
Comment 3 Richard Gallamore freebsd_committer 2018-04-08 21:04:38 UTC
(In reply to Greg Fitzgerald from comment #2)
Oh I see the issue. net-mgmt/seafile-server is a dependency of www/seahub. There must be some dependencies that are required that seahub installs. The base net-mgmt/seafile-server port is more of a dependency than the full application though. If you want to full application then you need www/seahub.

Don't think the developers really intended for it to run without all the ports installed.
Comment 4 Greg Fitzgerald 2018-04-08 21:08:19 UTC
That solved it! Thanks. Is there a way we can add some kind of message some where that explains the server scripts require hub to run? I would have expected pkg install seafile-server to install everything I needed to run a seafile-server. I'm not sure I understand seperating them like this if you can't run one without the other.

Regardless, thank you!
Comment 5 Richard Gallamore freebsd_committer 2018-04-08 21:19:04 UTC
(In reply to Greg Fitzgerald from comment #4)
It wouldn't be possible to list Seahub as a dependency because that would cause a dependency loop. To make this more clear, I am going to move the message of seafile-server to Seahub and change it to something along the lines of seafile-server is a dependency and required Seahub to run the full application. Hopefully, this will make it more clear for future users.
Comment 6 commit-hook freebsd_committer 2018-04-08 21:35:57 UTC
A commit references this bug:

Author: ultima
Date: Sun Apr  8 21:35:40 UTC 2018
New revision: 466834
URL: https://svnweb.freebsd.org/changeset/ports/466834

Log:
  Move net-mgmt/seafile-server's message to seahub and
  change it to clarify that Seahub is required for the
  full application. This will prevent users from being
  confused when installing net-mgmt/seafile-server.

  PR:		227337

Changes:
  head/net-mgmt/seafile-server/Makefile
  head/net-mgmt/seafile-server/files/pkg-message.in
  head/www/seahub/Makefile
  head/www/seahub/files/pkg-message.in