Bug 228115 - java/linux-oracle-jdk18: Seg fault during Matlab R2017b install
Summary: java/linux-oracle-jdk18: Seg fault during Matlab R2017b install
Status: New
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: amd64 Any
: --- Affects Only Me
Assignee: freebsd-java mailing list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-05-10 14:54 UTC by Jason W. Bacon
Modified: 2018-05-10 14:54 UTC (History)
0 users

See Also:
bugzilla: maintainer-feedback? (java)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jason W. Bacon freebsd_committer 2018-05-10 14:54:45 UTC
Crash seems to occur randomly at different points in the installation process.  Sometimes very early, once I almost completed a basic installation.

I've tried with both linux-c6 and linux-c7.

The installer does not work at all with native jdk 1.8.

Preparing installation files ...
Installing ...
#
# A fatal error has been detected by the Java Runtime Environment:
#
#  SIGSEGV (0xb) at pc=0x00000008301e1555, pid=21062, tid=0x0000000845fd2700
#
# JRE version: Java(TM) SE Runtime Environment (8.0_162-b12) (build 1.8.0_162-b12)
# Java VM: Java HotSpot(TM) 64-Bit Server VM (25.162-b12 mixed mode linux-amd64 compressed oops)
# Problematic frame:
# J 361  java.util.zip.Inflater.reset(J)V (0 bytes) @ 0x00000008301e1555 [0x00000008301e1480+0xd5]
#
# Core dump written. Default location: /tmp/mathworks_20909/core or core.21062 (max size 9007199254740991 kB). To ensure a full core dump, try "ulimit -c unlimited" before starting Java again
#
# An error report file with more information is saved as:
# /tmp/mathworks_20909/hs_err_pid21062.log
#
# If you would like to submit a bug report, please visit:
#   http://bugreport.java.com/bugreport/crash.jsp
#
/tmp/mathworks_20909/bin/glnxa64/install_unix: line 918: 21062 Aborted                 (core dumped) "/usr/local/linux-oracle-jdk1.8.0/jre//bin/java" -Xmx512m -splash:"/usr/home/bacon/Matlab/2017b/java/splash.png" -cp /tmp/mathworks_20909/java/config/professionalinstaller/pathlist.jar com/mathworks/professionalinstaller/Launcher -root "/usr/home/bacon/Matlab/2017b" -libdir "/tmp/mathworks_20909" 2> /dev/null
Finished

FreeBSD cray.acadix  bacon ~/Matlab/2017b 1038: df
Filesystem     Size    Used   Avail Capacity  Mounted on
/dev/ada0p2    447G    277G    135G    67%    /
devfs          1.0K    1.0K      0B   100%    /dev
fdescfs        1.0K    1.0K      0B   100%    /dev/fd
procfs         4.0K    4.0K      0B   100%    /proc
linprocfs      4.0K    4.0K      0B   100%    /compat/linux/proc
/dev/da0p1     226G    171G     36G    83%    /Backup

FreeBSD cray.acadix  bacon ~/Matlab/2017b 1039: pkg info |grep linux
linux-c6-alsa-lib-1.1.0_3      Advanced Linux Sound Architecture libraries (Linux CentOS 6.9)
linux-c6-alsa-plugins-oss-1.1.0_3 OSS plugin for ALSA (Linux CentOS 6.9)
linux-c6-atk-1.30.0_2          Accessibility Toolkit (Linux CentOS 6.9)
linux-c6-cairo-1.8.8_8         Vector graphics library Cairo (Linux CentOS 6.9)
linux-c6-curl-7.19.7_9         Command line tool for transferring files with URL syntax (Linux CentOS 6.9)
linux-c6-cyrus-sasl-lib-2.1.23_5 RFC 2222 SASL (Simple Authentication and Security Layer) (Linux CentOS 6.9)
linux-c6-devtools-6.9_7        Linux compilers and base libraries (CentOS 6.9)
linux-c6-dri-11.0.7_5          Mesa libGL runtime libraries (Linux CentOS 6.9)
linux-c6-elfutils-libelf-0.164_2 ELF file handling library (CentOS 6.9)
linux-c6-expat-2.0.1_5         XML 1.0 parser written in C (Linux CentOS 6.9)
linux-c6-fontconfig-2.8.0_3    XML-based font configuration API for X Windows (Linux CentOS 6.9)
linux-c6-gdk-pixbuf2-2.24.1_5  Graphic library for GTK+ (Linux CentOS 6.9)
linux-c6-gtk2-2.24.23_7        GTK+ library, version 2.X (Linux CentOS 6.9)
linux-c6-jasper-libs-1.900.1_4 JPEG-2000 reference implementation (Linux CentOS 6.9)
linux-c6-jpeg-1.2.1_3          SIMD-accelerated JPEG codec (Linux CentOS 6.9)
linux-c6-libgfortran-4.4.7_6   Runtime libraries for gfortran (Linux Centos 6.9)
linux-c6-libpciaccess-0.13.4_2 Generic PCI access library (CentOS 6.9)
linux-c6-libpng-1.2.49_5       Library for manipulating PNG images (Linux CentOS 6.9)
linux-c6-libssh2-1.4.2_6       Library implementing the SSH2 protocol (Linux CentOS 6.9)
linux-c6-libthai-0.1.12_1      Thai language support library (Linux CentOS 6.9)
linux-c6-libtiff-3.9.4_5       Tools and library routines for working with TIFF images (Linux CentOS 6.9)
linux-c6-nspr-4.13.1           Netscape Portable Runtime (Linux CentOS 6the.9)
linux-c6-nss-3.28.4_2          Network Security Services (Linux CentOS 6.9)
linux-c6-openldap-2.4.40_5     Lightweight Directory Access Protocol libraries (Linux CentOS 6.9)
linux-c6-openssl-1.0.1e_15     OpenSSL toolkit (Linux CentOS 6.9)
linux-c6-pango-1.28.1_7        Pango library (Linux CentOS 6.9)
linux-c6-pixman-0.32.8_1       Low-level pixel manipulation library (Linux CentOS 6.9)
linux-c6-sqlite-3.6.20_4       Library that implements an embeddable SQL database engine (Linux CentOS 6.9)
linux-c6-xorg-libs-7.4_10      Xorg libraries (Linux CentOS 6.9)
linux-flashplayer-27.0.0.183   Adobe Flash Player NPAPI Plugin
linux-oracle-jdk18-8.162       Oracle Java 8 Development Kit for Linux
linux_base-c6-6.9_7            Base set of packages needed in Linux mode (Linux CentOS 6.9)
linuxlibertine-g-20120116_1    Linux Libertine G and Linux Biolinum G fonts

FreeBSD cray.acadix  bacon ~/Matlab/2017b 1040: uname -a
FreeBSD cray.acadix.biz 11.1-RELEASE-p10 FreeBSD 11.1-RELEASE-p10 #0: Tue May  8 05:21:56 UTC 2018     root@amd64-builder.daemonology.net:/usr/obj/usr/src/sys/GENERIC  amd64