Bug 228334 - lte 4g network problems
Summary: lte 4g network problems
Status: Closed Not A Bug
Alias: None
Product: Base System
Classification: Unclassified
Component: misc (show other bugs)
Version: 11.1-RELEASE
Hardware: amd64 Any
: --- Affects Some People
Assignee: freebsd-net mailing list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-05-18 13:43 UTC by SF
Modified: 2018-08-02 10:36 UTC (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description SF 2018-05-18 13:43:38 UTC
I am using the ipfw firewall and recognised after a while of testing that freebsd is having connection problems with lte. Something is wrong the freebsd interacts with my lte-router. The packets it sends or something like this are wrong.

If i remove the "keep-state" command from my ipfw-firewall settings then i dont get any connection to the internet anymore. If i use the keep-state command within all my firewall-settings then the internet works almost flawlessly for browsing.

I only get connection-problems using wine with steam on freebsd, readjusting the mtu via ifconfig influences the stability of the connection. Sometimes it takes very long to log in on steam and steam always crashes after a few minutes. Setting cpu-frequency also affects stability of wine with steam.

This seems connected together, the keep-state command removes load from cpu if i remember right.

So whats wrong with this? With my previous internet-provider i didn't had any of such problems, changing to 4g lte caused me several problems. Signal-quality is almost on top.

Freebsd is somehow sending packets too slow or something, i don't know.
Comment 1 Eugene Grosbein freebsd_committer 2018-05-19 10:09:30 UTC
It is impossible to help you at the moment as you did not supply any technical details of the problem: used FreeBSD version, model of your networking hardware, configuration of FreeBSD, nothing. You should either switch to mailing lists of web forums for general discussion or add detailed description of your setup to this report.
Comment 2 SF 2018-05-19 12:34:11 UTC
Sorry, i was about to place some sentence about this. Iam new to os-development and iam unable to deliver such data.

re0: <RealTek 8168/8111 B/C/CP/D/DP/E/F/G PCIe Gigabit Ethernet> port 0xf000-0xf0ff mem 0xf7604000-0xf7604fff,0xf7600000-0xf7603fff irq 32 at device 0.0 on pci3
re0: Using 1 MSI-X message
re0: Chip rev. 0x54000000
re0: MAC rev. 0x00100000
miibus0: <MII bus> on re0
rgephy0: <RTL8251 1000BASE-T media interface> PHY 1 on miibus0
rgephy0:  none, 10baseT, 10baseT-FDX, 10baseT-FDX-flow, 100baseTX, 100baseTX-FDX, 100baseTX-FDX-flow, 1000baseT-FDX, 1000baseT-FDX-master, 1000baseT-FDX-flow, 1000baseT-FDX-flow-master, auto, auto-flow
re0: Using defaults for TSO: 65518/35/2048
re0: Ethernet address: 88:d7:f6:7a:66:d9
re0: netmap queues/slots: TX 1/256, RX 1/256
Comment 3 Eugene Grosbein freebsd_committer 2018-05-19 17:12:08 UTC
(In reply to SF from comment #2)

This is just your Ethernet card. Do you connect your LTE router to FreeBSD using wired Ethernet, or USB, or some wireless card?

You mentioned troubles with ipfw, so please show your /etc/rc.conf and firewall configuration.

What exactly are "cpu-frequency" settings you also mentioned?
Comment 4 SF 2018-05-19 18:52:39 UTC
It is no good idea posting configurations like this because it will show weaknesses of my pc.

The keep-state argument, if i remember right, is made to avoid cpu-load.

Setting cpu-frequency to 2ghz makes steam very unstable, having 3ghz+ allows it to run around 5mins before crashing.

The normal internet-browser doesn't work without the keep-state argument and steam is also affected by cpu-frequency settings. This means something within the os is wrong, my firewallsettings are as effective as possible.

more stability via Steam:
ifconfig re0 mtu 1500 -> 2000

less stability via Steam:
ifconfig re0 mtu 1500 -> 1000

Playing a game on lte which causes high cpu-load also suffers alot of crashes.

The router is connected with rj45, no way changing mtu-settings on it without using hacked firmware and iam not using this kind of firmware because of security.

Why does anything that speeds up cableinteraction between computer and router affects network-stability that much?
Comment 5 Eugene Grosbein freebsd_committer 2018-05-20 01:17:47 UTC
(In reply to SF from comment #4)

> It is no good idea posting configurations like this because it will show weaknesses of my pc.

It would not be quick nor easy to solve your problem unless show your setup.

> The keep-state argument, if i remember right, is made to avoid cpu-load.

Not exactly. Addition of ipfw keep-state changes the way ipfw operates from stateless to stateful operations and stateful mode generally takes more CPU load.

> Setting cpu-frequency to 2ghz makes steam very unstable, having 3ghz+ allows it to run around 5mins before crashing.

It is still not clear why and how do you change CPU frequency and what exacly do you mean by "crashing" - system reboots? Kernel hangs or panices? Some graphics subsystem problems? Or just some application exits abnormally? Please describe the problem in details because nobody sees your desktop other than you.

And you should not arbitrary modify MTU value when you are connecting to public internet services, or else you can get in multiple connectivity problems.
Comment 6 SF 2018-05-20 01:31:38 UTC
Connection loss due to timeout, this happens on high cpu-load or on low cpu-performance settings.

This happens with steam and with my normal internet-browser and with launchers from other games, everything that is related to browsing. If running normal clients without webcontent then my connection is stable and the program isn't crashing. The only program wihch got similiarly influenced like programs with webcontent caused high cpu-loads, increasing cpu-frequency did decrease crashs of this program.

We need to bypass the part of publicing my configuration, i will give more details if necessary but all ports are open which are relevant to browsing and using wine or something else. I also tryed opening different kinds of ports and things like this, i did alot of tweaking to my firewall but nothing of it except of "keep-state" did influence this in any way.
Comment 7 Eugene Grosbein freebsd_committer 2018-05-20 01:40:22 UTC
This does not seem like bug report but request for help with some hardware and/or network connectivity problem. It seems you should use FreeBSD web forums or mailing lists to discuss the matter.
Comment 8 SF 2018-05-20 01:45:20 UTC
Why? Iam not much into os-debugging. It's a bug, its appearing with programs on bsd and the only hint i have is its beaing affected by cpu-load/performance which makes me writing this report. I don't know whats wrong and there is no way to change some settings on bsd to do something more, its not happening on wired internet.
Comment 9 SF 2018-05-22 21:20:08 UTC
Setting mtu via ifconfig and readjusting some firewallsettings did entirely solve it. This router needs a better antenna, thats it. The part about keep-state was wrong, i did forget about the bidirectional part but increasing cpu-performance does help with lte internet.
Comment 10 SF 2018-08-02 10:36:57 UTC
Change nameserver to e.x. opendns, stable without any issue.

/etc/resolv.conf

nameserver 208.67.222.222

options timeout:2
options attempts:100