Bug 228392 - databases/qt4-mysql-plugin: compile errors related to "my_bool"
Summary: databases/qt4-mysql-plugin: compile errors related to "my_bool"
Status: Closed DUPLICATE of bug 227813
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: amd64 Any
: --- Affects Only Me
Assignee: freebsd-kde (Team)
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-05-21 10:21 UTC by Yunchih Chen
Modified: 2018-05-22 08:08 UTC (History)
1 user (show)

See Also:
bugzilla: maintainer-feedback? (kde)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Yunchih Chen 2018-05-21 10:21:27 UTC
Error:

../qt-everywhere-opensource-src-4.8.7/src/sql/drivers/mysql/qsql_mysql.cpp:963:33: error: assigning to 'my_bool *' (aka 'char *') from incompatible type 'bool *'
            currBind->is_null = &nullVector[i];
                                ^~~~~~~~~~~~~~


Complete log:
https://pkgbuild.csie.ntu.edu.tw/pkg-stat/data/freebsd11-default-workstation/2018-05-20_08h41m01s/logs/errors/qt4-mysql-plugin-4.8.7_4.log

Maybe related to this:
https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=227813
Comment 1 Adriaan de Groot freebsd_committer 2018-05-21 13:04:19 UTC
r469165 is supposed to fix this. Your build log shows you have that version. My best guess is that the version check done in that patch (#if MYSQL_VERSION_ID >= 80001) is true (so that we use bool for mysql_bool) while your MySQL (Maria?) headers don't use that yet.
Comment 2 Yunchih Chen 2018-05-22 08:07:17 UTC
Hi, Adriaan:

Thanks for the reply.

Indeed, as it's listed:

DEFAULT_VERSIONS+= mysql=101m bdb=5

we are using MariaDB 10.1.

But the patch only applies to MySQL, so in my case I must temporarily remove the patch in order to build successfully.  Maybe OP should take MariaDB into account.
Comment 3 Yunchih Chen 2018-05-22 08:08:04 UTC

*** This bug has been marked as a duplicate of bug 227813 ***