Bug 228770 - net/py-urllib3: 1.23 update breaks cmake (due to www/requests pinning < 1.23)
Summary: net/py-urllib3: 1.23 update breaks cmake (due to www/requests pinning < 1.23)
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Antoine Brodin
URL:
Keywords: regression
Depends on:
Blocks:
 
Reported: 2018-06-05 20:23 UTC by Marco Beishuizen
Modified: 2019-01-22 03:23 UTC (History)
5 users (show)

See Also:


Attachments
Poudriere build log on 11.1-REL (168.66 KB, text/plain)
2018-06-05 20:57 UTC, Bengt Ahlgren
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Marco Beishuizen 2018-06-05 20:23:46 UTC
The upgrade of cmake to 3.11.3 fails because py-urllib3 was updated today to the new version 1.23, but cmake requires < 1.23:

[...]
===>  Building for cmake-3.11.3                                                                                                                                       
Scanning dependencies of target documentation                                                                                                                         
Scanning dependencies of target cmcompress                                                                                                                            
[  1%] sphinx-build man: see Utilities/Sphinx/build-man.log                                                                                                           
[  1%] Building C object Utilities/cmcompress/CMakeFiles/cmcompress.dir/cmcompre                                                                                      ss.c.o                                                                                                  
Scanning dependencies of target cmsys_c                                                                                                                               
[  1%] Building C object Source/kwsys/CMakeFiles/cmsys_c.dir/ProcessUNIX.c.o                                                                                          
Scanning dependencies of target cmsys                                                                                                                                 
[  2%] Building C object Source/kwsys/CMakeFiles/cmsys.dir/ProcessUNIX.c.o                                                                                            
[  2%] Linking C static library libcmcompress.a                                                                                                                       
[  2%] Built target cmcompress                                                                                                                                        
[  3%] Building C object Source/kwsys/CMakeFiles/cmsys_c.dir/Base64.c.o                                                                                               
[  3%] Building C object Source/kwsys/CMakeFiles/cmsys.dir/Base64.c.o                                                                                                 
[  3%] Building C object Source/kwsys/CMakeFiles/cmsys_c.dir/EncodingC.c.o                                                                                            
[  3%] Building C object Source/kwsys/CMakeFiles/cmsys.dir/EncodingC.c.o                                                                                              
Traceback (most recent call last):                                                                                                                                    
  File "/usr/local/bin/sphinx-build", line 6, in <module>                                                                                                             
    from pkg_resources import load_entry_point                                                                                                                        
  File "/usr/local/lib/python2.7/site-packages/pkg_resources/__init__.py", line                                                                                       3095, in <module>                                                                                                                                   
    @_call_aside                                                                                                                                
  File "/usr/local/lib/python2.7/site-packages/pkg_resources/__init__.py", line                                                                                       3079, in _call_aside                                                                                                                                            
    f(*args, **kwargs)                                                                                                                                                
  File "/usr/local/lib/python2.7/site-packages/pkg_resources/__init__.py", line                                                                                       3108, in _initialize_master_working_set                                                                                                                               
    working_set = WorkingSet._build_master()                                                                                                                          
  File "/usr/local/lib/python2.7/site-packages/pkg_resources/__init__.py", line                                                                                       572, in _build_master                                                                                                                                               
    return cls._build_from_requirements(__requires__)                                                                                                                 
  File "/usr/local/lib/python2.7/site-packages/pkg_resources/__init__.py", line                                                                                       585, in _build_from_requirements                                                                                                                                      
    dists = ws.resolve(reqs, Environment())                                                                                                                           
  File "/usr/local/lib/python2.7/site-packages/pkg_resources/__init__.py", line                                                                                       774, in resolve                                                                                                                             
    raise DistributionNotFound(req, requirers)                                                                                                                        
pkg_resources.DistributionNotFound: The 'urllib3<1.23,>=1.21.1' distribution was                                                                                       not found and is required by requests                                                                                                                                
[  3%] Building C object Source/kwsys/CMakeFiles/cmsys_c.dir/MD5.c.o                                                                                                  
--- Utilities/Sphinx/doc_format_man ---                                                                                                                               
*** [Utilities/Sphinx/doc_format_man] Error code 1                                                                                                                    

make[4]: stopped in /usr/ports/devel/cmake/work/cmake-3.11.3                                                                                                          
1 error
[...]

My uname -a:
FreeBSD yokozuna 11.1-STABLE FreeBSD 11.1-STABLE #0 r328478: Sat Jan 27 22:31:28 CET 2018     root@yokozuna:/usr/obj/usr/src/sys/YOKOZUNA  amd64
Comment 1 Bengt Ahlgren 2018-06-05 20:57:19 UTC
Created attachment 194032 [details]
Poudriere build log on 11.1-REL

Me too, but somewhat different log - see attachment!
Comment 2 Tobias C. Berner freebsd_committer 2018-06-05 20:58:59 UTC
The change has been reverted by antoine:
https://svnweb.freebsd.org/ports?view=revision&revision=471820


mfg Tobias
Comment 3 Kubilay Kocak freebsd_committer freebsd_triage 2018-06-10 04:00:56 UTC
Issues resolved by commits are (fixed) with committer -> Assignee

Root cause of this is requests pinning (capping) the urllib3 package to <1.23.

request and urllib3 should probably be updated in tandem for now, at least until requests unpins (uncaps) urllib3.