Bug 229370 - mail/postfixadmin: Update to 3.2
Summary: mail/postfixadmin: Update to 3.2
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Many People
Assignee: Jochen Neumeister
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-06-27 16:18 UTC by Melissa Pilgrim
Modified: 2018-09-18 03:44 UTC (History)
1 user (show)

See Also:
ports.maintainer: maintainer-feedback+


Attachments
Update to v3.2 (39.44 KB, patch)
2018-06-27 16:18 UTC, Melissa Pilgrim
ports.maintainer: maintainer-approval+
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Melissa Pilgrim 2018-06-27 16:18:16 UTC
Created attachment 194681 [details]
Update to v3.2

Update postfixadmin to 3.2.

This update depends on the dependency fix to archivers/php71-phar submitted in bug 229368.  If this is committed before that fix, users of postfixadmin who update will get a PharException error about openssl not being loaded.
Comment 1 commit-hook freebsd_committer 2018-09-04 19:25:35 UTC
A commit references this bug:

Author: joneum
Date: Tue Sep  4 19:25:13 UTC 2018
New revision: 478986
URL: https://svnweb.freebsd.org/changeset/ports/478986

Log:
  Update to 3.2

    - move public facing stuff into public/, this allows us to stop exposing
      templates_c/ etc. to the world (but also means you'll need to adjust your
      webserver config)
    - enable users to reset their passwords by mail or SMS
      ($CONF['forgotten_user_password_reset'],
      $CONF['forgotten_admin_password_reset'], $CONF['sms_send_function'])
    - allow local alias targets (without @domain) - see #134
    - add $CONF['edit_alias'] to disable "edit_alias" function for users
    - add php_crypt $CONF["encrypt"] option (see #170 for examples)
    - add random_compat phar (see: https://github.com/paragonie/random_compat) to
      support random_int()/random_string() in older PHP versions.
    - add support for MySQL connections over SSL
    - language updates: sk, ja, nl, bg, fr, cz
    - update bundled smarty library (lib/smarty to 3.1.32; includes security fixes)
    - split up pacrypt() into different functions; add some minimal test coverage
    - add id autoincrement field to log table (#89)
    - add token to login.php to prevent CSRF
    - lots of bugfixes and code cleanup
    - drop unused code in postfixadmin-cli
    - introduce PHP-CS-Fixer to enforce code style
    - vacation.pl:
      - avoid answering to more known autoresponders
      - add $no_vacation_pattern to avoid sending autoresponders based on the To:
        address
      - replace Deprecated Mail::Sender by Email::Sender
      - use MIME:EncWords
      - remove unused MIME::Base64
  - add docker repo, see https://github.com/postfixadmin/docker

  PR:		229370
  Submitted by:	Melissa Pilgrim <ports.maintainer@evilphi.com> (maintainer)
  Sponsored by:	Netzkommune

Changes:
  head/mail/postfixadmin/Makefile
  head/mail/postfixadmin/distinfo
  head/mail/postfixadmin/files/pkg-message.in
  head/mail/postfixadmin/pkg-plist
Comment 2 Melissa Pilgrim 2018-09-07 23:10:20 UTC
(In reply to commit-hook from comment #1)

That was committed prematurely. The dependency on Bug 229368 was not trivial and not yet resolved.  The in-tree version is now broken per my opening comment on this bug. Please revert this commit.
Comment 3 Melissa Pilgrim 2018-09-17 10:50:15 UTC
Can be closed. Fixed in bug 231424
Comment 4 Kubilay Kocak freebsd_committer freebsd_triage 2018-09-18 03:44:24 UTC
Resolving the regression should have continued here, potentially escalating to portmgr for a revert, though I understand why a new bug (bug 231424) was created (lack of response, see comment 2)

Original patch has been committed, therefore resolve closed/fixed, removing bug 229368 as a blocker (in order to close). The regression due to this change is being addressed in bug 231424