Bug 229931 - cad/calculix: doesn't build after 2.14 update
Summary: cad/calculix: doesn't build after 2.14 update
Status: Closed Overcome By Events
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Pedro F. Giffuni
URL:
Keywords: regression
Depends on:
Blocks:
 
Reported: 2018-07-21 18:28 UTC by rsmith
Modified: 2018-12-18 14:57 UTC (History)
1 user (show)

See Also:
pfg: maintainer-feedback+


Attachments
git diff for the port directory. (3.38 KB, patch)
2018-07-21 18:28 UTC, rsmith
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description rsmith 2018-07-21 18:28:53 UTC
Created attachment 195340 [details]
git diff for the port directory.

After the 228260 update to 2.14, re-building this port failed for me.

There are a couple of issues:
1) The distfiles have changed.
2) The source directory lists itself as version 2.14.1, even though the tarball is still called 2.14.
3) The executable lists says it's 2.14.1

ad 1:

>ls -l /usr/ports/distfiles/calculix/cgx_2.14.*
-rw-r--r--  1 root  wheel  - 1308087 Jul 21 11:03 /usr/ports/distfiles/calculix/cgx_2.14.pdf
-rw-r--r--  1 root  wheel  -  338235 Jul 21 11:03 /usr/ports/distfiles/calculix/cgx_2.14.htm.tar.bz2
-rw-r--r--  1 root  wheel  - 3928431 Jul 21 11:03 /usr/ports/distfiles/calculix/cgx_2.14.exa.tar.bz2
-rw-r--r--  1 root  wheel  - 5451218 Jul 21 11:03 /usr/ports/distfiles/calculix/cgx_2.14.all.tar.bz2

> sha256 /usr/ports/distfiles/calculix/cgx_2.14.*
SHA256 (/usr/ports/distfiles/calculix/cgx_2.14.all.tar.bz2) = 07658fcf2c00489cad16b58c6065ca8402c974f2c7e9d3e9dbca87cfd7275d12
SHA256 (/usr/ports/distfiles/calculix/cgx_2.14.exa.tar.bz2) = 78dbd438b64e68af48cec0c34fd76ab79d11aa0c7fcceb7357cf107fb203c2da
SHA256 (/usr/ports/distfiles/calculix/cgx_2.14.htm.tar.bz2) = 280b5f76d3a6c61772fa50eeabca043b53d4083fcf186d1c80bfe5669398e6ea
SHA256 (/usr/ports/distfiles/calculix/cgx_2.14.pdf) = b933bddbd21184931f2253d77eca63b9cf92a52d808660f27a636b742b328060

ad 2:

> tar tf /usr/ports/distfiles/calculix/cgx_2.14.all.tar.bz2 | head -n 1
CalculiX/cgx_2.14.1/

It looks like the distfiles were remade?

I made some changes to the port to make it compile. A patch is attached.
I left the PORTVERSION as 2.14. Not sure what is the right thing to do in a case like this.
Comment 1 Pedro F. Giffuni freebsd_committer 2018-07-22 01:08:42 UTC
Hello;

Sorry for the delay, I have been very busy.

(In reply to rsmith from comment #0)

Indeed, upstream tends to do silent updates to the tarballs without notifying anyone. We need to bump the port revision but your patch seems OK.

CCing swills as he did the last commit and may be getting the same spam I do :-/.
Comment 2 Pedro F. Giffuni freebsd_committer 2018-12-18 14:57:44 UTC
The fix won't work anymore since 2.15 has been released.