Bug 230090 - FreeBSD 12-CURRENT r336739 on Asus H87M-E: UEFI Loader stays stuck at BootOrder line with ZFS on Root
Summary: FreeBSD 12-CURRENT r336739 on Asus H87M-E: UEFI Loader stays stuck at BootOrd...
Status: Closed Overcome By Events
Alias: None
Product: Base System
Classification: Unclassified
Component: misc (show other bugs)
Version: CURRENT
Hardware: Any Any
: --- Affects Only Me
Assignee: freebsd-bugs mailing list
URL:
Keywords: regression
Depends on:
Blocks:
 
Reported: 2018-07-27 17:46 UTC by Neel Chauhan
Modified: 2019-09-20 20:28 UTC (History)
3 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Neel Chauhan 2018-07-27 17:46:11 UTC
When I run FreeBSD 12-CURRENT r336739 on a homebuilt PC with an Asus H87M-E motherboard and try to use the UEFI Bootloader if I have my main partition as ZFS, I get stuck at the BootOrder line. I do not have this problem on the same computer in BIOS/CSM mode or when booting via USB with UEFI, nor do I have this problem on a HP EliteBook 1040 G3 in UEFI mode with ZFS on Root.
Comment 1 Robert Zelaya 2018-08-15 21:06:17 UTC
ISSUE:

I am having the same issue on FreeBSD 12-CURRENT amd64 20180726 r336739 efi zfs root and a ASUS H87I-PLUS motherboard. After I install FreeBSD I get stuck at the BootOrder line. I have also found that Refind can not boot FreeBSD boot1.efi. The only way it fix the boot issue is to use efibootmgr on linux.

FreeBSD should write to the bios boot manager after installation.

FIX:

Boot a Linux Live CD distro that has efibootmgr. Issue this command.
"sudo efibootmgr -c -d /dev/sda -p 1 -L FreeBSD -l /EFI/FreeBSD/boot1.efi"
Where "-d /dev/sda" is your boot disk, "-p 1" is the EFI partion number, -L is the uefi label name and -l is the path to boot1.efi. You may have to change the uefi boot order in the bios as an extra step.
Comment 2 Allan Jude freebsd_committer 2018-08-29 03:02:24 UTC
Can you try using /boot/loader.efi instead of /boot/boot1.efi as the boot\bootx64.efi file?
Comment 3 Robert Zelaya 2018-08-30 01:13:39 UTC
With Refind I tried loader.efi and boot1.efi. Both did not work.
As for renaming /boot/loader.efi and /boot/loader.efi to 

/boot/loader.efi instead of /boot/boot1.efi to boot\bootx64.efi. I dont remember trying that. I believe I did though.
Comment 4 Yuri Victorovich freebsd_committer 2018-09-29 23:56:53 UTC
see also bug#219957
Comment 5 Neel Chauhan 2019-09-20 20:28:38 UTC
This is no longer an issue with 12.0-RELEASE.