Bug 230283 - sysutils/py-pywatchman: Update to 1.4.1
Summary: sysutils/py-pywatchman: Update to 1.4.1
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Martin Wilke
URL:
Keywords:
Depends on: 231209
Blocks:
  Show dependency treegraph
 
Reported: 2018-08-02 01:59 UTC by Nathan
Modified: 2019-01-11 14:41 UTC (History)
3 users (show)

See Also:
bugzilla: maintainer-feedback? (linpct)


Attachments
Update (1.17 KB, patch)
2018-08-02 01:59 UTC, Nathan
no flags Details | Diff
Poudriere Log python 3 (23.42 KB, text/plain)
2018-08-02 02:00 UTC, Nathan
no flags Details
Poudriere Log for py2.7 (23.06 KB, text/plain)
2018-08-02 02:00 UTC, Nathan
no flags Details
Update; Add test switch (2.10 KB, patch)
2018-09-06 02:31 UTC, Nathan
no flags Details | Diff
Update; Add test switch (2.01 KB, patch)
2018-09-06 22:35 UTC, Nathan
ndowens04: maintainer-approval? (linpct)
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Nathan 2018-08-02 01:59:12 UTC
Created attachment 195748 [details]
Update

Update supports both Py2 and Py3 versions

Portlint: OK
Comment 1 Nathan 2018-08-02 02:00:05 UTC
Created attachment 195749 [details]
Poudriere Log python 3
Comment 2 Nathan 2018-08-02 02:00:52 UTC
Created attachment 195750 [details]
Poudriere Log for py2.7
Comment 3 Nathan 2018-09-06 02:31:09 UTC
Created attachment 196906 [details]
Update; Add test switch


sysutils/py-pywatchman

* Update to 4.9.0
* Switch source to github
  -- Newer versions available
* Removed find in post-install
  -- No need of finding only one file
     to strip
* Add if arm* use python2.7
  -- py36 causes error of files touched
     the filesystem

portlint -AC: looks fine
poudriere(amd64/i386) 11.2 12-cur: Built fine
poudriere(armv6/arm64) 11.2 : Built fine

@py27 worked fine
@py36 all but on armv6/arm64 worked(added switch to only use py27 on these)

make test: 100% Pass
Comment 4 linpct 2018-09-06 06:40:41 UTC
(In reply to Nathan from comment #3)
I could not build at my machine, log: https://paste2.org/UvgD89vd
Comment 5 Nathan 2018-09-06 10:24:52 UTC
(In reply to linpct from comment #4)
Can you paste the full log
Comment 6 Nathan 2018-09-06 11:08:12 UTC
From what it looks like, you’re building the regular watchman version 4.6.
Comment 7 Nathan 2018-09-06 11:16:50 UTC
Yeah that’s actual watchman error and not this port. Plan to update sysutils/watchman
Comment 8 Nathan 2018-09-06 13:45:56 UTC
(In reply to Nathan from comment #7)
Running into snags on updating watchman but I think I can get around it once I get time
Comment 9 linpct 2018-09-06 14:04:46 UTC
(In reply to Nathan from comment #8)
Hi, sorry I forgot that's watchman error, not pywatchman.

Please check this error log (with pkg install watchman 4.5)
https://paste2.org/LMU7V66A

Thanks.
Comment 10 Nathan 2018-09-06 14:21:07 UTC
(In reply to linpct from comment #9)
Looks like I’m gonna have to switch it back to find as if using py36 it doesn’t get stripped
Comment 11 Nathan 2018-09-06 22:35:57 UTC
Created attachment 196931 [details]
Update; Add test switch

sysutils/py-pywatchman:

* Update to 4.9.0
* Add missing LICENSE info
* Add if armv6,aarch64 to use only py27
  -- if py36 is used, some file touches filesystem

Portlint -AC: Seems fine

poudriere (amd64/i386) 11.2 12.0: Built
poudriere (armv6/arm64) 11.2 : Built
Comment 12 commit-hook freebsd_committer 2019-01-11 14:41:38 UTC
A commit references this bug:

Author: miwi
Date: Fri Jan 11 14:41:08 UTC 2019
New revision: 489974
URL: https://svnweb.freebsd.org/changeset/ports/489974

Log:
  - Update to 4.9.0
  - Add missing LICENSE info
  - Support python36 for i386/amd64
  - Fallback on armv6,aarch64 to py27
  - Switch to github

  PR:		230283
  Submitted by:	ndowens@yahoo.com
  Approved by:	maintainer
  Sponsored by:	iXsystems Inc.

Changes:
  head/sysutils/py-pywatchman/Makefile
  head/sysutils/py-pywatchman/distinfo