Bug 230437 - java/openjdk7: fails to install because of xorgproto change
Summary: java/openjdk7: fails to install because of xorgproto change
Status: Closed Unable to Reproduce
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: Greg Lewis
URL:
Keywords: needs-qa
Depends on:
Blocks:
 
Reported: 2018-08-07 12:13 UTC by Alejandro Bednarik
Modified: 2019-01-06 08:39 UTC (History)
2 users (show)

See Also:
bugzilla: maintainer-feedback? (glewis)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Alejandro Bednarik 2018-08-07 12:13:08 UTC
Today we tried to install java/openjdk7 and we found an issue. After this change https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=230023 regarding xorgproto, we are unable to install openjdk due to dependencies in this package which conflicts with old individual protocol packages from xorg


pkg install java/openjdk7
Updating FreeBSD repository catalogue...
FreeBSD repository is up to date.
Updating Perceptyx repository catalogue...
Perceptyx repository is up to date.
All repositories are up to date.
Checking integrity... done (7 conflicting)
  - recordproto-1.14.2 [FreeBSD] conflicts with xorgproto-2018.4 [installed] on /usr/local/include/X11/extensions/recordconst.h
  - xproto-7.0.31 [FreeBSD] conflicts with xorgproto-2018.4 [installed] on /usr/local/include/X11/DECkeysym.h
  - kbproto-1.0.7 [FreeBSD] conflicts with xorgproto-2018.4 [installed] on /usr/local/include/X11/extensions/XKB.h
  - fixesproto-5.0 [FreeBSD] conflicts with xorgproto-2018.4 [installed] on /usr/local/include/X11/extensions/xfixesproto.h
  - xextproto-7.3.0 [FreeBSD] conflicts with xorgproto-2018.4 [installed] on /usr/local/include/X11/extensions/EVI.h
  - inputproto-2.3.2 [FreeBSD] conflicts with xorgproto-2018.4 [installed] on /usr/local/include/X11/extensions/XI.h
  - renderproto-0.11.1 [FreeBSD] conflicts with xorgproto-2018.4 [installed] on /usr/local/include/X11/extensions/render.h
Cannot solve problem using SAT solver, trying another plan
Checking integrity... done (0 conflicting)
The most recent version of packages are already installed
Comment 1 Niclas Zeising freebsd_committer 2018-08-07 15:45:49 UTC
This looks like the openjdk package hasn't been updated or rebuilt since the change of the *proto ports.  From a quick glance at the makefile, I see nothing that indicates openjdk7 depends on the proto ports, but this might be hidden somewhere.
Comment 2 Michael Osipov 2018-08-11 10:25:38 UTC
You can request pkg to force-remove those old packages and retry. I had the same issue with other ports.
Comment 3 Tobias Kortkamp freebsd_committer 2019-01-06 08:39:32 UTC
Due to 11.2-RELEASE and 12.0-RELEASE packages on https://pkg.FreeBSD.org have
surely been all rebuilt by now at least once.