Bug 230814 - audio/icecast-kh: Crashes on vorbis source drop.
Summary: audio/icecast-kh: Crashes on vorbis source drop.
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Many People
Assignee: Tobias Kortkamp
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-08-22 09:51 UTC by shon
Modified: 2018-12-07 13:40 UTC (History)
2 users (show)

See Also:
tobik: maintainer-feedback-


Attachments
Patch file generated with svn diff (6.06 KB, patch)
2018-08-27 13:47 UTC, Samy Mahmoudi
no flags Details | Diff
Patch file generated with svn diff (6.06 KB, patch)
2018-08-27 13:49 UTC, Samy Mahmoudi
no flags Details | Diff
Patch file generated with svn diff (5.27 KB, patch)
2018-08-29 12:11 UTC, Samy Mahmoudi
no flags Details | Diff
Patch file generated with svn diff (4.85 KB, patch)
2018-08-29 15:52 UTC, Samy Mahmoudi
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description shon 2018-08-22 09:51:17 UTC
Running icecast-kh v2.3.3-kh10, using Traktor as a source, to the icecast server using ogg-vorbis 44100 192kbps. When Traktor disconnects, the icecast server crashes immediately.


[2018-08-22  02:03:26] INFO source/source_apply_mount Applying mount information for "/stream"
[2018-08-22  02:03:26] INFO source/source_startup source /stream is ready to start
[2018-08-22  02:03:26] INFO source/source_init Source /stream initialised
[2018-08-22  02:03:26] INFO source/source_read listener count on /stream now 0
[2018-08-22  02:03:26] INFO format-vorbis/initial_vorbis_page seen initial vorbis header
[2018-08-22  02:03:27] INFO source/source_set_override for /stream set to /jarbu192.mp3
[2018-08-22  02:03:28] INFO source/source_read End of Stream /stream
[2018-08-22  02:03:28] INFO source/source_shutdown Source "/stream" exiting
[2018-08-22  02:03:28] INFO source/source_set_fallback fallback on /stream to /stream192.ogg, but no listeners
[2018-08-22  02:03:28] INFO source/source_client_read no more listeners on /stream
[2018-08-22  02:03:28] EROR thread/rwlock unlock error triggered at 0x80557e2b8, source.c:317 (1)

no core file is created on the crash.

Operating on FreeBSD-amd64 10.4-RELEASE-p9

This is reproducible. Download Traktor 2 Pro Demo, install it on a machine, set up the broadcast settings to match the icecast server settings for the source, hit the tape recorder icon, then hit the broadcast tower icon. hit the broadcast tower icon again either after a few minutes or immediately (doesn't matter which) and you will get the same error above. It doesn't matter if anything is playing or not within Traktor.The problem is present when Traktor disconnects from the server.


This was a known bug that was fixed in 2.3.3-kh11-15-gbfe7ba4 and later versions. This biggest problem is that this port is over 3.5 years out of date. the current latest is 2.4.0-kh10 as of 05/27/18.

If we can get this port updated to the latest version, this issue will most likely be solved.

See the bug at the github site for the project below:
https://github.com/karlheyes/icecast-kh/issues/103
Comment 1 Samy Mahmoudi 2018-08-27 13:47:49 UTC
Created attachment 196596 [details]
Patch file generated with svn diff

Hi,

• Update to 2.4.0-kh10
• Patch src/auth_cmd.c to include signal.h unconditionally *
• Replace conditional structures with options helpers
• Add missing optional dependencies
• Regenerate patch files
• Reindent Makefile
• Bump PORTREVISION

* https://github.com/karlheyes/icecast-kh/pull/230
Comment 2 Samy Mahmoudi 2018-08-27 13:49:55 UTC
Created attachment 196597 [details]
Patch file generated with svn diff
Comment 3 Samy Mahmoudi 2018-08-27 13:57:41 UTC
Please note that you will probably need to set DEFAULT_VERSIONS+=ssl=openssl in your /etc/make.conf to be able to build the updated icecast-kh.
Comment 4 Samy Mahmoudi 2018-08-29 12:11:26 UTC
Created attachment 196676 [details]
Patch file generated with svn diff

The upstream modification I have suggested conflicts with an older pull request. I made the appropriate changes and requested a second pull.

• Update to 2.4.0-kh10
• Patch src/auth_cmd.c to include signal.h unconditionally *
• Replace conditional structures with options helpers
• Add missing optional dependencies
• Regenerate patch files
• Reindent Makefile
• Bump PORTREVISION

* https://github.com/karlheyes/icecast-kh/pull/231
Comment 5 Tobias Kortkamp freebsd_committer 2018-08-29 14:24:10 UTC
Comment on attachment 196676 [details]
Patch file generated with svn diff

Please revert all the bogus indentation changes (let DISTVERSIONPREFIX
and the options helpers be the odd lines out, not everything has to be
aligned to them).  They obscure the actual changes and make this harder
to read and review.
Comment 6 Samy Mahmoudi 2018-08-29 15:52:37 UTC
Created attachment 196681 [details]
Patch file generated with svn diff

Done ;-)

• Update to 2.4.0-kh10
• Patch src/auth_cmd.c to include signal.h unconditionally *
• Replace conditional structures with options helpers
• Add missing optional dependencies
• Regenerate patch files
• Bump PORTREVISION

* https://github.com/karlheyes/icecast-kh/pull/231
Comment 7 commit-hook freebsd_committer 2018-12-07 13:09:09 UTC
A commit references this bug:

Author: tobik
Date: Fri Dec  7 13:08:52 UTC 2018
New revision: 486860
URL: https://svnweb.freebsd.org/changeset/ports/486860

Log:
  audio/icecast-kh: Update to 2.4.0-kh10

  - Convert to options helpers
  - Drop incidental variables
  - Reset maintainer due to the long timeout

  Changes:	https://raw.githubusercontent.com/karlheyes/icecast-kh/icecast-2.4.0-kh10/NEWS
  PR:		230814
  Reported by:	shon@misproductions.com
  Submitted by:	Samy Mahmoudi <samy.mahmoudi@gmail.com> (based on)
  Approved by:	anes@anes.su (maintainer timeout, > 3 months)

Changes:
  head/audio/icecast-kh/Makefile
  head/audio/icecast-kh/distinfo
  head/audio/icecast-kh/files/patch-src_auth__cmd.c
  head/audio/icecast-kh/pkg-plist
Comment 8 Tobias Kortkamp freebsd_committer 2018-12-07 13:12:42 UTC
(In reply to Samy Mahmoudi from comment #6)
> Regenerate patch files

If the original patches apply fine to the new version (i.e., the patch context
is still good enough), best leave this out to not cause pointless churn.

Anyway, committed with some additional changes.  In case you want
to become the new maintainer, let me know here.  Thanks!
Comment 9 commit-hook freebsd_committer 2018-12-07 13:40:35 UTC
A commit references this bug:

Author: tobik
Date: Fri Dec  7 13:40:18 UTC 2018
New revision: 486861
URL: https://svnweb.freebsd.org/changeset/ports/486861

Log:
  audio/icecast-kh: Revert last minute PORTNAME changes and fix build

  ===> Checking for items in STAGEDIR missing from pkg-plist
  Error: Orphaned: share/icecast/admin/listclients.xsl

  - Also install icecast.xml.sample with @sample

  PR:		230814
  Pointy hat to:	tobik

Changes:
  head/audio/icecast-kh/Makefile
  head/audio/icecast-kh/pkg-plist