Bug 231299 - databases/p5-DBD-mysql: Does not compile with MariaDB 10.1
Summary: databases/p5-DBD-mysql: Does not compile with MariaDB 10.1
Status: Closed DUPLICATE of bug 231271
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Sunpoet Po-Chuan Hsieh
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-09-11 10:42 UTC by Sascha Holzleiter
Modified: 2018-09-11 18:55 UTC (History)
0 users

See Also:
bugzilla: maintainer-feedback? (perl)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Sascha Holzleiter 2018-09-11 10:42:31 UTC
Hi,

after the update to 4.047 the port doesn't compile with MariaDB installed:

--- dbdimp.o ---
dbdimp.c:1910:56: error: invalid token at start of a preprocessor expression
#if (MYSQL_VERSION_ID >= 50723) && (MYSQL_VERSION_ID < MARIADB_BASE_VERSION)
                                                       ^
/usr/local/include/mysql/mysql_version.h:16:31: note: expanded from macro 'MARIADB_BASE_VERSION'
#define MARIADB_BASE_VERSION            "mariadb-10.1"
                                        ^
dbdimp.c:1917:56: error: invalid token at start of a preprocessor expression
#if (MYSQL_VERSION_ID >= 50600) && (MYSQL_VERSION_ID < MARIADB_BASE_VERSION)
                                                       ^
/usr/local/include/mysql/mysql_version.h:16:31: note: expanded from macro 'MARIADB_BASE_VERSION'
#define MARIADB_BASE_VERSION            "mariadb-10.1"


Full poudriere log at: https://pkgs.blumenschaender.de/data/112amd64-default-desk/2018-09-11_04h09m16s/logs/errors/p5-DBD-mysql-4.047.log

There is already a bug report open upstream: https://github.com/perl5-dbi/DBD-mysql/issues/262 

The code in question was introduced with commit f4b0004ea5422ed724a252be07731f0bd8c24c79.

I'm not quite sure what the author had in mind here and there is also no MARIADB equivalent to MYSQL_VERSION_ID in /usr/local/include/mysql/mysql_version.h. So i've not come up with a workaround, yet.
Comment 1 Sunpoet Po-Chuan Hsieh freebsd_committer 2018-09-11 18:55:54 UTC

*** This bug has been marked as a duplicate of bug 231271 ***