Bug 231324 - archivers/liblz4: Update to v1.8.3
Summary: archivers/liblz4: Update to v1.8.3
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: Steve Wills
URL: https://github.com/lz4/lz4/blob/v1.8....
Keywords: patch
Depends on:
Blocks:
 
Reported: 2018-09-12 09:49 UTC by Martin Waschbüsch
Modified: 2018-09-18 15:10 UTC (History)
1 user (show)

See Also:


Attachments
Update to latest v1.8.3 (1.21 KB, patch)
2018-09-12 09:49 UTC, Martin Waschbüsch
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Martin Waschbüsch 2018-09-12 09:49:30 UTC
Created attachment 197048 [details]
Update to latest v1.8.3

Update to latest v1.8.3
Comment 1 Martin Waschbüsch 2018-09-12 09:51:02 UTC
portlint: OK
poudriere testport (on amd64 / 11.2-RELEASE): OK
Comment 2 Nathan 2018-09-12 11:41:54 UTC
Recheck build as when I tried this it gave plist error saying orphaned file share/man/man1... because seems man dir location in update changed. Changed MAKE_ARGS=   MANDIR=${MANDIRS} 
Worked for me
Comment 3 Nathan 2018-09-12 11:43:18 UTC
(In reply to Nathan from comment #2)
On side note did test this port with LLD for i386 when it gets released and it built for me with LLD enabled
Comment 4 Martin Waschbüsch 2018-09-12 12:29:15 UTC
(In reply to Nathan from comment #3)

I do not get any error concerning man pages on install or remove.
Same for:

make check-orphans
...
====> Compressing man pages (compress-man)
====> Running Q/A tests (stage-qa)
====> Checking for pkg-plist issues (check-plist)
===> Parsing plist
===> Checking for items in STAGEDIR missing from pkg-plist
===> Checking for items in pkg-plist which are not in STAGEDIR
===> No pkg-plist issues found (check-plist)
Comment 5 Nathan 2018-09-13 03:58:21 UTC
(In reply to Martin Waschbüsch from comment #4)
Seems you're right. Jails was messed up and worked for me after fixing them
Comment 6 commit-hook freebsd_committer 2018-09-18 15:09:39 UTC
A commit references this bug:

Author: swills
Date: Tue Sep 18 15:09:11 UTC 2018
New revision: 480030
URL: https://svnweb.freebsd.org/changeset/ports/480030

Log:
  archivers/liblz4: Update to v1.8.3

  PR:		231324
  Submitted by:	Martin Waschb?sch <martin@waschbuesch.de> (maintainer)

Changes:
  head/archivers/liblz4/Makefile
  head/archivers/liblz4/distinfo
  head/archivers/liblz4/pkg-plist
Comment 7 Steve Wills freebsd_committer 2018-09-18 15:10:00 UTC
Committed, thanks!