docker-compose should be renamed to py-docker-compose according to current naming convention.
(py27-docker-compose and py36-docker-compose)
Hi! This port already generates a package for each version of Python.
In this case it's docker-compose and docker-compose-py36 by default.
Since it's an utility and not a library, suffix is acceptable and
might make it easier to discover.
Can you explain the motivation for this change please?
The motivation is to use a straightforward naming convention in ports.
If a port requires Python as a basic programming language it should in the ports name not matter if it's a library or tool (e.g. py-certbot, py-iocage). That makes it much easier to keep stuff together using own mirrors and when using orchestration tools you can easily choose your corresponding Python version.
(I don't want to start a general discussion but as soon as py3 finally becomes standard Python version the packages must be renamed again "tool vs tool-py27". Using orchestration upgrading "tool" will then automatically install Python3.x.).
It's an enhancement request, not a bug. Just close this ticket if you disagree.
Seems rejected, can we close here?