Bug 231430 - 'Fatal trap 9: general protection fault while in kernel mode' when rebooting after installkernel on VirtualBox VM
Summary: 'Fatal trap 9: general protection fault while in kernel mode' when rebooting ...
Status: Closed FIXED
Alias: None
Product: Base System
Classification: Unclassified
Component: kern (show other bugs)
Version: CURRENT
Hardware: amd64 Any
: --- Affects Only Me
Assignee: freebsd-virtualization (Nobody)
URL:
Keywords: crash
Depends on:
Blocks:
 
Reported: 2018-09-17 14:17 UTC by Yasuhiro KIMURA
Modified: 2018-10-10 08:11 UTC (History)
2 users (show)

See Also:


Attachments
Screenshot when updating from ALPHA3 to ALPHA4 (35.10 KB, image/png)
2018-09-17 14:17 UTC, Yasuhiro KIMURA
no flags Details
Screenshot when updating from ALPHA4 to ALPHA5 (35.58 KB, image/png)
2018-09-17 14:27 UTC, Yasuhiro KIMURA
no flags Details
Screenshot when updating from ALPHA5 to ALPHA6 (35.21 KB, image/png)
2018-09-18 17:51 UTC, Yasuhiro KIMURA
no flags Details
Screenshot when updating from ALPHA6 to ALPHA7 (35.20 KB, image/png)
2018-09-21 21:01 UTC, Yasuhiro KIMURA
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Yasuhiro KIMURA 2018-09-17 14:17:19 UTC
Created attachment 197171 [details]
Screenshot when updating from ALPHA3 to ALPHA4

I'm tracking head with VirtualBox VM. Every time new snapshot is released I update to same revision. So buildworld, buildkernel and installkernel always complete sucsessfully. But when rebooting system always crashes with 'Fatal trap 9: general protection fault while in kernel mode' message. And if I closed VM window and restart VM, new kernel start up without any problem.

Attached PNG file is a screenshot when updating from ALPHA3 to ALPHA4.

Conditions about VM and host are following:

VM:
  CPU: x4
  Memory: 8GB
  Disk: 100GB SATA
Host:
  CPU: Intel Core i7 4770S
  Memory: 16GB
  Disk: 2TB SATA
  OS: 64bit Windows 10 Enterprise 1803
  VirualBox: 5.2.18
Comment 1 Yasuhiro KIMURA 2018-09-17 14:27:57 UTC
Created attachment 197172 [details]
Screenshot when updating from ALPHA4 to ALPHA5

Attached PNG file is screenshot when updating from ALPHA4 to ALPHA5. Backtrace is added according to advice of Mark Johnston(markj@freebsd.org).
Comment 2 Yasuhiro KIMURA 2018-09-18 17:51:29 UTC
Created attachment 197211 [details]
Screenshot when updating from ALPHA5 to ALPHA6

Attached file is screenshot when updating from ALPHA5 to ALPHA6.
Comment 3 Yasuhiro KIMURA 2018-09-21 21:01:02 UTC
Created attachment 197321 [details]
Screenshot when updating from ALPHA6 to ALPHA7

Attached PNG file is screenshot when updating from ALPHA6 to ALPHA7.
Comment 4 Vladimir Kondratyev freebsd_committer 2018-09-21 21:56:07 UTC
Looks like duplicate of PR/227784
Comment 5 Mark Millard 2018-09-22 01:11:30 UTC
(In reply to Yasuhiro KIMURA from comment #0)

My amd64 FreeBSD is in a Virtual Box on macOS on a MacBookPro.
I build FreeBSD from source and have been updating as 12 went
through the ALPHA*'s and before. I do have virtualbox-ose-additions
built and installed that I've been keeping up to date in the VM
image, currently:

# pkg info virtualbox-ose-additions
virtualbox-ose-additions-5.2.18_1
Name           : virtualbox-ose-additions
Version        : 5.2.18_1
Installed on   : Sat Sep 15 13:50:41 2018 PDT
Origin         : emulators/virtualbox-ose-additions
Architecture   : FreeBSD:12:amd64
Prefix         : /usr/local
Categories     : emulators kld
Licenses       : GPLv2
Maintainer     : vbox@FreeBSD.org
WWW            : http://www.virtualbox.org/
Comment        : VirtualBox additions for FreeBSD guests
Options        :
	DBUS           : on
	DEBUG          : off
	OPENGL         : off
	X11            : on
. . .

(I'm not actively using X11 despite the option.)


I've not had any problems with shutdown -r now after
installs.

This suggests needing to figure out what contributes to
having the problem vs. not having it. I've no clue at this
point.

Sometimes I'm synchronized to a version between ALPHAs. All
have behaved just fine for installing updates and rebooting.
Comment 6 Mark Millard 2018-09-22 01:12:39 UTC
(In reply to Mark Millard from comment #5)

My context is strictly UFS based, no ZFS.
Comment 7 Yasuhiro KIMURA 2018-09-29 23:05:10 UTC
While updating from ALPHA7 to ALPHA8, reboot succeeded without crash. So this problem may be resolved. But just in case I would like to wait next update to check if crash doesn't happen before closing this problem report.
Comment 8 Yasuhiro KIMURA 2018-10-10 08:11:24 UTC
(In reply to Yasuhiro KIMURA from comment #7)

While updating from ALPHA8 to ALPHA9 reboot succeeded without crash again. So I conclude the problem is fixed and close this bug report.