Bug 231729 - graphics/colord: Add polkit build option
Summary: graphics/colord: Add polkit build option
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: Steve Wills
URL:
Keywords: easy, feature, needs-qa
: 250533 (view as bug list)
Depends on:
Blocks:
 
Reported: 2018-09-26 10:36 UTC by Ali Abdallah
Modified: 2021-01-17 19:41 UTC (History)
5 users (show)

See Also:
koobs: merge-quarterly?


Attachments
Add option for building with/without polkit (1.11 KB, patch)
2018-09-26 10:36 UTC, Ali Abdallah
no flags Details | Diff
updated patch (1.14 KB, patch)
2020-12-16 15:09 UTC, Steve Wills
swills: maintainer-approval? (kwm)
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Ali Abdallah 2018-09-26 10:36:40 UTC
Created attachment 197504 [details]
Add option for building with/without polkit
Comment 1 Ali Abdallah 2018-10-31 12:17:52 UTC
Could you please apply the attached patch? colord is only one package that pull out the badly designed polkit as a dependency on my setup.
Comment 2 Walter Schwarzenfeld freebsd_triage 2019-08-08 02:30:37 UTC
ping!
Comment 3 Ali Abdallah 2020-06-04 08:47:10 UTC
Ping, any way to get this patch included?
Comment 4 Kubilay Kocak freebsd_committer freebsd_triage 2020-06-26 09:01:00 UTC
Hi Ali,

Does the present patch still apply against ports head?
Comment 5 Steve Wills freebsd_committer 2020-12-16 15:09:53 UTC
Created attachment 220621 [details]
updated patch
Comment 6 Steve Wills freebsd_committer 2020-12-16 15:10:16 UTC
*** Bug 250533 has been marked as a duplicate of this bug. ***
Comment 7 commit-hook freebsd_committer 2021-01-17 19:39:40 UTC
A commit references this bug:

Author: swills
Date: Sun Jan 17 19:38:45 UTC 2021
New revision: 561864
URL: https://svnweb.freebsd.org/changeset/ports/561864

Log:
  graphics/colord: Add polkit build option

  PR:		231729
  Submitted by:	Ali Abdallah <ali.abdallah@suse.com> (previous version)
  Approved by:	maintainer timeout (kwm, >1 month)

Changes:
  head/graphics/colord/Makefile
Comment 8 Steve Wills freebsd_committer 2021-01-17 19:41:31 UTC
Committed, thanks!