Bug 231864 - textproc/docbook.xsl causes net/samba48 to fail if build with MANDOC option is set.
Summary: textproc/docbook.xsl causes net/samba48 to fail if build with MANDOC option i...
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: Sunpoet Po-Chuan Hsieh
URL:
Keywords:
: 233288 (view as bug list)
Depends on:
Blocks:
 
Reported: 2018-10-01 18:52 UTC by ddrinnon
Modified: 2018-11-18 23:13 UTC (History)
4 users (show)

See Also:
bugzilla: maintainer-feedback? (timur)


Attachments
svn-diff-docbook-lib.xsl (1.77 KB, application/xslt+xml)
2018-10-15 12:49 UTC, Walter Schwarzenfeld
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description ddrinnon 2018-10-01 18:52:33 UTC
net/samba48 fails to build if MANDOC option is enabled.

Tail end of build log from Poudriere:

runtime error: file file:///usr/local/share/xsl/docbook/lib/lib.xsl line 58 element choose
xsltApplySequenceConstructor: A potential infinite template recursion was detected.
You can adjust xsltMaxDepth (--maxdepth) in order to raise the maximum number of nested template calls and variables/params (currently set to 3000).
Templates:
#0 name string.subst 
#1 name string.subst 
#2 name string.subst 
#3 name string.subst 
#4 name string.subst 
#5 name string.subst 
#6 name string.subst 
#7 name string.subst 
#8 name string.subst 
#9 name string.subst 
#10 name string.subst 
#11 name string.subst 
#12 name string.subst 
#13 name string.subst 
#14 name string.subst 
Variables:
#0
replacement 
target 
string 
#1
target 
string 
#2
string 
#3
replacement 
target 
string 
#4
target 
string 
#5
string 
#6
replacement 
target 
string 
#7
target 
string 
#8
string 
#9
replacement 
target 
string 
#10
target 
string 
#11
string 
#12
replacement 
target 
string 
#13
target 
string 
#14
string 
error: file default/docs-xml/manpages/smb.conf.5.xml
xsltRunStylesheet : run failed
Waf: Leaving directory `/wrkdirs/usr/ports/net/samba48/work/samba-4.8.5/bin'
Build failed:  -> task failed (err #11): 
	{task: manpages/smb.conf.5 smb.conf.5.xml,parameters.all.xml -> smb.conf.5}
*** Error code 1

Stop.
make: stopped in /usr/ports/net/samba48

Config options:
OPTIONS_FILE_SET+=ADS
OPTIONS_FILE_SET+=AD_DC
OPTIONS_FILE_SET+=AESNI
OPTIONS_FILE_UNSET+=CLUSTER
OPTIONS_FILE_SET+=CUPS
OPTIONS_FILE_UNSET+=DEBUG
OPTIONS_FILE_UNSET+=DEVELOPER
OPTIONS_FILE_SET+=DOCS
OPTIONS_FILE_SET+=FAM
OPTIONS_FILE_UNSET+=GPGME
OPTIONS_FILE_SET+=LDAP
OPTIONS_FILE_SET+=MANDOC
OPTIONS_FILE_UNSET+=NTVFS
OPTIONS_FILE_SET+=PROFILE
OPTIONS_FILE_SET+=QUOTAS
OPTIONS_FILE_UNSET+=SPOTLIGHT
OPTIONS_FILE_SET+=SYSLOG
OPTIONS_FILE_SET+=UTMP
OPTIONS_FILE_SET+=GSSAPI_BUILTIN
OPTIONS_FILE_UNSET+=GSSAPI_MIT
OPTIONS_FILE_UNSET+=NSUPDATE
OPTIONS_FILE_UNSET+=BIND911
OPTIONS_FILE_UNSET+=MDNSRESPONDER
OPTIONS_FILE_UNSET+=AVAHI
Comment 1 Oleg Sidorkin 2018-10-15 12:06:59 UTC
Looks like docbook-xsl bug: https://forums.funtoo.org/topic/1257-samba-installation-fails-due-to-manpage/

Proposed patch was upstreamed. docbook-xsl development moved to github, so SF mirror is quite outdated
Comment 2 Walter Schwarzenfeld freebsd_triage 2018-10-15 12:49:58 UTC
Created attachment 198173 [details]
svn-diff-docbook-lib.xsl

Confirm, this patch is working.
Comment 3 Oleg Sidorkin 2018-10-15 13:00:58 UTC
(In reply to w.schwarzenfeld from comment #2)

Should this bug to be reassigned to sunpoet@ since docbook-xsl is under his maintainership?
Comment 4 Walter Schwarzenfeld freebsd_triage 2018-10-15 13:06:29 UTC
I added sunpoet to the CC-List.
Comment 5 Walter Schwarzenfeld freebsd_triage 2018-10-15 13:11:38 UTC
Change it, I think so it is better.
Comment 6 commit-hook freebsd_committer 2018-11-18 22:50:22 UTC
A commit references this bug:

Author: timur
Date: Sun Nov 18 22:49:46 UTC 2018
New revision: 485287
URL: https://svnweb.freebsd.org/changeset/ports/485287

Log:
  Incorporate fix from Debian/Fedora for the deep recursion while expanding.

  PR:		231864
  Approved by:	maintainer timeout

Changes:
  head/textproc/docbook-xsl/Makefile
  head/textproc/docbook-xsl/files/
  head/textproc/docbook-xsl/files/docbook-style-xsl-non-recursive-string-subst.patch
Comment 7 Timur I. Bakeyev freebsd_committer 2018-11-18 23:12:06 UTC
*** Bug 233288 has been marked as a duplicate of this bug. ***
Comment 8 Timur I. Bakeyev freebsd_committer 2018-11-18 23:13:20 UTC
Committed, thanks!