Bug 232183 - www/firefox: r481071 of Mk/bsd.gecko.mk inhibits the use of ccache by absolute pathnames
Summary: www/firefox: r481071 of Mk/bsd.gecko.mk inhibits the use of ccache by absolut...
Status: Closed DUPLICATE of bug 224471
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: freebsd-gecko mailing list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-10-11 18:01 UTC by Trond.Endrestol
Modified: 2019-08-16 15:41 UTC (History)
3 users (show)

See Also:
bugzilla: maintainer-feedback? (gecko)


Attachments
Patch for Mk/bsd.gecko.mk removing absolute pathnames for CC, CPP, and CXX (707 bytes, patch)
2018-10-11 18:01 UTC, Trond.Endrestol
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Trond.Endrestol 2018-10-11 18:01:20 UTC
Created attachment 198041 [details]
Patch for Mk/bsd.gecko.mk removing absolute pathnames for CC, CPP, and CXX

The use of absolute pathnames for CC, CPP, and CXX, inhibits the use of ccache and further more erects new ccaches in ${WRKDIR}/.cache, rendering a central ccache like /root/.ccache or /var/cache/ccache useless. See attached patch.
Comment 1 Charlie Li 2018-10-11 20:22:37 UTC
This has the exact same aims as my bug 224471. Only MOZ_OPTIONS+=--with-ccache needs specified in order to use ccache, which when enabled, calls ccache directly in front of the exact compiler paths. This is done with a conditional checking whether WITH_CCACHE_BUILD is enabled in a user's make.conf (or otherwise enabled in poudriere).

Hang on, I've an updated patch that fixes my muffed conditional that was in the patch before; been using this privately for quite some time now...
Comment 2 Nuno Teixeira 2018-11-23 09:07:52 UTC
I've tested both patches on FreeBSD 11.2 RELEASE, poudriere 3.2.8, ports current:

- removing absolute pathnames does't work, ccache not called

- using --with-ccache works, cccache caches ok.

Conclusion:

To have ccache working within poudriere, we just need patch:

.if ${WITH_CCACHE_BUILD}
MOZ_OPTIONS+=     --with-ccache
.endif.

I not tested build outside poudriere.
Comment 3 Trond.Endrestol 2018-11-23 09:25:25 UTC
(In reply to Nuno Teixeira from comment #2)
I failed to mention I have /usr/local/libexec/ccache prepended to PATH.
Comment 4 Trond.Endrestol 2018-11-23 09:28:44 UTC
(In reply to Trond.Endrestol from comment #3)
Telling configure to use ccache when requested is better than not doing anything.
Comment 5 Walter Schwarzenfeld freebsd_triage 2019-08-16 14:49:10 UTC
*** Bug 224471 has been marked as a duplicate of this bug. ***
Comment 6 Walter Schwarzenfeld freebsd_triage 2019-08-16 15:41:34 UTC

*** This bug has been marked as a duplicate of bug 224471 ***