Bug 232308 - lang/python27,35+: Remove MAKE_JOBS_UNSAFE
Summary: lang/python27,35+: Remove MAKE_JOBS_UNSAFE
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: Kubilay Kocak
URL: https://reviews.freebsd.org/D17579
Keywords: easy
: 228173 (view as bug list)
Depends on:
Blocks:
 
Reported: 2018-10-16 06:43 UTC by Kubilay Kocak
Modified: 2018-12-23 02:04 UTC (History)
4 users (show)

See Also:
koobs: maintainer-feedback+
koobs: merge-quarterly+


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Kubilay Kocak freebsd_committer freebsd_triage 2018-10-16 06:43:50 UTC
lang/python27,35+: Remove MAKE_JOBS_UNSAFE

ports r393217 via bug 200622 [1] originally set MAKE_JOBS_UNSAFE=yes due to
incorrect uses of recursive make [2], causing intermittent build failures when 
run with multiple jobs (-jN).

Upstream committed a fix for the issue in default (3.6, at the time), 3.5 and
2.7 which are now contained in all released lang/python?? port versions. 3.4 did
not receieve a backport merge.

lang/python3.5+ ports inadvertently inherited MAKE_JOBS_UNSAFE=yes, via
repocopies from lang/python34 on their creation, when they were infact safe to
use with -j.

Remove MAKE_JOBS_UNSAFE in all lang/python?? except python34 ports accordingly.

[1] https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=200622
[2] https://bugs.python.org/issue22359
Comment 1 commit-hook freebsd_committer 2018-10-17 06:24:04 UTC
A commit references this bug:

Author: koobs
Date: Wed Oct 17 06:24:00 UTC 2018
New revision: 482271
URL: https://svnweb.freebsd.org/changeset/ports/482271

Log:
  lang/python27,35+: Remove MAKE_JOBS_UNSAFE

  ports r393217 via bug 200622 [1] originally set MAKE_JOBS_UNSAFE=yes due to
  incorrect uses of recursive make [2], causing intermittent build failures when
  run with multiple jobs (-jN).

  Upstream committed a fix for the issue in default (3.6, at the time), 3.5 and
  2.7 which are now contained in all released lang/python?? port versions. 3.4 did
  not receieve a backport merge.

  lang/python3.5+ ports inadvertently inherited MAKE_JOBS_UNSAFE=yes, via
  repocopies from lang/python34 on their creation, when they were infact safe to
  use with -j.

  Remove MAKE_JOBS_UNSAFE in all lang/python?? ports except python34 accordingly.

  [1] https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=200622
  [2] https://bugs.python.org/issue22359

  PR:		232308
  Reported by:	cem
  Reviewed by:	cem
  Approved by:	koobs (python)
  MFH:		2018Q4
  Differential Revision:	D17579

Changes:
  head/lang/python27/Makefile
  head/lang/python35/Makefile
  head/lang/python36/Makefile
  head/lang/python37/Makefile
Comment 2 commit-hook freebsd_committer 2018-10-19 03:06:17 UTC
A commit references this bug:

Author: koobs
Date: Fri Oct 19 03:06:00 UTC 2018
New revision: 482401
URL: https://svnweb.freebsd.org/changeset/ports/482401

Log:
  MFH: r482271 lang/python27,35+: Remove MAKE_JOBS_UNSAFE

  ports r393217 via bug 200622 [1] originally set MAKE_JOBS_UNSAFE=yes due to
  incorrect uses of recursive make [2], causing intermittent build failures when
  run with multiple jobs (-jN).

  Upstream committed a fix for the issue in default (3.6, at the time), 3.5 and
  2.7 which are now contained in all released lang/python?? port versions. 3.4 did
  not receieve a backport merge.

  lang/python3.5+ ports inadvertently inherited MAKE_JOBS_UNSAFE=yes, via
  repocopies from lang/python34 on their creation, when they were infact safe to
  use with -j.

  Remove MAKE_JOBS_UNSAFE in all lang/python?? ports except python34 accordingly.

  [1] https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=200622
  [2] https://bugs.python.org/issue22359

  PR:		232308
  Reported by:	cem
  Reviewed by:	cem
  Approved by:	koobs (python)
  Differential Revision:	D17579

  Approved by:	portmgr (miwi)

Changes:
_U  branches/2018Q4/
  branches/2018Q4/lang/python27/Makefile
  branches/2018Q4/lang/python35/Makefile
  branches/2018Q4/lang/python36/Makefile
  branches/2018Q4/lang/python37/Makefile
Comment 3 Kubilay Kocak freebsd_committer freebsd_triage 2018-10-19 03:08:24 UTC
Committed/merged, thanks for the heads up & reminder Conrad
Comment 4 Kubilay Kocak freebsd_committer freebsd_triage 2018-12-23 02:04:18 UTC
*** Bug 228173 has been marked as a duplicate of this bug. ***