Bug 232360 - Shared object "libdl.so.1" not found, required by "vim"
Summary: Shared object "libdl.so.1" not found, required by "vim"
Status: Closed Works As Intended
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: amd64 Any
: --- Affects Only Me
Assignee: Tobias Kortkamp
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-10-17 15:15 UTC by Gerd
Modified: 2019-05-31 04:32 UTC (History)
2 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Gerd 2018-10-17 15:15:23 UTC
After updateing:
FreeBSD ah-customers 11.1-RELEASE FreeBSD 11.1-RELEASE #0 r321309: Fri Jul 21 02:08:28 UTC 2017     root@releng2.nyi.freebsd.org:/usr/obj/usr/src/sys/GENERIC  amd64

I have three FreeBSD machines and I see this error on two of them, I updated all three the same way.

I have no idea what is going on there.
Comment 1 Tobias Kortkamp freebsd_committer 2018-10-21 15:27:57 UTC
(In reply to Gerd from comment #0)
FreeBSD 11.1 is no longer supported since September 30, 2018 and packages
are now built for FreeBSD 11.2 which has libdl.so.

Please update to FreeBSD 11.2.
Comment 2 ishtar@lethe.ca 2018-10-29 16:34:11 UTC
Alternatively, building from source does not have this problems even on 11.x.
Comment 3 Slawomir Wojciech Wojtczak 2019-05-30 08:51:46 UTC
My buddy had the same problem with 'node' package on 11.1.

Copying the /usr/lib/libdl.so.1 from FreeBSD 11.2 system to that 11.1 system into the same /usr/lib/libdl.so.1 place helped.

Its VERY unsupported solution so its better upgrade then do that but when really fast (not best) solution is needed - then it works too.

Regards,
vermaden