Bug 232906 - databases/mariadb103-server fails to install with tokudb option enabled due to pkg-plist conflict
Summary: databases/mariadb103-server fails to install with tokudb option enabled due t...
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: Bernard Spil
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-11-02 11:02 UTC by Oleg Sidorkin
Modified: 2018-11-26 16:13 UTC (History)
1 user (show)

See Also:
bugzilla: maintainer-feedback? (brnrd)


Attachments
drop man/man1/tokuft_logprint.1.gz from mariadb103-client pkg-plist not to clash with mariadb103-server (543 bytes, patch)
2018-11-02 11:02 UTC, Oleg Sidorkin
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Oleg Sidorkin 2018-11-02 11:02:48 UTC
Created attachment 198884 [details]
drop man/man1/tokuft_logprint.1.gz from mariadb103-client pkg-plist not to clash with mariadb103-server

man/man1/tokuft_logprint.1.gz is installed by databases/mariadb103-client unconditionally and also is installed by databases/mariadb103-server with tokudb option enabled.


Proposed patch removes it from databases/mariadb103-client so file is installed by 
databases/mariadb103-server only.
Comment 1 commit-hook freebsd_committer 2018-11-10 14:12:36 UTC
A commit references this bug:

Author: brnrd
Date: Sat Nov 10 14:11:46 UTC 2018
New revision: 484613
URL: https://svnweb.freebsd.org/changeset/ports/484613

Log:
  databases/mariadb103-server: Remove XTRADB option

   - The XtraDB engine was removed from 10.3
   - Fix plist conflict for TOKUDB option [1]

  PR:		232906 [1]
  Submitted by:	Oleg Sidorkin <osidorkin gmail com>

Changes:
  head/databases/mariadb103-client/pkg-plist
  head/databases/mariadb103-server/Makefile
  head/databases/mariadb103-server/pkg-plist
Comment 2 Dries Michiels freebsd_committer 2018-11-10 15:42:45 UTC
Hi I get build/link errors after this revision not sure if related.

[ 85%] Building CXX object storage/federated/CMakeFiles/federated.dir/ha_federated.cc.o
cd /construction/xports/databases/mariadb103-server/work/mariadb-10.3.10/storage/federated && /usr/bin/c++  -DHAVE_CONFIG_H -DMYSQL_DYNAMIC_PLUGIN -Dfederated_EXPORTS -I/construction/xports/databases/mariadb103-server/work/mariadb-10.3.10/include -I/construction/xports/databases/mariadb103-server/work/mariadb-10.3.10/sql -I/construction/xports/databases/mariadb103-server/work/mariadb-10.3.10/pcre -I/usr/local/include -O2 -pipe -fstack-protector -isystem /usr/local/include -fno-strict-aliasing  -isystem /usr/local/include -Wl,-z,relro,-z,now -fstack-protector --param=ssp-buffer-size=4 -fno-rtti -O2 -pipe -fstack-protector -isystem /usr/local/include -fno-strict-aliasing  -isystem /usr/local/include -D_FORTIFY_SOURCE=2 -DDBUG_OFF -fPIC -o CMakeFiles/federated.dir/ha_federated.cc.o -c /construction/xports/databases/mariadb103-server/work/mariadb-10.3.10/storage/federated/ha_federated.cc
c++: warning: -Wl,-z,relro,-z,now: 'linker' input unused [-Wunused-command-line-argument]
--- extra/mariabackup/CMakeFiles/mariabackup.dir/all ---
/usr/bin/ld: error: undefined symbol: fil_system
>>> referenced by xtrabackup.cc
>>>               CMakeFiles/mariabackup.dir/xtrabackup.cc.o:(mdl_lock_all())
/usr/bin/ld: error: undefined symbol: srv_undo_space_id_start
>>> referenced by xtrabackup.cc
>>>               CMakeFiles/mariabackup.dir/xtrabackup.cc.o:(mdl_lock_all())
/usr/bin/ld: error: undefined symbol: srv_undo_tablespaces_open
>>> referenced by xtrabackup.cc
>>>               CMakeFiles/mariabackup.dir/xtrabackup.cc.o:(mdl_lock_all())
/usr/bin/ld: error: undefined symbol: ut_dbg_assertion_failed(char const*, char const*, unsigned int)
>>> referenced by xtrabackup.cc
>>>               CMakeFiles/mariabackup.dir/xtrabackup.cc.o:(filename_to_spacename(unsigned char const*, unsigned long))
/usr/bin/ld: error: undefined symbol: ut_dbg_assertion_failed(char const*, char const*, unsigned int)
>>> referenced by xtrabackup.cc
>>>               CMakeFiles/mariabackup.dir/xtrabackup.cc.o:(filename_to_spacename(unsigned char const*, unsigned long))
/usr/bin/ld: error: undefined symbol: ut_dbg_assertion_failed(char const*, char const*, unsigned int)
>>> referenced by xtrabackup.cc
>>>               CMakeFiles/mariabackup.dir/xtrabackup.cc.o:(filename_to_spacename(unsigned char const*, unsigned long))
/usr/bin/ld: error: undefined symbol: ut_dbg_assertion_failed(char const*, char const*, unsigned int)
>>> referenced by xtrabackup.cc
>>>               CMakeFiles/mariabackup.dir/xtrabackup.cc.o:(filename_to_spacename(unsigned char const*, unsigned long))
/usr/bin/ld: error: undefined symbol: srv_undo_tablespaces
>>> referenced by xtrabackup.cc
>>>               CMakeFiles/mariabackup.dir/xtrabackup.cc.o:(xb_get_one_option(int, my_option const*, char*))
/usr/bin/ld: error: undefined symbol: srv_undo_dir
>>> referenced by xtrabackup.cc
>>>               CMakeFiles/mariabackup.dir/xtrabackup.cc.o:(xb_get_one_option(int, my_option const*, char*))
/usr/bin/ld: error: undefined symbol: srv_log_group_home_dir
>>> referenced by xtrabackup.cc
>>>               CMakeFiles/mariabackup.dir/xtrabackup.cc.o:(xb_get_one_option(int, my_option const*, char*))
/usr/bin/ld: error: undefined symbol: srv_file_flush_method
>>> referenced by xtrabackup.cc
>>>               CMakeFiles/mariabackup.dir/xtrabackup.cc.o:(xb_get_one_option(int, my_option const*, char*))
/usr/bin/ld: error: undefined symbol: srv_file_flush_method
>>> referenced by xtrabackup.cc
>>>               CMakeFiles/mariabackup.dir/xtrabackup.cc.o:(xb_get_one_option(int, my_option const*, char*))
/usr/bin/ld: error: undefined symbol: innodb_flush_method_names
>>> referenced by xtrabackup.cc
>>>               CMakeFiles/mariabackup.dir/xtrabackup.cc.o:(xb_get_one_option(int, my_option const*, char*))
/usr/bin/ld: error: undefined symbol: srv_checksum_algorithm
>>> referenced by xtrabackup.cc
>>>               CMakeFiles/mariabackup.dir/xtrabackup.cc.o:(xb_get_one_option(int, my_option const*, char*))
/usr/bin/ld: error: undefined symbol: srv_checksum_algorithm
>>> referenced by xtrabackup.cc
>>>               CMakeFiles/mariabackup.dir/xtrabackup.cc.o:(xb_get_one_option(int, my_option const*, char*))
/usr/bin/ld: error: undefined symbol: innodb_checksum_algorithm_names
>>> referenced by xtrabackup.cc
>>>               CMakeFiles/mariabackup.dir/xtrabackup.cc.o:(xb_get_one_option(int, my_option const*, char*))
/usr/bin/ld: error: undefined symbol: ut_dbg_assertion_failed(char const*, char const*, unsigned int)
>>> referenced by xtrabackup.cc
>>>               CMakeFiles/mariabackup.dir/xtrabackup.cc.o:(xb_get_one_option(int, my_option const*, char*))
/usr/bin/ld: error: undefined symbol: ut_dbg_assertion_failed(char const*, char const*, unsigned int)
>>> referenced by xtrabackup.cc
>>>               CMakeFiles/mariabackup.dir/xtrabackup.cc.o:(xb_get_one_option(int, my_option const*, char*))
/usr/bin/ld: error: undefined symbol: os_event_reset(os_event*)
>>> referenced by xtrabackup.cc
>>>               CMakeFiles/mariabackup.dir/xtrabackup.cc.o:(xtrabackup_io_throttling())
/usr/bin/ld: error: undefined symbol: os_event_wait_low(os_event*, long)
>>> referenced by xtrabackup.cc
>>>               CMakeFiles/mariabackup.dir/xtrabackup.cc.o:(xtrabackup_io_throttling())
/usr/bin/ld: error: too many errors emitted, stopping now (use -error-limit=0 to see all errors)
--- storage/connect/CMakeFiles/connect.dir/all ---
--- storage/connect/CMakeFiles/connect.dir/mycat.cc.o ---
[ 85%] Building CXX object storage/connect/CMakeFiles/connect.dir/mycat.cc.o
--- extra/mariabackup/CMakeFiles/mariabackup.dir/all ---
c++: error: linker command failed with exit code 1 (use -v to see invocation)
*** [extra/mariabackup/mariabackup] Error code 1

make[3]: stopped in /construction/xports/databases/mariadb103-server/work/mariadb-10.3.10
1 error

make[3]: stopped in /construction/xports/databases/mariadb103-server/work/mariadb-10.3.10
*** [extra/mariabackup/CMakeFiles/mariabackup.dir/all] Error code 2

make[2]: stopped in /construction/xports/databases/mariadb103-server/work/mariadb-10.3.10
--- storage/connect/CMakeFiles/connect.dir/all ---
cd /construction/xports/databases/mariadb103-server/work/mariadb-10.3.10/storage/connect && /usr/bin/c++  -DFORCE_INIT_OF_VARS -DGZ_SUPPORT -DHAVE_CONFIG_H -DHUGE_SUPPORT -DLIBXML2_SUPPORT -DLINUX -DMARIADB -DMYSQL_DYNAMIC_PLUGIN -DNOCRYPT -DODBC_SUPPORT -DUBUNTU -DUNIX -DVCT_SUPPORT -DXMAP -DZIP_SUPPORT -Dconnect_EXPORTS -I/construction/xports/databases/mariadb103-server/work/mariadb-10.3.10/include -I/construction/xports/databases/mariadb103-server/work/mariadb-10.3.10/sql -I/construction/xports/databases/mariadb103-server/work/mariadb-10.3.10/pcre -I/usr/local/include -I/usr/local/include/libxml2 -O2 -pipe -fstack-protector -isystem /usr/local/include -fno-strict-aliasing  -isystem /usr/local/include -Wl,-z,relro,-z,now -fstack-protector --param=ssp-buffer-size=4 -fno-rtti -Wall -Wmissing-declarations -Wno-unused-function -Wno-unused-variable -Wno-unused-value -Wno-parentheses -Wno-strict-aliasing -Wno-implicit-fallthrough -fpermissive -fexceptions -fPIC  -O2 -pipe -fstack-protector -isystem /usr/local/include -fno-strict-aliasing  -isystem /usr/local/include -D_FORTIFY_SOURCE=2 -DDBUG_OFF -fPIC -o CMakeFiles/connect.dir/mycat.cc.o -c /construction/xports/databases/mariadb103-server/work/mariadb-10.3.10/storage/connect/mycat.cc
c++: warning: -Wl,-z,relro,-z,now: 'linker' input unused [-Wunused-command-line-argument]
A failure has been detected in another branch of the parallel make

make[3]: stopped in /construction/xports/databases/mariadb103-server/work/mariadb-10.3.10
*** [storage/connect/CMakeFiles/connect.dir/all] Error code 2

make[2]: stopped in /construction/xports/databases/mariadb103-server/work/mariadb-10.3.10
--- storage/federated/CMakeFiles/federated.dir/all ---
A failure has been detected in another branch of the parallel make

make[3]: stopped in /construction/xports/databases/mariadb103-server/work/mariadb-10.3.10
*** [storage/federated/CMakeFiles/federated.dir/all] Error code 2

make[2]: stopped in /construction/xports/databases/mariadb103-server/work/mariadb-10.3.10
3 errors

make[2]: stopped in /construction/xports/databases/mariadb103-server/work/mariadb-10.3.10
*** [all] Error code 2

make[1]: stopped in /construction/xports/databases/mariadb103-server/work/mariadb-10.3.10
1 error

make[1]: stopped in /construction/xports/databases/mariadb103-server/work/mariadb-10.3.10
===> Compilation failed unexpectedly.
Comment 3 Bernard Spil freebsd_committer 2018-11-10 21:57:57 UTC
(In reply to Dries Michiels from comment #2)
This PR is fixed, please open a new one for other problems. I think you're running into https://jira.mariadb.org/browse/MDEV-17560 which I couldn't reproduce myself. Do you build in poudriere?
Comment 4 commit-hook freebsd_committer 2018-11-26 16:13:23 UTC
A commit references this bug:

Author: brnrd
Date: Mon Nov 26 16:13:16 UTC 2018
New revision: 485944
URL: https://svnweb.freebsd.org/changeset/ports/485944

Log:
  MFH: r484613 r484810 r485783

  databases/mariadb103-server: Remove XTRADB option

   - The XtraDB engine was removed from 10.3
   - Fix plist conflict for TOKUDB option [1]

  PR:		232906 [1]
  Submitted by:	Oleg Sidorkin <osidorkin gmail com>

  databases/mariadb103-server: Fix linking issue

   - Link issues when INNOBASE is set to DYNAMIC [1]
   - While here, remove MDEV-14072 fix

  [1]: https://jira.mariadb.org/browse/MDEV-17560

  PR:		233135
  Submitted by:	Ralf van der Enden <tremere cainites net>
  Reported by:	Dries Michiels <driesm michiels gmail com>

  databases/mariadb103-server: Security update to 10.3.11

   - Add workaround for LZ4, SNAPPY build issues [1]

  PR:		233212 [1]
  Reported by:	Peter Putzer <freebsd mnd sc>
  Security:	ec5072b0-d43a-11e8-a6d2-b499baebfeaf

  Approved by:	ports-secteam (miwi)

Changes:
_U  branches/2018Q4/
  branches/2018Q4/databases/mariadb103-client/pkg-plist
  branches/2018Q4/databases/mariadb103-server/Makefile
  branches/2018Q4/databases/mariadb103-server/distinfo
  branches/2018Q4/databases/mariadb103-server/pkg-plist