Bug 232929 - biology/bowtie fails to build with GCC 8
Summary: biology/bowtie fails to build with GCC 8
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: Jason W. Bacon
URL:
Keywords:
Depends on:
Blocks: 231590
  Show dependency treegraph
 
Reported: 2018-11-03 12:34 UTC by Gerald Pfeifer
Modified: 2018-11-04 14:23 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Gerald Pfeifer freebsd_committer 2018-11-03 12:34:33 UTC
biology/bowtie has the following bit

  # FIXME: bowtie-align intermittently dumps core when compiled with clang
  # GCC 4.2 does not provide good performance
  USE_GCC=        yes

alas it now fails to build with GCC 8, blocking the update of the default
version of GCC.

Cf. http://package22.nyi.freebsd.org/data/112amd64-default-PR231590/2018-10-29_06h48m05s/logs/errors/bowtie-1.1.2_6.log

ebwt.h: In member function 'uint32_t* Ebwt<TStr>::isa() const':
ebwt.h:863:44: error: cannot convert 'TIndexOffU* const' {aka 'long unsigned int* const'} to 'uint32_t*' {aka 'unsigned int*'} in return
  uint32_t*   isa() const          { return _isa; } /* check */
                                            ^~~~


How about retiring this port in favor of biology/bowtie2 ?
Comment 1 Jason W. Bacon freebsd_committer 2018-11-03 21:06:34 UTC
We generally want to avoid removing scientific ports unless they become very difficult to maintain, since researchers may need to reproduce results years after the initial analysis, e.g. for grant renewals.  There's a simple workaround for this one, which I'll commit shortly,
Comment 2 commit-hook freebsd_committer 2018-11-03 23:25:08 UTC
A commit references this bug:

Author: jwb
Date: Sat Nov  3 23:24:30 UTC 2018
New revision: 483954
URL: https://svnweb.freebsd.org/changeset/ports/483954

Log:
  biology/bowtie: Patch for gcc8 and clean up

  PR:             232929
  Reported by:    gerald
  Approved by:    jrm (mentor, implicit)

Changes:
  head/biology/bowtie/Makefile
  head/biology/bowtie/files/patch-ebwt.h
Comment 3 Gerald Pfeifer freebsd_committer 2018-11-04 11:06:29 UTC
(In reply to Jason W. Bacon from comment #1)
> We generally want to avoid removing scientific ports unless they become
> very difficult to maintain, since researchers may need to reproduce results
> years after the initial analysis, e.g. for grant renewals.  There's a simple
> workaround for this one, which I'll commit shortly,

Thank you, Jason! That was quick. :-) 

And the explanation on keeping the original version of bowtie in
addition to bowtie2 does make sense.

(You haven't closed the PR yet, so I'll just move it to "In Progress"
based on your commit.)
Comment 4 Jason W. Bacon freebsd_committer 2018-11-04 14:23:08 UTC
Tested with USE_GCC=8.  Should be OK now.