Bug 232933 - devel/xtensa-esp32-elf fails to build with GCC 8 (and is years outdated)
Summary: devel/xtensa-esp32-elf fails to build with GCC 8 (and is years outdated)
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: Craig Leres
URL:
Keywords:
Depends on:
Blocks: 231590
  Show dependency treegraph
 
Reported: 2018-11-03 14:03 UTC by Gerald Pfeifer
Modified: 2018-11-04 11:01 UTC (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Gerald Pfeifer freebsd_committer 2018-11-03 14:03:24 UTC
Cf. http://package22.nyi.freebsd.org/data/112amd64-default-PR231590/2018-10-29_06h48m05s/logs/errors/xtensa-esp32-elf-1.22.0.g20171219_2.log

[INFO ]  Installing pass-2 core C gcc compiler
[ERROR]    /wrkdirs/usr/ports/devel/xtensa-esp32-elf/work/crosstool-NG-1.22.0-80-g6c4433a5/.build/src/gcc-5.2.0/gcc/wide-int.h:370:10: error: too many template-parameter-lists
[ERROR]    /wrkdirs/usr/ports/devel/xtensa-esp32-elf/work/crosstool-NG-1.22.0-80-g6c4433a5/.build/src/gcc-5.2.0/gcc/wide-int.h:377:10: error: too many template-parameter-lists
[ERROR]    /wrkdirs/usr/ports/devel/xtensa-esp32-elf/work/crosstool-NG-1.22.0-80-g6c4433a5/.build/src/gcc-5.2.0/gcc/wide-int.h:384:10: error: too many template-parameter-lists


This also is based on a major version of GCC long out of maintenance
(GCC 5, and even GCC 6 isn't maintained any more), so perhaps best
simply deprecate and remove the port?
Comment 1 Craig Leres freebsd_committer 2018-11-04 00:41:25 UTC
I've tested USE_GCC=7 and will commit change that soon.

Regarding obsolete gcc versions, Kyle Evans provide a great answer last time
this came up:

On 5/22/18 3:56 AM, Kyle Evans wrote:
> This is kind of a crosstool-NG/vendor thing -- they maintain a stable
> set of versions that they've confirmed works correctly for the target
> platform in question, and they move ahead a little more
> cautiously/slowly then the rest of us might because they have to
> consider correctness, size, and speed with each toolchain upgrade.

For example openvehicles.com depends on this version of the toolchain (which is why I created the port in the first place). This toolchain can also be used to build esp32/arduino sketches.
Comment 2 commit-hook freebsd_committer 2018-11-04 02:02:06 UTC
A commit references this bug:

Author: leres
Date: Sun Nov  4 02:01:11 UTC 2018
New revision: 483956
URL: https://svnweb.freebsd.org/changeset/ports/483956

Log:
  Pin to gcc7 and unblock 231590 which wants to update GCC_DEFAULT
  from 7 to 8.

  PR:		232933
  Reported by:	Gerald Pfeifer
  Approved by:	ler (mentor, implicit)

Changes:
  head/devel/xtensa-esp32-elf/Makefile
Comment 3 Gerald Pfeifer freebsd_committer 2018-11-04 11:01:12 UTC
(In reply to Craig Leres from comment #1)
> I've tested USE_GCC=7 and will commit change that soon.

Thank you, Craig!

> Regarding obsolete gcc versions, Kyle Evans provide a great answer last time
> this came up:

Fair enough, though GCC 5.2 is reaaally rather old by now (even
within the GCC 5 series) so there may be problems we'll be running
into later on, even with USE_GCC=7.