Bug 232981 - multimedia/libva-intel-driver: enable HYBRID by default
Summary: multimedia/libva-intel-driver: enable HYBRID by default
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Jan Beich
URL:
Keywords: needs-qa, patch
Depends on: 233259
Blocks:
  Show dependency treegraph
 
Reported: 2018-11-05 12:02 UTC by Jan Beich
Modified: 2018-11-17 13:36 UTC (History)
3 users (show)

See Also:
madpilot: maintainer-feedback+


Attachments
v1 (1.09 KB, patch)
2018-11-05 12:02 UTC, Jan Beich
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Jan Beich freebsd_committer 2018-11-05 12:02:48 UTC
Created attachment 198962 [details]
v1

Allow binary package users to benefit from Hybrid decoding. It gracefully falls back to software decoding if not supported or remains unused if hardware proper support.
Comment 1 Jan Beich freebsd_committer 2018-11-05 12:40:02 UTC
Can someone on x11@ list check for regressions? For example,

$ mpv --no-config --hwdec=vaapi --ytdl-format='bestvideo[height<=2160][vcodec=vp9]+bestaudio' 'https://www.youtube.com/watch?v=1La4QzGeaaQ'

- SandyBridge, IvyBridge don't support hybrid decoding. VP9 decoding should be in software while H264 in hardware.
- Haswell, Broadwell, Skylake should use hybrid VP9 decoding for 8bit streams with resulotion up to 2160p. Expect CPU usage to drop by ~50%.
- Kabylake or newer shouldn't use hybrid decoding because VP9 is supported natively.
Comment 2 rkoberman 2018-11-06 06:18:29 UTC
Testing on Sandy Bridge with hybrid works fine, though does report:
/usr/local/lib/dri/hybrid_drv_video.so init failed
Not using hybrid_drv_video.so
AO: [oss] 48000Hz stereo 2ch s32
[ffmpeg/video] vp9: No support for codec vp9 profile 0.

I assume that this is expected. Video plays cleanly, though it uses all CPU and does not play smoothly.
Comment 3 Jan Beich freebsd_committer 2018-11-06 09:53:42 UTC
(In reply to rkoberman from comment #2)
> Video plays cleanly, though it uses all CPU and does not play smoothly.

Please, also check H264 or whatever previously decoded on hardware (SandyBridge) still does.
Comment 4 rkoberman 2018-11-06 16:32:05 UTC
Sorry. I should have included that a "standard" 1080p HD video plays fine at about 55% CPU as apposed to 390% without acceleration, so it looks good.
Comment 5 Guido Falsi freebsd_committer 2018-11-06 21:28:17 UTC
I tested it on my laptop which is a little old.

Like rkoberman it works in software and the video stutters.

Anyway I approve the change since it does not break anything.
Comment 6 commit-hook freebsd_committer 2018-11-07 22:41:20 UTC
A commit references this bug:

Author: jbeich
Date: Wed Nov  7 22:40:28 UTC 2018
New revision: 484415
URL: https://svnweb.freebsd.org/changeset/ports/484415

Log:
  multimedia/libva-intel-driver: enable HYBRID by default

  PR:		232981
  Approved by:	madpilot (maintainer)
  Tested by:	Kevin Oberman, madpilot

Changes:
  head/multimedia/libva-intel-driver/Makefile