Bug 232995 - [dtrace] failed to establish error handler
Summary: [dtrace] failed to establish error handler
Status: Closed DUPLICATE of bug 232675
Alias: None
Product: Base System
Classification: Unclassified
Component: bin (show other bugs)
Version: CURRENT
Hardware: amd64 Any
: --- Affects Many People
Assignee: freebsd-bugs mailing list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-11-05 16:43 UTC by mikhail.rokhin
Modified: 2018-11-06 01:36 UTC (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description mikhail.rokhin 2018-11-05 16:43:03 UTC
at CURRENT amd64 (rv 340151)

# dtrace -h
dtrace: failed to establish error handler: "/usr/lib/dtrace/ip.d", line 112: failed to copy typedef in6_addr_t source type: Type information is in parent and unavailable

leading to failure at perl5.26.2 compilation with dtrace option "on"
Comment 1 mikhail.rokhin 2018-11-05 18:47:16 UTC
and after reboot it changed to

# dtrace -h
dtrace: failed to establish error handler: "/usr/lib/dtrace/psinfo.d", line  39: failed to copy type of 'pr_uid' : Type information is in parent and unavailable

There was no such problem when FBSD CURRENT version was 12 (it's changed to 13 recently).
Comment 2 Mark Johnston freebsd_committer 2018-11-06 01:36:37 UTC

*** This bug has been marked as a duplicate of bug 232675 ***