Bug 233202 - net-mgmt/librenms: Fix build with EXAMPLES disabled
Summary: net-mgmt/librenms: Fix build with EXAMPLES disabled
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Muhammad Moinur Rahman
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-11-13 15:27 UTC by Luca Pizzamiglio
Modified: 2018-12-16 17:40 UTC (History)
0 users

See Also:
bugzilla: maintainer-feedback? (bofh)


Attachments
The fixing patch (945 bytes, patch)
2018-11-13 15:27 UTC, Luca Pizzamiglio
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Luca Pizzamiglio freebsd_committer 2018-11-13 15:27:32 UTC
Created attachment 199210 [details]
The fixing patch

Currently, the build fails if EXAMPLES option is disabled.

The root cause is the missing directories /var/log/librenms and /var/log/librenms.

The attached patch should solve the issue.
Comment 1 commit-hook freebsd_committer 2018-12-16 17:38:28 UTC
A commit references this bug:

Author: bofh
Date: Sun Dec 16 17:37:53 UTC 2018
New revision: 487604
URL: https://svnweb.freebsd.org/changeset/ports/487604

Log:
  net-mgmtt/librenms: Fix build with EXAMPLES disabled

  - Pet portlint

  PR:			233202
  Submitted by:		pizzamig

Changes:
  head/net-mgmt/librenms/Makefile