Bug 233215 - [amdtemp] Explore further temperature sensors on 17h
Summary: [amdtemp] Explore further temperature sensors on 17h
Status: New
Alias: None
Product: Base System
Classification: Unclassified
Component: kern (show other bugs)
Version: CURRENT
Hardware: amd64 Any
: --- Affects Some People
Assignee: freebsd-bugs (Nobody)
URL:
Keywords:
Depends on: 228480
Blocks:
  Show dependency treegraph
 
Reported: 2018-11-14 04:09 UTC by Conrad Meyer
Modified: 2018-11-14 04:10 UTC (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Conrad Meyer freebsd_committer 2018-11-14 04:09:45 UTC
> It seem to show the correct temperature but only for one core. If I attached the
> device to Data Fabric Function 3 pci id 0x15eb, which is suggested to be the correct
> way described here:
> https://patchwork.kernel.org/patch/10381565/
> I get 4 temperatures in dev.cpu, however they're all 0.
>
> Maybe some offset that is not correct.
>
> ...
> The motherboard is ASRock A320M-HDV.
> ...
> CPU: AMD Ryzen 3 2200G with Radeon Vega Graphics     (3493.51-MHz K8-class CPU)
>  Origin="AuthenticAMD"  Id=0x810f10  Family=0x17  Model=0x11  Stepping=0


+++ This bug was initially created as a clone of Bug #228480 +++

# pciconf -lv
...
hostb6@pci0:0:24:3:	class=0x060000 card=0x00000000 chip=0x15eb1022 rev=0x00 hdr=0x00
    vendor     = 'Advanced Micro Devices, Inc. [AMD]'
    class      = bridge
    subclass   = HOST-PCI
...