Bug 233269 - devel/boost-libs: boost_mpi is missing
Summary: devel/boost-libs: boost_mpi is missing
Status: New
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: freebsd-office mailing list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-11-17 05:58 UTC by Yuri Victorovich
Modified: 2019-02-12 06:28 UTC (History)
1 user (show)

See Also:
bugzilla: maintainer-feedback? (office)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Yuri Victorovich freebsd_committer 2018-11-17 05:58:31 UTC
This CMakeLists.txt
> list(APPEND BOOST_COMPONENTS mpi serialization filesystem system)
> find_package(Boost "1.53.0" REQUIRED ${BOOST_COMPONENTS})
fails:
> CMake Error at /usr/local/share/cmake/Modules/FindBoost.cmake:2049 (message):
>   Unable to find the requested Boost libraries.
>   Boost version: 1.68.0
>   Boost include path: /usr/local/include
>   Could not find the following Boost libraries:
>           boost_mpi

I'm not sure if mpi should be in devel/boost-libs itself, or it should be a separate port.
Comment 1 w.schwarzenfeld freebsd_triage 2019-02-12 06:23:26 UTC
We have Version 1.69.0_1. I think this issue is solved.
Comment 2 Yuri Victorovich freebsd_committer 2019-02-12 06:28:23 UTC
(In reply to w.schwarzenfeld from comment #1)

No, it's not solved.