Bug 233274 - databases/mariadb102-server: Fails to build with SNAPPY option enabled
Summary: databases/mariadb102-server: Fails to build with SNAPPY option enabled
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Bernard Spil
URL:
Keywords:
: 233212 (view as bug list)
Depends on:
Blocks:
 
Reported: 2018-11-17 16:01 UTC by Dave Bendit
Modified: 2018-11-24 19:40 UTC (History)
3 users (show)

See Also:
bugzilla: maintainer-feedback? (brnrd)


Attachments
Proposed patch to re-add fix from 221159 (721 bytes, patch)
2018-11-17 16:14 UTC, Dave Bendit
david: maintainer-approval? (brnrd)
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Dave Bendit 2018-11-17 16:01:21 UTC
The exact same issue that was reported in https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=221159 is happening again. Revision https://svnweb.freebsd.org/ports?view=revision&revision=484896 removes the Makefile changes that were added in https://svnweb.freebsd.org/changeset/ports/452143 to fix the issue originally, and now the same build issue is back. Manually adding in the Makefile change from the original changeset fixes the issue for me.
Comment 1 Dave Bendit 2018-11-17 16:14:40 UTC
Created attachment 199295 [details]
Proposed patch to re-add fix from 221159
Comment 2 commit-hook freebsd_committer 2018-11-18 09:05:07 UTC
A commit references this bug:

Author: brnrd
Date: Sun Nov 18 09:04:30 UTC 2018
New revision: 485219
URL: https://svnweb.freebsd.org/changeset/ports/485219

Log:
  databases/mariadb102-server: Fix build with compression

   - Re-add workaround for link issues [1] with
     compression options

  [1]: https://jira.mariadb.org/browse/MDEV-14072

  PR:		233274
  Submitted by:	Dave Bendit <david ibendit com>
  MFH:		2018Q4

Changes:
  head/databases/mariadb102-server/Makefile
Comment 3 Bernard Spil freebsd_committer 2018-11-18 09:23:11 UTC
Thanks for reporting and supplying the patch Dave!

Dunno why this workaround works, but options are broken without it...
Comment 4 commit-hook freebsd_committer 2018-11-24 19:37:45 UTC
A commit references this bug:

Author: brnrd
Date: Sat Nov 24 19:36:57 UTC 2018
New revision: 485787
URL: https://svnweb.freebsd.org/changeset/ports/485787

Log:
  MFH: r485219

  databases/mariadb102-server: Fix build with compression

   - Re-add workaround for link issues [1] with
     compression options

  [1]: https://jira.mariadb.org/browse/MDEV-14072

  PR:		233274
  Submitted by:	Dave Bendit <david ibendit com>

  Approved by:	ports-secteam (miwi)

Changes:
_U  branches/2018Q4/
  branches/2018Q4/databases/mariadb102-server/Makefile
Comment 5 Bernard Spil freebsd_committer 2018-11-24 19:40:02 UTC
*** Bug 233212 has been marked as a duplicate of this bug. ***