Bug 233281 - IP forwarding clarification in rc.conf man-page
Summary: IP forwarding clarification in rc.conf man-page
Status: Closed Works As Intended
Alias: None
Product: Documentation
Classification: Unclassified
Component: Manual Pages (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Many People
Assignee: freebsd-bugs mailing list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-11-17 23:43 UTC by peos42
Modified: 2019-05-26 02:03 UTC (History)
3 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description peos42 2018-11-17 23:43:56 UTC
Hi

I am new to FreeBSD but have used BSD since 20 years back…

In the man-page for rc.conf I can see…

—snip--
ipv6_gateway_enable
                (bool) The IPv6 equivalent of gateway_enable.
—snip—

and…

—snip--
 gateway_enable
                (bool) If set to "YES", configure host to act as an IP
                router, e.g. to forward packets between interfaces.
—snip—


If this is equal to set net.inet6.ip6.forwarding=1 in sysctl.conf it would for clarification be a good thing to mention in the man-page for rc.conf that this is an alternate way of setting this sysctl setting. A simple small parentesis containing "Equal to set net.inet6.ip6.forwarding=1 in sysctl.conf" would be good.
Comment 1 Andrey V. Elsukov freebsd_committer 2018-11-19 09:55:33 UTC
AFAIR, they are not equal. devd can reapply network configuration on some events, and if you have not *gateway_enable option in rc.conf, you will lost your gateway, because sysctl.conf does not applied in the same time.
Comment 2 Allan Jude freebsd_committer 2019-05-26 02:03:35 UTC
They are not equivalent, gateway_enable="YES" is a superset of net.inet.ip.forwarding=1