Bug 233472 - shells/bash STATIC does not compile after upgrade from 11-STABLE to 12-STABLE
Summary: shells/bash STATIC does not compile after upgrade from 11-STABLE to 12-STABLE
Status: Closed Overcome By Events
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Emanuel Haupt
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-11-24 15:10 UTC by jakub_lach
Modified: 2019-01-11 08:49 UTC (History)
0 users

See Also:
bugzilla: maintainer-feedback? (ehaupt)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description jakub_lach 2018-11-24 15:10:49 UTC
checking for sig_atomic_t in signal.h... yes
checking size of char... Segmentation fault (core dumped)
configure: error: in `/usr/obj/usr/ports/shells/bash/work/bash-4.4':
configure: error: cannot compute sizeof (char)
See `config.log' for more details
===>  Script "configure" failed unexpectedly.

Default version is ok, system is self hosted, other ports recompiled fine.
Comment 1 Emanuel Haupt freebsd_committer 2018-11-25 11:57:05 UTC
Confirmed. I'm trying to isolate the change in base [1] that caused the break.

[1] https://www.freebsd.org/doc/en_US.ISO8859-1/books/porters-handbook/versions-12.html
Comment 2 jakub_lach 2018-11-25 12:25:51 UTC
Thank you for prompt reply :)

For now, I've just added

shells_bash_UNSET=STATIC

to ports.conf.
Comment 3 Emanuel Haupt freebsd_committer 2019-01-07 08:24:42 UTC
I've just tried compiling it on a recent version of 12-STABLE (r342806) and whatever caused the issue seems to be gone. I can't reproduce the compiler error anymore. Can you confirm?
Comment 4 jakub_lach 2019-01-08 00:27:09 UTC
Confirmed on FreeBSD 12.0-STABLE #0 r342683. Thanks!