Bug 233679 - www/firefox 63.0.3_3,1 command line times out with errors
Summary: www/firefox 63.0.3_3,1 command line times out with errors
Status: New
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: amd64 Any
: --- Affects Only Me
Assignee: freebsd-gecko mailing list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-12-01 05:02 UTC by Christopher Hall
Modified: 2018-12-06 03:21 UTC (History)
2 users (show)

See Also:
bugzilla: maintainer-feedback? (gecko)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Christopher Hall 2018-12-01 05:02:14 UTC
After updating Firefox on 2018-11-30 the command line will no longer open an URL. It just times out after a minute with both an error message and an error dialog. This break Firefox integration with all other desktop Apps.

The system is:
  % uname -v
  FreeBSD 11.2-RELEASE-p5 #0: Tue Nov 27 09:33:52 UTC 2018     root@amd64-  builder.daemonology.net:/usr/obj/usr/src/sys/GENERIC

Firefox 63.0.3_3,1 is running and in terminal the following command is entered:

  % time firefox www.hinet.net                    
  JavaScript error: jar:file:///usr/local/lib/firefox/omni.ja!/components/XULStore.js, line 60: Error: Can't find profile directory.
  firefox www.hinet.net  0.62s user 0.30s system 1% cpu 1:03.84 total

Along with above error get the following Dialog:

  Firefox is already running, but is not responding. To open a new
  window, you must first close the existing Firefox process, or restart
  your system.


If close Firefox and revert to older Firefox 63.0.1,1:

  % pkg remove -f firefox
  % pkg add /var/cache/pkg/firefox-63.0.1,1-b9137a62c5.txz

Firefox restarted
Now I can open URLs by command line:

  % time firefox www.hinet.net
  firefox www.hinet.net  0.03s user 0.01s system 22% cpu 0.215 total

A new tab is open very quickly in the running Firefox.
Comment 1 Jan Beich freebsd_committer 2018-12-01 17:10:33 UTC
I can't reproduce. Try
- Run "pkg upgrade" to make sure all dependencies are up to date
- Back up ~/.mozilla, go to about:support and click Refresh Firefox. Alternatively, close Firefox, remove ~/.mozilla directory, start Firefox.
- Update firefox to 64.* (see bug 233028)
Comment 2 Niclas Zeising freebsd_committer 2018-12-02 19:34:38 UTC
Hi!
I'm seeing this issue as well, both with Firefox 63.0.1 abd 63.0.3.  I've tried with a new profile, but the results are the same as with my current profile.
When running firefox from the command line, I also get this message on the command line:
firefox www.cnn.com
JavaScript error: jar:file:///usr/local/lib/firefox/omni.ja!/components/XULStore.js, line 60: Error: Can't find profile directory.

I'm not sure if this is the reason, or a result of the issue.

I'll see if I can give 64 a spin later this week.
Comment 3 Jan Beich freebsd_committer 2018-12-02 19:52:00 UTC
(In reply to Niclas Zeising from comment #2)
What FreeBSD version? If 11.2 again then see ports r480744 or cherry pick base r337975.
Comment 4 Niclas Zeising freebsd_committer 2018-12-02 20:07:46 UTC
(In reply to Jan Beich from comment #3)

This is on Current.

r341394 with Firefox 63.0.3 and r340490 with Firefox 63.0.1
Comment 5 Christopher Hall 2018-12-03 01:46:06 UTC
(In reply to Jan Beich from comment #1)

I tried moving profile away but still the same. Also tried.
 pkg remove firefox
 pkg clean -a
 pkg install firefox 

+ sysctl net.local.stream.recvspace=16384

Still not working

I tried truss looks like it is timing out when waiting for a DBus response:

connect(8,{ AF_UNIX "/tmp/dbus-7mrQAVwt73" },22) = 0 (0x0)
fcntl(8,F_GETFL,)				 = 2 (0x2)
fcntl(8,F_SETFL,O_RDWR|O_NONBLOCK)		 = 0 (0x0)
geteuid()					 = 1001 (0x3e9)
getsockname(8,{ AF_UNIX "" },0x7fffffffda2c)	 = 0 (0x0)
poll({ 8/POLLOUT },1,0)				 = 1 (0x1)
sendmsg(8,{NULL,0,[{"\0",1}],1,{{level=SOL_SOCKET,type=SCM_CREDS,data={0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00}}},104,0},MSG_NOSIGNAL) = 1 (0x1)
sendto(8,"AUTH EXTERNAL 31303031\r\n",24,MSG_NOSIGNAL,NULL,0) = 24 (0x18)
poll({ 8/POLLIN },1,-1)				 = 1 (0x1)
read(8,"OK 76e1075a3ca33ef1de344a3b5c011"...,2048) = 37 (0x25)
poll({ 8/POLLOUT },1,-1)			 = 1 (0x1)
sendto(8,"NEGOTIATE_UNIX_FD\r\n",19,MSG_NOSIGNAL,NULL,0) = 19 (0x13)
poll({ 8/POLLIN },1,-1)				 = 1 (0x1)
read(8,"AGREE_UNIX_FD\r\n",2048)		 = 15 (0xf)
poll({ 8/POLLOUT },1,-1)			 = 1 (0x1)
sendto(8,"BEGIN\r\n",7,MSG_NOSIGNAL,NULL,0)	 = 7 (0x7)
poll({ 8/POLLIN|POLLOUT },1,-1)			 = 1 (0x1)
sendmsg(8,{NULL,0,[{"l\^A\0\^A\0\0\0\0\^A\0\0\0n\0\0"...,128},{0x8027061d0,0}],2,{},0,0},MSG_NOSIGNAL) = 128 (0x80)
poll({ 8/POLLIN },1,25000)			 = 1 (0x1)
recvmsg(8,{NULL,0,[{"l\^B\^A\^A\n\0\0\0\^A\0\0\0=\0\0"...,2048}],1,{},0,0x40000},0x40000) = 260 (0x104)
recvmsg(8,0x7fffffffdac0,0x40000)		 ERR#35 'Resource temporarily unavailable'
__getcwd("/usr/home/hsw",1024)			 = 0 (0x0)
sendmsg(8,{NULL,0,[{"l\^A\0\^A\0\0\0\0\^B\0\0\0r\0\0"...,136},{0x802694a80,0}],2,{},0,0},MSG_NOSIGNAL) = 136 (0x88)
poll({ 8/POLLIN },1,25000)			 = 1 (0x1)
recvmsg(8,{NULL,0,[{"l\^B\^A\^A%\^A\0\0\^C\0\0\0=\0\0"...,2048}],1,{},0,0x40000},0x40000) = 373 (0x175)
recvmsg(8,0x7fffffffd8a0,0x40000)		 ERR#35 'Resource temporarily unavailable'
sendmsg(8,{NULL,0,[{"l\^A\0\^A4\0\0\0\^C\0\0\0\M^H\0"...,152},{"0\0\0\0\^B\0\0\0\^Z\0\0\0"\0\0\0"...,52}],2,{},0,0},MSG_NOSIGNAL) = 204 (0xcc)

-----Waits here----

^Cpoll({ 8/POLLIN },1,25000)			 ERR#4 'Interrupted system call'
Comment 6 Niclas Zeising freebsd_committer 2018-12-04 19:10:37 UTC
Installing Firefox 64 (the version in ports, rc1 I think) after building it with poudriere, seem to have solved the issue for me.
Comment 7 Craig Leres freebsd_committer 2018-12-06 01:04:13 UTC
firefox 64.0 seems to solve this issue for me as well.

Something I noticed is that the problem would eventually clear up like there was some kind of log-jam. Basically I'd occasonally try to open a window via my windows manager (e.g. "firefox &") and I'd get the popup. But after hours I'd try to open a window and *all* of the windows attempted to be opened via the command line would get created.

It'll be awesome if this really is fixed, it was super annoying.
Comment 8 Christopher Hall 2018-12-06 03:21:20 UTC
After Upgrading firefox from 63.0.3_3,1 to 64.0,1...

It is working I have openen URLsfrom several apps and command line without any timeouts.  Hope this issue is now fixed.